Announcement

Collapse
No announcement yet.

MeiHarmonyHub version 3.1.0.10 (Beta) is now available!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MeiHarmonyHub version 3.1.0.10 (Beta) is now available!

    MeiHarmonyHub v3.1.0.10 is now available in the HomeSeer store and in the updater (Beta Section)!

    The following are included:
    • Fixed installing 3.1.0.9 made the plugin disappear from the plugin management screen (doh!)
    PLEASE NOTE THAT i HAVEN'T FULLY TESTED THIS RELEASE FROM MY CODE CLEANUP. I AM RELEASING IT BECAUSE LOGITECH MADE A CHANGE IN THE NEWEST FIRMWARE AND I WANTED TO GET A FIX OUT FAST. THIS IS TRULY BETA. THE MORE PEOPLE THAT TEST THE BETTER.

    Please see the full descriptions here:
    https://forums.homeseer.com/showthread.php?t=194095

    Release notes Here:
    https://forums.homeseer.com/showthread.php?t=194096

    Request new Features Here:
    https://forums.homeseer.com/showthread.php?t=194097
    MeiAutomtion Home

  • #2
    Installed and seems to be working correctly.
    (Now imagine this in Peter Falk's voice) There's just one more thing...
    On the hub management screen, there appears to be a duplicate of each of my hubs.
    Bedroom
    (3f01637b-880a-42b8-0d32-337f45cc50ca)
    192.168.1.28
    LivingRoom
    (46b4cb49-e5ae-42eb-01c2-637bd7e904cc)
    192.168.1.27
    Bedroom
    (8b839c60dc27ae9adad8d66be1cd1087eaeabd0b)
    192.168.1.28
    LivingRoom
    (c9c7d2829a604caecfe366b42a6f22fd2a52846a)
    192.168.1.27
    The first two have all the boxes checked, and the last two have none of the boxes checked. Is it safe to hit the delete button on them?

    Comment


    • #3
      I probably did cause the duplicates by hitting the search button on the prior plugin this morning when it stopped working.

      Comment


      • #4
        They changed the unique identifiers for the hubs....I didn't notice this as the hub I had on .250 was never added to HomeSeer. Crap!

        I'll have to think if there is a way to "map" the new UIDs to the old ones.
        MeiAutomtion Home

        Comment


        • #5
          Tonight, I will try and write a screen so that you transfer an old one to a new one.

          *Edit: Transfer the settings
          MeiAutomtion Home

          Comment


          • #6
            Originally posted by joegr View Post
            The first two have all the boxes checked, and the last two have none of the boxes checked. Is it safe to hit the delete button on them?
            Actually, don't delete the bottom ones yet. I think it's working because the IP is right, but if your IP ever changes it will mess everything up. I'll write a procedure(as I mentioned before) to map the new ones that are all disabled to to the new ones by copying over the UniqueID to the old one. I'll base it off of the IP. I'll try and dynamically add the button in the hubs screen.
            MeiAutomtion Home

            Comment


            • #7
              Okay. No problem. I'll wait.

              Comment


              • #8
                Originally posted by joegr View Post
                Okay. No problem. I'll wait.
                I have a fix that I will release shortly. On startup the plugin will scan for new hubs, if it finds a new hub with another hub that has the same IP, but different UniqueIDs (the new one having to be 40 characters long), then it will replace the UID of the old one with the new one. This way if the IP changes later it should fix it.

                If you happen to add a duplicate hub by using it's IP and it results in a duplicate, next to the OLD one it will have button called "Fix UniqueID". This will do the same thing that is in the discovery process.
                MeiAutomtion Home

                Comment

                Working...
                X