Announcement

Collapse
No announcement yet.

Error Calling HSEvent in plugin & Frequent crashing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • fx12002
    started a topic Error Calling HSEvent in plugin & Frequent crashing

    Error Calling HSEvent in plugin & Frequent crashing

    Hi,

    I am running the plug-in beta version 3.1.0.14 and am frequently getting the following error:
    Mar-13 7:00:00 AM Error Calling HSEvent in plugin MeiHarmonyHub, Instance :Object reference not set to an instance of an object.
    After some time, I will find that the plug-in EXE has crashed (ie on my HS3 computer, it has stopped responding and I need to hit close and it will then re-launch). I am running Windows 7 on a normal Intel based PC. I have several other plug-ins that are running without any issue.

    Would appreciate any help troubleshooting this issue.

    Thank you!

  • sirmeili
    replied
    The HSEvent error is fixed in 3.1.0.15 in the beta section. See if you get the error still and keep debug logging on and if it crashes again, PM me the Logs or post them here (from the file, not from the HS Logs screen).

    Leave a comment:


  • fx12002
    replied
    Just following up on this, thanks.

    Leave a comment:


  • fx12002
    replied
    Hi Frank,

    Sent you the above, thanks!

    Leave a comment:


  • sirmeili
    replied
    Originally posted by fx12002 View Post
    Hi Frank,

    Also getting the following in the log:
    Mar-13 7:49:11 AM Warning Plugin MeiHarmonyHub is not responding but it is still running, not restarting yet.
    And here is a partial copy of a giant debug message in the log (it basically repeats):
    Debug Message for Hub cd3c5b34e3c2c796253542f3a5601f53fcd54b0d: Retrived stored Config: {"activity":[{"suggestedDisplay":"WatchRoku","isAVActivity":true,"labe l": "Watch Roku","id":"23897474","activityTypeDisplayName":"Default","c ontrolGroup":[{"name":"Volume","function":[{"action":"{"command":"Mute","type":"IRCommand","deviceId ":" 41388985"}","name":"Mute","label":"Mute"},{"action":"{"comma nd":"VolumeDown","type":"IRCommand","deviceId":"41388985"} ", "name":"VolumeDown","label":"Volume Down"},{"action":"{"command":"VolumeUp","type":"IRCommand"," deviceId":"41388985"}","name":"VolumeUp","label":"Volume Up"}]},{"name":"NavigationBasic","function":[{"action":"{"command":"DirectionDown","type":"IRCommand", "de viceId":"41388983"}","name":"DirectionDown","label":"Directi on Down"},{"action":"{"command":"DirectionLeft","type":"IRComma nd","deviceId":"41388983"}","name":"DirectionLeft","label" :" Direction Left"},{"action":"{"command":"DirectionRight","type":"IRComm and","deviceId":"41388983"}","name":"DirectionRight","label " :"Direction Right"},{"action":"{"command":"DirectionUp","type":"IRComman d","deviceId":"41388983"}","name":"DirectionUp","label":" Dir ection Up"},{"action":"{"command":"OK","type":"IRCommand","device Id ":"41388983"}","name":"Select","label":"Select"}]},{"name":"TransportBasic","function":[{"action":"{"command":"Play","type":"IRCommand","deviceId ":" 41388983"}","name":"Play","label":"Play"},{"action":"{"comma nd":"Rewind","type":"IRCommand","deviceId":"41388983"}","n am e":"Rewind","label":"Rewind"},{"action":"{"command":"Paus e", "type":"IRCommand","deviceId":"41388983"}","name":"Pause ","l abel":"Pause"},{"action":"{"command":"FastForward","type":"I RCommand","deviceId":"41388983"}","name":"FastForward","labe l":"Fast Forward"}]},{"name":"NavigationDVD","function":[{"action":"{"command":"Back","type":"IRCommand","deviceId ":" 41388983"}","name":"Back","label":"Back"}]},{"name":"Program","function":[{"action":"{"command":"Options*","type":"IRCommand","devi ceI d":"41388983"}","name":"Options","label

    I don't think I am making lots of changes to devices if I am understanding your question correctly. In the Harmony Hub, I have maybe 6 or 7 devices and 9 Sonos speakers. These issues are all happening regardless if anyone is actually using the Harmony remote. For the rest of my system, I don't think it is a large system - maybe 32 Hue bulbs and 15 or so switches/ motion sensors.

    Please let me know if you need more information about any of the above.

    Thank you!
    I meant devices in HomeSeer. Can you turn on the debug logging if you haven't already and just let it run until it crashes again. Then send me the log(s) files? They will be in /Logs/MeiHarmonyHubYYYYMMDD.log where YYYYMMDD will be the date of the files. If it runs more than one day, just send me all the log files from when it starts.

    Also, can you send me the support details from HomeSeer: Tools -> About Homeseer -> Click "Display Details for Support" -> Copy/paste the details in the "Message board" section.

    Thanks,
    Frank

    Leave a comment:


  • fx12002
    replied
    Hi Frank,

    Also getting the following in the log:
    Mar-13 7:49:11 AM Warning Plugin MeiHarmonyHub is not responding but it is still running, not restarting yet.

    And here is a partial copy of a giant debug message in the log (it basically repeats):
    Debug Message for Hub cd3c5b34e3c2c796253542f3a5601f53fcd54b0d: Retrived stored Config: {"activity":[{"suggestedDisplay":"WatchRoku","isAVActivity":true,"label": "Watch Roku","id":"23897474","activityTypeDisplayName":"Default","c ontrolGroup":[{"name":"Volume","function":[{"action":"{"command":"Mute","type":"IRCommand","deviceId":" 41388985"}","name":"Mute","label":"Mute"},{"action":"{"comma nd":"VolumeDown","type":"IRCommand","deviceId":"41388985"}", "name":"VolumeDown","label":"Volume Down"},{"action":"{"command":"VolumeUp","type":"IRCommand"," deviceId":"41388985"}","name":"VolumeUp","label":"Volume Up"}]},{"name":"NavigationBasic","function":[{"action":"{"command":"DirectionDown","type":"IRCommand","de viceId":"41388983"}","name":"DirectionDown","label":"Directi on Down"},{"action":"{"command":"DirectionLeft","type":"IRComma nd","deviceId":"41388983"}","name":"DirectionLeft","label":" Direction Left"},{"action":"{"command":"DirectionRight","type":"IRComm and","deviceId":"41388983"}","name":"DirectionRight","label" :"Direction Right"},{"action":"{"command":"DirectionUp","type":"IRComman d","deviceId":"41388983"}","name":"DirectionUp","label":"Dir ection Up"},{"action":"{"command":"OK","type":"IRCommand","deviceId ":"41388983"}","name":"Select","label":"Select"}]},{"name":"TransportBasic","function":[{"action":"{"command":"Play","type":"IRCommand","deviceId":" 41388983"}","name":"Play","label":"Play"},{"action":"{"comma nd":"Rewind","type":"IRCommand","deviceId":"41388983"}","nam e":"Rewind","label":"Rewind"},{"action":"{"command":"Pause", "type":"IRCommand","deviceId":"41388983"}","name":"Pause","l abel":"Pause"},{"action":"{"command":"FastForward","type":"I RCommand","deviceId":"41388983"}","name":"FastForward","labe l":"Fast Forward"}]},{"name":"NavigationDVD","function":[{"action":"{"command":"Back","type":"IRCommand","deviceId":" 41388983"}","name":"Back","label":"Back"}]},{"name":"Program","function":[{"action":"{"command":"Options*","type":"IRCommand","deviceI d":"41388983"}","name":"Options","label

    I don't think I am making lots of changes to devices if I am understanding your question correctly. In the Harmony Hub, I have maybe 6 or 7 devices and 9 Sonos speakers. These issues are all happening regardless if anyone is actually using the Harmony remote. For the rest of my system, I don't think it is a large system - maybe 32 Hue bulbs and 15 or so switches/ motion sensors.

    Please let me know if you need more information about any of the above.

    Thank you!

    Leave a comment:


  • sirmeili
    replied
    That error shouldn't cause the plugin to crash. I am looking into that error as I think I introduced it in .14. I haven't had it reproduced in my system. Are you making a lot of changes to devices? (even ones not owned by the plugin) .I'm trying to maintain a cache of devices in the plugin for faster displaying of them in triggers and actions. Unfortunately doing it the old way means on systems with lots of devices it can take 3-5 seconds to build the dropdwn and i was trying to speed that up.

    Leave a comment:

Working...
X