Announcement

Collapse
No announcement yet.

HS Not Seeing Activities

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • kwatt
    replied
    I think this may have something to do with it.

    K.
    Click image for larger version

Name:	screenshot.jpg
Views:	92
Size:	15.0 KB
ID:	1333999

    Leave a comment:


  • sirmeili
    replied
    Originally posted by kwatt View Post
    No, sorry been busy too.

    It doesn't appear to see any changes to activities nor send to Harmony when it should do.

    K.
    I'm sure you've done this before, but can you turn on debugging, start a few activities and PM me the logs? I'll do my best to look at them this week and figure it out.

    Leave a comment:


  • kwatt
    replied
    No, sorry been busy too.

    It doesn't appear to see any changes to activities nor send to Harmony when it should do.

    K.

    Leave a comment:


  • sirmeili
    replied
    Originally posted by kwatt View Post
    Was a cure ever found to this as mine is still not working?

    K.
    So the plugin still doesn't see activity changes? But it correctly sets them when you start up the plugin?

    (please note I'll try and check back on this, but work is super crazy right now with me workig 60-80 hour weeks and it's about to get work as we go into our final stretch)

    Leave a comment:


  • kwatt
    replied
    Was a cure ever found to this as mine is still not working?

    K.

    Leave a comment:


  • dennismccreery
    replied
    Finally figured out how to connect and pull the logs. Sent you a link in a PM.

    Regards,

    Dennis

    Leave a comment:


  • sirmeili
    replied
    Originally posted by dennismccreery View Post
    Is there any way to get to these logs via the Homeseer Web UI? Or do I need to connect to the Linux instance?

    Regards,

    Dennis
    You could output to your HS logs, but it makes it really hard for me to go through them. You can use a program like WinSCP to connect to your linux install and grab the logs. You will need credentials for connection to the machine. I'll try and dig up instructions today/tonight.

    Leave a comment:


  • joegr
    replied
    Originally posted by dennismccreery View Post
    Is there any way to get to these logs via the Homeseer Web UI? Or do I need to connect to the Linux instance?

    Regards,

    Dennis
    I use a free plug-in to get to files on my HS machine, but I think it is a windows only plug-in. I don't know of any way just using the HS UI.

    Leave a comment:


  • dennismccreery
    replied
    Is there any way to get to these logs via the Homeseer Web UI? Or do I need to connect to the Linux instance?

    Regards,

    Dennis

    Leave a comment:


  • sirmeili
    replied
    Originally posted by joegr View Post

    Interestingly (or not) in my case the logs are directly at: [hs3InstallPath]/Logs/
    no sub-directory.
    I may have changed that starting with the MeiUnifi plugin to keep the logs directory cleaner for users. My bad.

    Leave a comment:


  • joegr
    replied
    Originally posted by sirmeili View Post
    It logs to [hs3InstallPath]/Logs/MeiHarmonyHub/MeiHarmonyHubYYYYMMDD.log where YYYYMMDD is the date. will be log for each date with a maximum of 10 log files. ...
    Interestingly (or not) in my case the logs are directly at: [hs3InstallPath]/Logs/
    no sub-directory.

    Leave a comment:


  • sirmeili
    replied
    It logs to [hs3InstallPath]/Logs/MeiHarmonyHub/MeiHarmonyHubYYYYMMDD.log where YYYYMMDD is the date. will be log for each date with a maximum of 10 log files. I'll only need the one with the date of the error or at most that one and the day before (in case it spans more than 1 day).

    Leave a comment:


  • dennismccreery
    replied
    Ok, turned HSSentry back off and put the MeiHarmonyHub logging in Debug mode (does it log into the main Homeseer log or somewhere else?) I'll wait for the next incident to see what's in the logs.

    Regards,

    Dennis

    Leave a comment:


  • kwatt
    replied
    Not sure if this is correct but hope it helps.

    K.
    Attached Files

    Leave a comment:


  • sirmeili
    replied
    Originally posted by dennismccreery View Post
    I didn't have it in debug mode when it crashed, and I also didn't have HSSentry turned on. Should I put the whole system in debug logging mode or just the plugin?

    Turned HSSentry on (it was off) and it seems to be working now. Here's a log from the latest crash (before I turned on HSSentry). This section appears to be where the crash occurred, the message "Plugin MeiHarmonyHub is not responding but it is still running, not restarting yet." occurs over and over again as far back as I can go:

    Jun-26 14:38:19 Startup ************************************************************ ********************
    Jun-26 14:38:19 Startup HomeSeer version 3.0.0.534 Edition: HS3 Standard (SEL) Starting Now
    Jun-26 14:38:19 Startup ************************************************************ ********************
    Jun-26 14:38:19 Startup
    Jun-26 14:38:18 Startup Settings Loaded.
    Jun-26 14:38:18 Warning HomeSeer was not shut down successfully the previous time it was started.
    Jun-26 14:38:18 Startup Loading Settings
    Jun-26 08:34:23 Warning Plugin MeiHarmonyHub is not responding but it is still running, not restarting yet.
    Jun-26 08:33:52 Warning Plugin MeiHarmonyHub is not responding but it is still running, not restarting yet.
    Jun-26 08:33:24 Warning Plugin MeiHarmonyHub is not responding but it is still running, not restarting yet.
    Jun-26 08:32:52 Warning Plugin MeiHarmonyHub is not responding but it is still running, not restarting yet.
    I would need the plugin's debug turned on. In the plugin settings you don't need to set the HS Logging level (thats only for logging to the HS logs if you want), you just need to check Debug Logging which logs to file.

    Leave a comment:

Working...
X