Announcement

Collapse
No announcement yet.

Issues connecting to hubs randomly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issues connecting to hubs randomly

    I keep getting the following errors with one hub, wondering if its something hub related or with the plugin?

    I also see occasionally some hubs say "Forcefully Disconnected" but that is random when it happens however still annoying.

    Here are the errors I am seeing currently.
    The Connection to Hub with ID HUB2 failed with stack trace: at System.Net.Sockets.NetworkStream.Write(Byte[] buffer, Int32 offset, Int32 size) at HarmonyHub.Client.Send(String xml)
    Jun-27 10:53:52 AM Error The Connection to Hub with ID HUB1 failed with stack trace: at System.Net.Sockets.NetworkStream.Write(Byte[] buffer, Int32 offset, Int32 size) at HarmonyHub.Client.Send(String xml)
    Jun-27 10:53:52 AM Error The Connection to Hub with ID HUB4 failed with stack trace: at System.Net.Sockets.NetworkStream.Write(Byte[] buffer, Int32 offset, Int32 size) at HarmonyHub.Client.Send(String xml)
    Jun-27 10:53:52 AM Error The Connection to Hub with ID HUB3 failed with stack trace: at System.Net.Sockets.NetworkStream.Write(Byte[] buffer, Int32 offset, Int32 size) at HarmonyHub.Client.Send(String xml)
    Jun-27 10:53:52 AM Error The Connection to Hub with ID HUB4 failed with message: Unable to write data to the transport connection: An existing connection was forcibly closed by the remote host.
    Jun-27 10:53:52 AM Error The Connection to Hub with ID HUB3 failed with message: Unable to write data to the transport connection: An existing connection was forcibly closed by the remote host.
    Jun-27 10:53:52 AM Error The Connection to Hub with ID HUB2 failed with message: Unable to write data to the transport connection: An existing connection was forcibly closed by the remote host.
    Jun-27 10:53:52 AM Error The Connection to Hub with ID HUB1 failed with message: Unable to write data to the transport connection: An existing connection was forcibly closed by the remote host.
    Jun-27 10:47:26 AM Error The Connection to Hub with ID HUB4 failed with stack trace: at HarmonyHub.StreamParser.NextElement(String[] expected) at HarmonyHub.Client.GetSessionToken(String ip, String username, String password, Boolean bypassLogitech) at HarmonyHub.Client.Authenticate() at HarmonyHub.Client.Connect(Int32 heartbeatInterval)
    Jun-27 10:47:26 AM Error The Connection to Hub with ID HUB4 failed with message: Unexpected XML element, expected: challenge, success, failure; received: message; full element: System.Xml.XmlElement

  • #2
    Does the hub reconnect automatically or stay disconnected?

    Are you on Android or iOS for your phone (lets me know a way we can diagnose)?

    Also, are you using any UniFi equipment?
    MeiAutomtion Home

    Comment


    • #3
      I am using Unifi and have auto optimize off as well as allowing multicast as per your instructions in the other post. The hub stays disconnected and as soon as I click connect it will connect without issue then drop a couple days later, seems 2 hubs have this issue more than others. I have Android and my wife uses iPhone.

      Comment


      • #4
        Originally posted by bandrews View Post
        I am using Unifi and have auto optimize off as well as allowing multicast as per your instructions in the other post. The hub stays disconnected and as soon as I click connect it will connect without issue then drop a couple days later, seems 2 hubs have this issue more than others. I have Android and my wife uses iPhone.
        What does your android harmony app say about the hub? When it's disconnects go to the 'switch hubs' option in the app a look if it says 'connect' or 'away'. If it says away then your hub is having issues connecting to your wifi.

        You probably already did, but try a 'reconnect' of your hub in the client list of the Unifi controller. But check the 'away' status in the app first to help diagnose the problem.

        M
        iCore5 Win 10 Pro x64 SSD

        HS3 Pro Edition 3.0.0.435 Windows

        BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

        Comment


        • #5
          Originally posted by mminehan View Post

          What does your android harmony app say about the hub? When it's disconnects go to the 'switch hubs' option in the app a look if it says 'connect' or 'away'. If it says away then your hub is having issues connecting to your wifi.

          You probably already did, but try a 'reconnect' of your hub in the client list of the Unifi controller. But check the 'away' status in the app first to help diagnose the problem.

          M
          Should I be using unify?

          Comment


          • #6
            Originally posted by sirmeili View Post
            Does the hub reconnect automatically or stay disconnected?

            Are you on Android or iOS for your phone (lets me know a way we can diagnose)?

            Also, are you using any UniFi equipment?
            Mine stays disconnected until I restart the plugin. Hitting the connect button just generates more errors.

            Comment


            • #7
              Originally posted by ttantalol View Post

              Mine stays disconnected until I restart the plugin. Hitting the connect button just generates more errors.
              can you turn on debug logging and recreate those errors and post the log?
              MeiAutomtion Home

              Comment


              • #8
                I did post some before but the log gets big then i cant attach it

                Comment


                • #9
                  next time it's disconnected, turn on debug logging, then hit the connect button. You said it generates errors, so they should show up in the logs. Then stop debug logging and post the logs. This should keep the file size down.
                  MeiAutomtion Home

                  Comment

                  Working...
                  X