Announcement

Collapse
No announcement yet.

Getting repeated errors when I go to enable plugin.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • sirmeili
    replied
    Originally posted by logicmax View Post
    I got it working.

    I was first getting an error that there was an unmet dependency in libcairo2. So I ran "sudo apt-get install libcairo2" took a while but finally installed. At which point I tried the "sudo sh mono5_zees2.sh" but again it errored out for unmet dependancy. It looked like it was having trouble installing mono-devel even though that was in the sh script. So i turned off homeseer and tried it manually with "sudo apt-get install mono-devel" at which point it installed properly, even installing mono-complete.

    I then verified the version I was running running "mono --version" and it nurtured with "5.18.1.0". So I rebooted everything started up properly and I was able to enable MeiHarmonyHub without errors.

    Thanks for the help Frank
    awesome! Glad you got it working! Let me know if you run into any other issues.

    Leave a comment:


  • logicmax
    replied
    I got it working.

    I was first getting an error that there was an unmet dependency in libcairo2. So I ran "sudo apt-get install libcairo2" took a while but finally installed. At which point I tried the "sudo sh mono5_zees2.sh" but again it errored out for unmet dependancy. It looked like it was having trouble installing mono-devel even though that was in the sh script. So i turned off homeseer and tried it manually with "sudo apt-get install mono-devel" at which point it installed properly, even installing mono-complete.

    I then verified the version I was running running "mono --version" and it nurtured with "5.18.1.0". So I rebooted everything started up properly and I was able to enable MeiHarmonyHub without errors.

    Thanks for the help Frank

    Leave a comment:


  • sirmeili
    replied
    Ok, yeah, it will be a mono issue. I think some others have done the upgrade and help out. I'll help out as much as I can, but I've never had to do it before.

    Leave a comment:


  • logicmax
    replied
    Looks like I am running Mono 3.2.8. Tried the update method from the first link and it didnt update so going to look through the second link and see what I can figure out.


    Version info:

    Mono JIT compiler version 3.2.8 (Debian 3.2.8+dfsg-4+rpi1)
    Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
    TLS: __thread
    SIGSEGV: normal
    Notifications: epoll
    Architecture: armel,vfp+hard
    Disabled: none
    Misc: softdebug
    LLVM: supported, not enabled.
    GC: sgen

    Leave a comment:


  • sirmeili
    replied
    Chances are you have an older version of Mono installed. YOu willl need to upgrade to Mono 5 for this plugin to work.

    Here is HomeSeer's instructions: https://helpdesk.homeseer.com/articl...date-to-mono-5
    here is another post from another plugin that gives some details on how to check what version is installed: https://forums.homeseer.com/forum/th...er-is-required

    Leave a comment:


  • logicmax
    started a topic Getting repeated errors when I go to enable plugin.

    Getting repeated errors when I go to enable plugin.

    I have the HomeTroller Zee S2 and after installing the plugin I am getting some weird problems. I have tried a few things after reading through many of the forum posts but didnt find anything that matched my problem. I keep getting a Connection failed with message Expected element 'item', but found 'Harmony' in namespace '' error at 1254. I provided a picture of the repeated errors. They show up about once every couple seconds.
    Attached Files
Working...
X