Announcement

Collapse
No announcement yet.

Error when enabling plug in

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error when enabling plug in

    Jul-22 12:52:36 Error The Connection to Hub with ID [snipped ID] failed with stack trace: at System.Net.Sockets.TcpClient..ctor(String hostname, Int32 port) at HarmonyHub.Client.Connect(Int32 heartbeatInterval)
    Jul-22 12:52:36 Error The Connection to Hub with ID [snipped ID] failed with message: No connection could be made because the target machine actively refused it [snipped IP and port]
    Is this related to XMPP? Echo and Google Assistant can control the Harmony Hub just fine.

    Please advise. Thank you.

  • #2
    Do you have XMPP enabled? If not, you'll need it to be enabled. I don't know if Logitech uses XMPP for Google/Alexa, but I doubt it since they tried to kill it the end of last year.

    Normaly that is a network issue (firewall or general wireless issue). The hubs have really crappy wifi in them and I hear they work best on channels 1, 6 and 11. Also, I have heard that a wonky power supply can cause the wifi to be flakey.
    MeiAutomtion Home

    Comment


    • #3
      Originally posted by sirmeili View Post
      Do you have XMPP enabled? If not, you'll need it to be enabled. I don't know if Logitech uses XMPP for Google/Alexa, but I doubt it since they tried to kill it the end of last year.

      Normaly that is a network issue (firewall or general wireless issue). The hubs have really crappy wifi in them and I hear they work best on channels 1, 6 and 11. Also, I have heard that a wonky power supply can cause the wifi to be flakey.
      I will check tonight and reply back. The "machine actively refused..." message is indicating that a network connection was made but the Hub refused to connect?

      Comment


      • #4
        Originally posted by sirmeili View Post
        Do you have XMPP enabled? If not, you'll need it to be enabled. I don't know if Logitech uses XMPP for Google/Alexa, but I doubt it since they tried to kill it the end of last year.

        Normaly that is a network issue (firewall or general wireless issue). The hubs have really crappy wifi in them and I hear they work best on channels 1, 6 and 11. Also, I have heard that a wonky power supply can cause the wifi to be flakey.
        After I enabled XMPP, all was well. Thanks for the support!

        Comment


        • #5
          NP.... glad it worked
          MeiAutomtion Home

          Comment

          Working...
          X