Announcement

Collapse
No announcement yet.

Plugin setup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Plugin setup

    Just got my Harmony and hub. Synced up ok and operate basics on AV system
    Started plugin used Run discovery and it finds the hub on the correct IP address that is bound to the MAC address.
    When I tick enable i get the following in the log
    The Connection to Hub with ID 70d6ef79f8b1e0a4272da92c6b5bf020cb0872f5 failed with message: No connection could be made because the target machine actively refused it 192.168.1.13:5222
    When I look at devices actions etc there is nothing there of course.
    If I try to input the IP address manually the plugin says there is no hub on that address!
    So although the plugin sees the hub it does not connect.
    Have tried firewall settings etc but to no avail.
    What am I missing in the basics that is preventing connection?
    My phone seems to have a stable connection and can do the basics on my systems.

  • #2
    Hi palli ,

    You have to enable XMPP so that the hub will listen on port 5222. XMPP is the protocol the plugin uses to communicate locally with the hub. Discovery must use a default open port like 80. From within the Harmony App, go here: Menu > Harmony Setup > Add/Edit Devices & Activities > Remote & Hub > Enable XMPP

    Hope this helps,
    Ken

    Comment


    • #3
      Thank you

      Comment

      Working...
      X