Announcement

Collapse
No announcement yet.

IP Change causes a connection error - is this a bug?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • IP Change causes a connection error - is this a bug?

    Hello:

    Just discovered why this plugin hasnt been connecting correctly. When running the discovery for the hub the plugin always finds the hub but when I enable the hub I get this error:
    The Connection to Hub with ID 5f108f0d94627fb5e056080b4d1d5af09c883e29 failed with message: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.168.xxx.yyy:5222
    So as it turns out my DHCP server changed the hub's IP address. Should the plugin be able to recognize and deal with changing IP address - especially since discovery clearly sees the hub?
    For now I fixed it by deleting and recreating the hub and devices.

  • #2
    You could just make a static DHCP assignment for the IP on the hub. Problem solved.

    Comment


    • #3
      I would recommend a static DHCP. Beside that you can adjust the auto discovery (in the general settings) and it will fix it on the next discovery cycle.
      MeiAutomtion Home

      Comment

      Working...
      X