Announcement

Collapse
No announcement yet.

Alexa not working when Meiharmonyhub plugin is active

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Alexa not working when Meiharmonyhub plugin is active

    hello all ,

    Got a wierd issue with my system, took me 2 weeks to troubleshoot , but I finally found where the problem lies.

    I have several plugins , 2 of them are the sonos plugin and Meiharmonyhub plugin. Both are working fine.
    2 weeks ago I wanted to setup voice commands for Alexa. Alexa did not discover any device. After 2 weeks of troubleshooting and with the help of Homeseer support I got Alexa working , It finally discovered devices.
    Wierdly enough the discovery only works when I delete all devices created by MeiharmonyHub and sonos plugin. Afterwards I can enable the Sonos plugin again and Alexa keeps on discovering new devices , but when I enable Meiharmonyhub plugin and the devices are created, Alexa stops discovering new devices.
    I than have to delete the Meiharmonyhub devices again and Sonos devices.

    So , in short , the MeiHarmonyhub plugin I can not use at all , and the sonos plugin I have to disable and delete devices before I can discover with Alexa again.

    It is very very wierd does someone have an idea what could be wrong?

    Thanks,
    Cor

    Current Date/Time: 1/29/2020 10:00:04 PM
    HomeSeer Version: HS3 Standard Edition 3.0.0.548
    Operating System: Microsoft Windows 10 Pro - Work Station
    System Uptime: 0 Days 0 Hours 59 Minutes 16 Seconds
    IP Address: 192.168.68.20
    Number of Devices: 395
    Number of Events: 153
    Available Threads: 799
    HSTouch Enabled: True
    Event Threads: 0
    Event Trigger Eval Queue: 0
    Event Trigger Priority Eval Queue: 0
    Device Exec Queue: 0
    HSTouch Event Queue: 0
    Email Send Queue: 0
    Anti Virus Installed: Windows Defender
    In Virtual Machine: No MFG: asustek computer inc.
    Enabled Plug-Ins
    1.0.0.0: drhsEventEnabler
    3.0.0.40: ImperiHome
    3.0.0.14: MeiUnifi
    0.0.0.47: Pushover 3P
    3.0.7.3: SDJ-Health
    3.1.0.51: Sonos
    3.0.1.252: Z-Wave
    ​​​​​​​3.1.0.16: Meiharmonyhub (disabled)

  • #2
    I will be investigating this, I use the Harmony plugin and haven't been able to add new devices or events to Alexa in months. So, disable harmony( i do not use Sonos), remove harmony devices, restart, discover, re-enable harmony?

    Comment


    • #3
      thomauto@aol.coI am not the only one..... that is a relief.

      Yes, that is exactly as I did.
      -disable the plugin
      -select all devices to do with meiharmonyhub.
      -delete them all in 1 go on the " device management" page.

      Then I could discover devices with Alexa.
      I have not re enabled harmony and checked if alexa is working with voice command, i just know for now that after "meiharmonyhub" is enabled, the discovery is not working anymore.

      would be nice if you can check as well if that solves the problem.

      Cor

      Comment


      • #4
        I don't know what I would be doing that woudl cause this. Have you set all the MeiHarmonyHub devices to NOT be voice devices (something HS sets to true by default)?
        MeiAutomtion Home

        Comment


        • #5
          Yes I did..... a lot of times even.
          On the sonos plugin forum there is a similar threat for this alexa problem.
          Dirk, the developer of Sonis plugin says to delete the .ini file so the plugin can restore in a normall way.
          Does the Harmony hub have a similar ini file.... can I delete that one as well? Will it after enabling again restore all?
          Where can I find this ini file?

          thanks
          Cor

          Comment


          • #6
            Sadly this did not fix my discovery. I didn't do the "remove all voice control and add back" but I did disable and relink the skill, still no additional devices or events were found. It did help me in one respect, I had a couple of roku devices I had removed from my hub but were still in HS. Disabling, deleting all and enabling the plugin again got rid of them.
            Mike

            Comment

            Working...
            X