Announcement

Collapse
No announcement yet.

Meiharmony not communicating with Hub

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • sirmeili
    replied
    The Profit Have you tried restarting HS3 or your computer? I find it odd it just stopped working. did you upgrade the plugin to a newer version?

    Sgetschel I have yet to try an HS3 -> HS4 converions, but HST said that this should just work. can you try turning on debugging and capturing a debug log?

    Leave a comment:


  • Sgetschel
    replied
    I am having the same issue. I just upgraded to HS4 Pro from HS3. Everything was working fine in HS3 but it is not communicating with the hub in HS4. I have tried the above suggestions with no success.

    Leave a comment:


  • The Profit
    replied
    Originally posted by sirmeili View Post
    Do you have XMPP enabled on the hub?

    https://forums.homeseer.com/forum/au...plugin-to-work
    Yes. When I originally set it up with the plugin I had enabled XMPP and it was working fine until July 22nd. I don't see any errors in the log. I turned on debug for the plugin and then clicked on the "Connect" button for the HarmonyHub Root device, I've pasted the log below:
    Aug-07 3:32:24 PM Debug Hub should now be connected.
    Aug-07 3:32:24 PM Debug Disconnecting: Hub: XXXXX, Client is connected?: No
    Aug-07 3:32:24 PM Debug Connecting: Hub: XXXXX, Is there a client?: Yes
    Aug-07 3:32:24 PM Debug Connecting: Hub: XXXXXX, KnownDevice Connection Status: FailedToConnect
    Aug-07 3:32:24 PM Debug Starting Connect to Hub: XXXXX
    Aug-07 3:32:24 PM Device Control Device: MeiHarmonyHub MeiHarmonyHub Harmony Hub Hub to Connect (1) by/from: CAPI Control Handler
    Aug-07 3:32:23 PM Debug HS Config Changed: Relationship,Relationship for device ref: 1780
    Aug-07 3:32:23 PM Debug HS Config Changed: Relationship,Relationship for device ref: 1779
    Aug-07 3:32:23 PM Debug HS Config Changed: Relationship,Relationship for device ref: 1777
    Aug-07 3:32:23 PM Debug HS Config Changed: Relationship,Relationship for device ref: 1776
    Aug-07 3:32:23 PM Debug HS Config Changed: AdditionalDisplayData for device ref: 1133
    Aug-07 3:32:14 PM Info KnownDevices: {"XXXXX":{"UniqueId":"XXXXX","Location":"192.168.1 .44","Name":"Harmony Hub","RemoteID":"16067","Devices":{"685":{"DeviceId" :"635","DeviceRef":1712,"Enabled":true,"DeviceSettings" :{"CommandSettings":{},"CommandNameMappings":{},"Repeat":1 ," RepeatDelay":500,"InterCommandDelay":1}},"66":{"Device Id":"66","DeviceRef":1713,"Enabled":true,"DeviceSettin gs":{"CommandSettings":{},"CommandNameMappings":{},"Repeat ": 1,"RepeatDelay":500,"InterCommandDelay":1}},"68":{"Dev iceId":"68","DeviceRef":1714,"Enabled":true,"DeviceSet tings":{"CommandSettings":{},"CommandNameMappings":{},"Repea t":1,"RepeatDelay":500,"InterCommandDelay":1}},"6578":{" DeviceId":"678","DeviceRef":1715,"Enabled":true,"Device Settings":{"CommandSettings":{},"CommandNameMappings":{},"Re peat":1,"RepeatDelay":500,"InterCommandDelay":1}},"6833" :{"DeviceId":"683","DeviceRef":1716,"Enabled":true,"Dev iceSettings":{"CommandSettings":{},"CommandNameMappings":{}, "Repeat":1,"RepeatDelay":500,"InterCommandDelay":1}},"68 3734 37":{"DeviceId":"683","DeviceRef":1717,"Enabled":true," DeviceSettings":{"CommandSettings":{},"CommandNameMappings": {},"Repeat":1,"RepeatDelay":500,"InterCommandDelay":1}},"68 3 73431":{"DeviceId":"631","DeviceRef":1718,"Enabled":tru e,"DeviceSettings":{"CommandSettings":{},"CommandNameMappi ng s":{},"Repeat":1,"RepeatDelay":500,"InterCommandDelay":1} }," 684":{"DeviceId":"634","DeviceRef":1719,"Enabled": true,"DeviceSettings":{"CommandSettings":{},"CommandNameMapp ings":{},"Repeat":1,"RepeatDelay":500,"InterCommandDelay":1} },"62":{"DeviceId":"6832","DeviceRef":1720,"Enable d":true,"DeviceSettings":{"CommandSettings":{},"CommandNa meM appings":{},"Repeat":1,"RepeatDelay":500,"InterCommandDelay" :1}},"629":{"DeviceId":"629","DeviceRef":1721,"Ena bled":true,"DeviceSettings":{"CommandSettings":{},"CommandNa meMappings":{},"Repeat":1,"RepeatDelay":500,"InterCommandDel ay":1}}},"Remotes":null,"ActivityVoiceControlMappings":nul l, "HubRootDeviceReference":1709,"ActivityDeviceReference": 1710 ,"SleepTimerDeviceReference":1711,"Enabled":true,"CreateA cti vityDevice":true,"CreateDeviceDevices":true,"CreateSleepDevi ce":true}}
    Aug-07 3:32:14 PM Info Plugin Settings: {"MaxConnectionAttempts":0,"MaxMissedHeartbeats":2,"TimeB etw eenConnectionAttempts":5000,"RequestTimeout":15000,"Heartbea tInterval":30000,"DevicePollingInterval":"1.00:00:00","Updat eActivityDeviceOn":2,"DebugLogging":true,"HSLoggingLevel":1, "SettingsVersion":{"Major":3,"Minor":1,"Build":0,"Revisi on": 16,"MajorRevision":0,"MinorRevision":16}}
    Aug-07 3:32:14 PM Info Plugin Version: 3.1.0.16
    Aug-07 3:32:14 PM Info Debug Logging Turned on.
    Aug-07 3:32:14 PM Debug Posting back data on page (MeiHarmonyHub_General_Config) with data: DebugLogging=checked&id=DebugLogging
    Aug-07 3:32:14 PM Info Page MeiHarmonyHub_General_Config; Date DebugLogging=checked&id=DebugLogging

    Leave a comment:


  • sirmeili
    replied
    Do you have XMPP enabled on the hub?

    https://forums.homeseer.com/forum/au...plugin-to-work

    Leave a comment:


  • The Profit
    replied
    Originally posted by sirmeili View Post

    NP. It doesn't necessarily have to be 15000 but I would make sure that whatever you set it to that the heartbeat interval is more than the request timeout.
    Hello,
    I’m having issues with the hub connecting to your plugin. I have checked all of the above setting you’ve mentioned and nothing seems to get this working. Could you let me know what you need to assist?


    Sent from my iPhone using Tapatalk

    Leave a comment:


  • sirmeili
    replied
    Originally posted by CameronHilliard View Post

    I changed this to 15000 and it worked. Thanks for looking into this!
    NP. It doesn't necessarily have to be 15000 but I would make sure that whatever you set it to that the heartbeat interval is more than the request timeout.

    Leave a comment:


  • CameronHilliard
    replied
    Originally posted by CameronHilliard View Post

    2000
    I changed this to 15000 and it worked. Thanks for looking into this!

    Leave a comment:


  • CameronHilliard
    replied
    Originally posted by sirmeili View Post
    Can you go to the plugins' general settings and tell me what you have set for "Request Timeout"?

    Click image for larger version

Name:	2020-07-09_22-14-25.png
Views:	147
Size:	124.0 KB
ID:	1401163
    2000

    Leave a comment:


  • sirmeili
    replied
    Can you go to the plugins' general settings and tell me what you have set for "Request Timeout"?

    Click image for larger version

Name:	2020-07-09_22-14-25.png
Views:	147
Size:	124.0 KB
ID:	1401163

    Leave a comment:


  • CameronHilliard
    replied
    Originally posted by sirmeili View Post
    I will take a look at your logs after work today.
    Thank you

    Leave a comment:


  • sirmeili
    replied
    I will take a look at your logs after work today.

    Leave a comment:


  • CameronHilliard
    started a topic Meiharmony not communicating with Hub

    Meiharmony not communicating with Hub

    I have looked at nearly every post in this forum. I assumed my issue was the enable xmpp (which I needed to do) no dice.
    I then checked and made sure I downloaded the latest beta version of the plugin. no dice
    I'm running homeseer on a windows machine. The hub works just fine normally. I don't have to connect through the cloud.
    I've been scouring the forums for 3 hours and I give up. Please assist if you don't mind. Here are the logs I have already turned on the developer debug log



    Attached Files
Working...
X