No announcement yet.

MeiHarmony Plugin No Longer Functions After Reboot

  • Filter
  • Time
  • Show
Clear All
new posts

    MeiHarmony Plugin No Longer Functions After Reboot

    After a power outage caused an unexpected reboot, my MeiHarmony Plugin fails to load at startup and I cannot get it back online. From the startup Log:

    9/3/2020 8:57:35 PM ~!~Starting Plug-In~!~Initializing plugin MeiHarmonyHub ...

    9/3/2020 8:57:39 PM ~!~Error~!~Initializing plug-in(2): MeiHarmonyHub Instance::Object reference not set to an instance of an object.STACK: at System.Runtime.Remoting.Messaging.LogicalCallContext.Propaga teIncomingHeadersToCallContext(IMessage msg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.InitIO(String port) at Scheduler.clsHSPI.CheckInterfaces()

    9/3/2020 8:57:39 PM ~!~Starting Plug-In~!~MeiHarmonyHub loaded in 4316 milliseconds

    I tried a reinstall of the plugin, started at a lower version and updated through the beta, no luck. Same issue every time.

    I just built a very complex set of TV & Device control pages in HSTouch based off the MeiHarmony devices in Homeseer. I REALLY want to avoid redoing all of that work, so restoring functionality of the currently existing devices is my end goal. If the devices in HomeSeer are replaced, then I have to redo every button in HSTouch.

    Any advice would be greatly appreciated.


    You may have to verify that the settings files are intact. You said that you re-installed, but will not overwrite the settings files ([hs3installpath]/configs/MeiHarmonyHub/).

    My guess is they have been corrupted. There may be backups in there.
    MeiAutomtion Home


      I believe you are right, as when I open the KnownHubs JSON it just several repeated NUL characters. Same for the .bak versions.

      I fully removed those files and reinstalled, and the hub plugin now loads. It even finds my hubs at the same IPs, however, if I try and address the HS devices that were built around the hubs, it crashes the plugin:

      Sep-04 2:44:17 PM Info Plugin MeiHarmonyHub with instance: has disconnected
      Sep-04 2:44:15 PM Device Control Device: MeiHarmonyHub MeiHarmonyHub Apple TV 1 to Choose Command (1) by/from: CAPI Control Handler

      I noticed the Known Hubs JSON now shows all of my Hubs and IPs, but devices just show { }, implying they are empty. Any possible way to reuse what is existing in Homeseer, even if I have to modify that file? That would retain my HSTouch references I think.

      Thank you for the support.


        I have got the same issue. It has been been working great for ages but now not working. this error message in log. Even though the harmony app on my iphone and my router can clearly see the hub. I have upgraded to latest beta but no success.
        Sep-10 13:25:33 Error The Connection to Hub with ID 5a772dcf74583f3a4d449f84b11ff5d22bedb755 failed with stack trace: at System.Net.Sockets.TcpClient..ctor(String hostname, Int32 port) at HarmonyHub.Client.Connect(Int32 heartbeatInterval)
        Sep-10 13:25:33 Error The Connection to Hub with ID 5a772dcf74583f3a4d449f84b11ff5d22bedb755 failed with message: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond


          Solved by deleting hub from plugin, deleting devices and uninstalling plugin. Reinstalled again no issues so far.