Announcement

Collapse
No announcement yet.

Duplicate Hub with different IDs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Duplicate Hub with different IDs

    Hello,

    Getting the following in HS log:

    Click image for larger version

Name:	Capture.JPG
Views:	40
Size:	30.1 KB
ID:	1475278

    I know the 1st question you will ask, did I enable XMPP? Yes, I did. Hub firmware is at .210. I didn't expect this to actually downgrade the hub's firmware...

    I did have some issues setting the hub initially and at some point after the firmware update I was getting this in the plugin:

    Click image for larger version

Name:	Capture.JPG
Views:	40
Size:	38.6 KB
ID:	1475279

    Not much was working at this point. So I elected to clear the hubs, stop the plugin, remove related HS devices and restart the plugin to get a clean slate. From there, the 1st hub (the one enabled) showed up and all the configuration has been done with that one.

    That worked. I was able to control everything present in the Harmony hub. I then proceeded to build the events. I was just done then everything stopped working, getting the above errors again and also again the duplicate hubs.

    I only have 1 Harmony hub. Notice the name is the same for both. That's the name I gave it in the Harmony setup. The IDs are quite different though. When I 1st got the duplicates, I tried the "Fix UID" button. That got rid of the second hub from the GUI, but the devices were still not working, hence why I restarted from scratch.

    Now that the setup is all done, I'm reluctant removing 1 of the dupe hubs.

    So,
    question 1: why am I getting duplicate hubs?
    question 2: how to fix that without loosing the configuration?
    question 3: how to prevent that situation happening again?

    For the record, I'm running HS4 Pro Edition 4.1.15.0 (Windows).


    Attached Files

    #2
    I found the culprit. While doing the events, the hub updated itself to version .290 which was the version it had originally.

    I also found out that since version .250, you can enable XMPP. That option is only available in the mobile app though. Thanks to thoughtful engineers at Logitech, it's not available in the PC app.

    So, app download, enable XMPP, say yes twice to the BS warning this is insecure and voilĂ , everything works.

    Removed the dupe hub and restarted the plugin, just to be sure, no more duplicate hub.

    Comment

    Working...
    X