Announcement

Collapse
No announcement yet.

No longer connecting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No longer connecting

    Hi! I have HS3, a GC iTach IP2IR and have used your plugin successfully on this computer in the past, but have not actively used for the past 6 months or so.

    Yesterday I attempted to revamp my use of IR for a TV, and found that the events I used previously no longer worked.

    Ihelp is seeing the device, and ILearn can connect, but UltraGCIR shows Global Cache Status: Device Count 0, and none of the other tabs show any data.

    Unit Details
    IP Address:
    192.168.101.11
    MAC Address: 000C1E03BEA1
    Model: iTachIP2IR
    SDKClass: Utility
    Make: GlobalCache
    Revision: 710-1005-05
    Pkg_Level: GCPK002
    PCB_PN: 025-0028-03
    Status: Ready
    Beacon Dump
    AMXB
    <-UUID=GlobalCache_000C1E03BEA1>
    <-SDKClass=Utility>
    <-Make=GlobalCache>
    <-Model=iTachIP2IR>
    <-Revision=710-1005-05>
    <-Pkg_Level=GCPK002>
    <-Config-URL=http://192.168.101.11>
    <-PCB_PN=025-0028-03>
    <-Status=Ready>

    I made a copy of the database and then removed & reinstalled the plugin with no success. I then removed the plugin from HS3 as well as the individual devices. I reinstalled the plugin and neither did the GC show in device count, nor did the individual devices/IR commands repopulate in the DB or HS3

    I've attached the old DB, new DB, .ini, and debug logs for your review. The new DB has no device data, the old DB has them all. No apparent errors in the log. 2 windows firewall rules exist- 1 for UDP and 1 for TCP for the ultragcir3 executable.

    Can you suggest other things I can try / look for to resolve the issue?

    Thanks!
    Attached Files

  • #2
    Hi,

    It's possible the plug-in no longer has permission to listen for packets sent from the Global Cache devices. Can you connect to the console on your HomeSeer system, then restart it, then check for any firewall prompts during the startup of the plug-in?

    Regards,
    Ultrajones
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

    Comment


    • #3
      I did try that before, based on another post I saw. I deleted the firewall rules and restarted HS3 & received the firewall prompts asking to allow.

      Here's what I saw after restarting HS3 today - there were 3 entries in the startup log:

      7/19/2017 9:02:26 AM ~!~Plug-In~!~Found plug-in: UltraGCIR3, version: 3.0.6132.16975
      7/19/2017 9:02:37 AM ~!~Info~!~Plugin UltraGCIR3 has connected. IP:127.0.0.1:43300
      7/19/2017 9:02:38 AM ~!~Plug-In~!~Finished initializing plug-in UltraGCIR3

      Comment


      • #4
        Tried a couple more things

        - Reset the GC Device to defaults
        - Changed IP address to a different static IP
        - Included Public Profile in Windows Firewall Rule
        - Paused Kaspersky AV
        - Added Exception for UltraGCIR3 executable and HS3

        Comment


        • #5
          Running SysInternals Process Monitor now. Haven't seen anything that stands out so far. Let me know if a capture of this would be of any use to you?

          I'll try to find some time to setup Wireshark and get a capture from it this weekend.

          Comment


          • #6
            Please confirm you're not running iHelp at the same time. iHelp isn't configured to allow more than 1 program to use the port at the same time.

            What version of Windows are you running?
            Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

            Comment


            • #7
              Confirmed. I only ran Ihelp/Ilearn/Itest to confirm connectivity to the Itach

              Windows 10 Pro. 64 bit
              V. 1703 Build 15063.483

              Comment


              • #8
                Does the Kaspersky software also have a firewall?

                Not sure what else to suggest at this point. There has been at least one other user that experienced a similar issue, but I don't recall how/if they were able to resolve the issue.

                Regards,
                Ultrajones
                Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                Comment


                • #9
                  Issue Resolved?

                  Spent a lot of time trying to figure this out to no avail... until tonight!

                  I noticed that one of my events that speaks the status of the Craftsman garage door was repeating open/closed multiple times. After unfiltering the device list, I discovered that there were 5 instances of the garage door when there should only have been 1. I deleted the 4 bad instances and resolved that issue.

                  Then...just happened to notice that there were ULTRAGCIR3 devices back in the list! Sure enough, when I looked at the ULTRAGCIR3 tab, it was listing the GC device again.

                  While I don't know for sure how, things seem to be working...I restored the old database, updated the device ID's and am back in business

                  I'm wondering if there was a conflict with device ID's and that could have caused the issue?

                  Comment


                  • #10
                    I am now having the same issue.
                    ihelp shows the ip, yes it is off when problem occurs. Uninstalled and reinstalled plugin, also restored everything from a previous working time. Still nothing plugin doesn’t see it, go to router and see the global cache as a client. Now what?


                    Sent from my iPhone using Tapatalk

                    Comment


                    • #11
                      I'm having the exact same issue. iHelp sees the GC-100 device but Plugin always has Device Count=0.
                      Any help would be appreciated.
                      I'm running Windows 10, HSPro Ver 3.0.0.531
                      Thanks.

                      Comment

                      Working...
                      X