Announcement

Collapse
No announcement yet.

Set Up Issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Set Up Issues

    Installed and enabled the plugin, correctly identifies the module I have but whenever I try to load the setup web page I get the following.

    System.NullReferenceException: Object variable or With block variable not set. Server stack trace: at Microsoft.VisualBasic.CompilerServices.Symbols.Container..ct or(Object Instance) at Microsoft.VisualBasic.CompilerServices.NewLateBinding.LateGe t(Object Instance, Type Type, String MemberName, Object[] Arguments, String[] ArgumentNames, Type[] TypeArguments, Boolean[] CopyBack) at Scheduler.hsapplication.Plugin(String pi_name) at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateP rocessMessage(IntPtr md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs) at System.Runtime.Remoting.Messaging.StackBuilderSink.PrivatePr ocessMessage(RuntimeMethodHandle md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs) at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProce ssMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext) Exception rethrown at [0]: at Microsoft.VisualBasic.CompilerServices.Symbols.Container.Inv okeMethod(Method TargetProcedure, Object[] Arguments, Boolean[] CopyBack, BindingFlags Flags) at Microsoft.VisualBasic.CompilerServices.NewLateBinding.LateGe t(Object Instance, Type Type, String MemberName, Object[] Arguments, String[] ArgumentNames, Type[] TypeArguments, Boolean[] CopyBack) at ASP.hspi_ultragcir_hspi_ultragcir_aspx.Page_Load(Object sender, EventArgs e) in C:\Program Files\HomeSeer\html\hspi_ultragcir\hspi_ultragcir.aspx:line 49

    Also is there any documentation that comes with the plugin?
    Regards, Bob

  • #2
    Did you restart HomeSeer?

    Comment


    • #3
      Originally posted by rhodesep View Post
      Did you restart HomeSeer?
      Yes, rebooted the computer as well.
      Regards, Bob

      Comment


      • #4
        Are you running HomeSeer as a service?
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment


        • #5
          Originally posted by Ultrajones View Post
          Are you running HomeSeer as a service?
          Nope
          Regards, Bob

          Comment


          • #6
            Line 49 is:

            Code:
            hspi = hs.Plugin("UltraGCIR")
            Are you using any other plug-ins that use .ASPX web pages? I believe the last time someone reported a simliar error, it was resolved by doing a repair to the .NET 2.0 framework. Please open a case with HomeSeer and ask them to provide you instructions on how to do this. Please let me know if a .NET repair does not work.

            Regards,
            Ultrajones
            Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

            Comment


            • #7
              UPDATE: I installed the newly released service pack for Windows7 and it appears to be working now.
              Regards, Bob

              Comment

              Working...
              X