Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Reconnection

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Reconnection

    Hello UJ,

    running HS 2.5.0.1, iTach WF2IR firmware 710-1001-02, UltraGCIR 1.1.3993.38767.

    From time to time, my WF2IR gets stuck and has to be restarted. When that happens, UltraGCIR apparently starts attempting to reconnect, with an increasing time interval between 2 attempts, ending up with a 1 hour interval.

    After rebooting my WF2IR, when I select the reconnect option from the iTach HomeSeer Wifi Module 0:1 to force a reconnect attempt, it apparently waits till the end of the 1 hour interval before actually reconnecting.

    Is this the expected behavior?

    Thanks and regards,
    Nicolas

  • #2
    No, that is not the expect behavior. It should reconnect immediately. I'll disconnect mine to see if I can duplicate this.

    Regards,
    Ultrajones
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

    Comment


    • #3
      I was able to duplicate this today. I think this can ocurr when NetworkStream.Close() generates an exception which could cause the TcpClient.Close to get skipped. I added a Try Catch block around both to ensure both get executed when DisconnectEthernet() is called. I'll post an update there once I upload the new version to the HomeSeer updater.

      Update: The root cause is the order I was attemtping to close the network. I should have closed the TCP connection first.

      Regards,
      Ultrajones
      Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

      Comment


      • #4
        UltraGCIR HSPI version 1.1.4165.18196 was just posted to the HomeSeer updater.

        Regards,
        Ultrajones
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment


        • #5
          Hi UJ,

          thanks for the update. Have installed it and will keep you posted.

          Regards,
          Nicolas

          Comment


          • #6
            Hello UJ,

            apparently, the behavior is still the same. For instance, today:

            Connection was lost at 02:49:46
            I cycled power on my WF2IR around 9:10
            The last attempt to reconnect had taken place at 08:57:00
            I asked the plugin to reconnect at 9:13:20
            The plugin actually attempted to reconnect (and succeeded) at 09:57:00

            I'm running UltraGCIR version 1.1.4246.36142, WF2IR firmware 710-1001-05, HS 2.5.0.1

            Thanks,
            Nicolas
            Last edited by nchollet; December 3rd, 2011, 04:56 AM.

            Comment

            Working...
            X