Announcement

Collapse
No announcement yet.

iTach Flex

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • iTach Flex

    Has anyone used iTach Flex yet?

    It's pretty interesting that the same device can function as WIFI/LAN to Serial or WIFI/LAN to Infrared by just switching the cable. Somewhat cheaper than WF2IR and IP2IR too.

    On top of being backward compatible with GC-100 and previous iTach devices, it introduces 2 more control path (via web), I suppose to cater to the mobile (iOS, Android)?

    Anyway, I've just ordered a (wired) iTach Flex + 3 port IR cable to replace my GC-100-12 which cannot handle IR commands for Daikin and Mitsubishi Mr.Slim airconditioners.
    HW: HS3 w/ Win8.1 on ASRock C2550d4i. Digi AnywhereUSB, Hubport, Edgeport, UZB, Z-trollers, PLCBUS, SONOS, GC-100, iTach IP2SL, WF2IR, IP2IR, RFXtrx433, Harmony Hubs, Hue, Ademco Vista 128BP, NetAtmo, NetAtmo Welcome

    Google Search for HomeSeer Forum

  • #2
    It works with HS2 UltraGCIR

    Even though it is not official. My Flex was recognized by UltraGCIR. My flex is a single Blaster. GCIR finds it as 1:1. I loaded Power on/off codes for 4 devices and all works fine. This Blaster actuality works (unlike the BL2 Blaster).

    ULTRA the link to your documentation above is broken.

    Comment


    • #3
      I've got my flex, with the tri-port cable. Unfortunately GCIR doesn't recognize that it's a device with 3 output and only shows up as a 1:1 node.

      It seems that iTach Flex is not supported yet by UltraGCIR.

      Ultrajones, can we get this fixed please?
      Last edited by LeoS; July 19th, 2013, 03:16 PM.
      HW: HS3 w/ Win8.1 on ASRock C2550d4i. Digi AnywhereUSB, Hubport, Edgeport, UZB, Z-trollers, PLCBUS, SONOS, GC-100, iTach IP2SL, WF2IR, IP2IR, RFXtrx433, Harmony Hubs, Hue, Ademco Vista 128BP, NetAtmo, NetAtmo Welcome

      Google Search for HomeSeer Forum

      Comment


      • #4
        I just unboxed my iTachFlex. It is a pretty neat device. I'll get UltraGCIR HSPI updated to support the iTachFlex before starting the HS3 conversion. It may take up to 2 weeks before I can post an update though ...

        Regards,
        Ultrajones
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment


        • #5
          I have the Global Cache Flex working with any combination of IR devices connected. I now have to figure out how to code it so that if you connect a serial device to one of the tri-ports, it doesn't display it as an IR device. Almost there ...

          Regards,
          Ultrajones
          Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

          Comment


          • #6
            It looks like the tri-port cable and the serial cable cannot be used at the same time, so I think the coding changes are complete. I'll post an update shortly that adds support for the Global Cache iTach iFlex.

            Regards,
            Ultrajones
            Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

            Comment


            • #7
              Originally posted by Ultrajones View Post
              It looks like the tri-port cable and the serial cable cannot be used at the same time, so I think the coding changes are complete. I'll post an update shortly that adds support for the Global Cache iTach iFlex.

              Regards,
              Ultrajones
              HS2 or HS3?

              Comment


              • #8
                The update is to UltraGCIR HSPI for HS2.
                Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                Comment


                • #9
                  I just posted UltraGCIR HSPI version 1.1.4999.26515 that adds support for the Global Cache iTach Flex.

                  Regards,
                  Ultrajones
                  Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                  Comment


                  • #10
                    I had my flex working before the upgrade. I only have a single IR blaster. I have a tri cable but I am not using it. New version will not find Flex. Old version found it an it worked. Should I do something special?

                    update: The flex is appearing in the status as Wifi module 0:1. It does not appear when I go to the plugin to input codes.
                    Last edited by rhodesep; September 8th, 2013, 05:03 PM.

                    Comment


                    • #11
                      I was wrong

                      iTech Flex is not showing up. Ultramon detects it but, ultraGCIR does not.

                      Comment


                      • #12
                        Can you tell me what firmware version you are using? I believe the latest is 710-2000-07.

                        Regards,
                        Ultrajones
                        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                        Comment


                        • #13
                          Originally posted by Ultrajones View Post
                          Can you tell me what firmware version you are using? I believe the latest is 710-2000-07.

                          Regards,
                          Ultrajones
                          I am on 710-2000-07. I had been using the flex since it arrived on the last software. Since I only using one BL and no tri cable. The last version found it. I learned the codes and all worked.

                          Comment


                          • #14
                            New information

                            Randy

                            There is a new iHelp (ver 4.3) which upgrades the firmware to 710-2000-09.
                            You will have to shutdown HS2 to run iHelp that will load the firmware. Guess what, the iTach Flex showed up when I restarted HS2. The device and codes I had entered were still there. It seems to be working OK.


                            Thanks, Gene

                            Comment


                            • #15
                              Serial Commands?

                              Hi guys - I have a 2 iTach Flexs. One is being used in triport IR and works great (in early testing). My other one is a serial connection.

                              Did you ever get the iTach Flex Serial to work? You mention the code is complete. It shows up as a Serial device to me and is discovered just fine by HS3. However, I can't figure out how to send Serial commands. I already know the strings to send.

                              The documentation mentions IR triggers, but I am not sure how to apply that to serial.

                              Comment

                              Working...
                              X