Announcement

Collapse
No announcement yet.

UltraGCIR3 HSPI - Bug Reports

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    That change worked for me.
    Thanks,
    Barry

    Comment


    • #17
      Thank you for confirming. I updated the file and posted the package update to the HomeSeer3 updater. To apply the change, simply shutdown the plug-in, re-install the plug-in, then re-enable the plug-in.

      Regards,
      Ultrajones
      Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

      Comment


      • #18
        New version working here.

        Thanks
        Jeff

        Comment


        • #19
          I reloaded the plugin and now have a log full of the following-

          10/12/2013 4:30:34 PM Warning Exception adding a (single) pair to the collection: Item has already been added. Key in dictionary: '1' Key being added: '1'
          10/12/2013 4:30:34 PM Warning Exception adding a (single) pair to the collection: Item has already been added. Key in dictionary: '0' Key being added: '0'
          10/12/2013 4:30:34 PM Warning Exception adding a (single) pair to the collection: Item has already been added. Key in dictionary: '-1' Key being added: '-1'
          10/12/2013 4:30:34 PM Warning Exception adding a (single) pair to the collection: Item has already been added. Key in dictionary: '-2' Key being added: '-2'
          10/12/2013 4:30:34 PM Warning Exception adding a (single) pair to the collection: Item has already been added. Key in dictionary: '-3' Key being added: '-3'
          10/12/2013 4:30:34 PM Warning Exception adding a (single) pair to the collection: Item has already been added. Key in dictionary: '1' Key being added: '1'
          10/12/2013 4:30:34 PM Warning Exception adding a (single) pair to the collection: Item has already been added. Key in dictionary: '0' Key being added: '0'
          10/12/2013 4:30:34 PM Warning Exception adding a (single) pair to the collection: Item has already been added. Key in dictionary: '-1' Key being added: '-1'
          10/12/2013 4:30:34 PM Warning Exception adding a (single) pair to the collection: Item has already been added. Key in dictionary: '-2' Key being added: '-2'
          10/12/2013 4:30:34 PM Warning Exception adding a (single) pair to the collection: Item has already been added. Key in dictionary: '-3' Key being added: '-3'
          10/12/2013 4:30:34 PM Warning Exception adding a (single) pair to the collection: Item has already been added. Key in dictionary: '1' Key being added: '1'
          10/12/2013 4:30:34 PM Warning Exception adding a (single) pair to the collection: Item has already been added. Key in dictionary: '0' Key being added: '0'
          10/12/2013 4:30:34 PM Warning Exception adding a (single) pair to the collection: Item has already been added. Key in dictionary: '-1' Key being added: '-1'
          10/12/2013 4:30:34 PM Warning Exception adding a (single) pair to the collection: Item has already been added. Key in dictionary: '-2' Key being added: '-2'
          10/12/2013 4:30:34 PM Warning Exception adding a (single) pair to the collection: Item has already been added. Key in dictionary: '-3' Key being added: '-3'

          Barry

          Comment


          • #20
            It is a harmless warning. Ignore for now.
            Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

            Comment


            • #21
              Originally posted by Ultrajones View Post
              If you're experiencing an issue getting the plug-in to recognize your Global Cache devices, please try this and report back:

              1) Open up hspi_ultragcir3.exe.config in the HomeSeer3 root directory using notepad
              2) Change the line
              PHP Code:
              <probing privatePath="bin\hspi_ultracid3"/> to <probing privatePath="bin\hspi_ultragcir3"/> 
              That fixed it straight away. Got the Win8 firewall warning, allowed the app through and the iTach devices all showed up perfectly.
              Nicolai L

              Comment


              • #22
                Ultra... Fixed my problems as well...
                Attached Files
                Ubuntu on the Intel NUC ( 8i5BEK ), 32 G, 250G SSD, V4 Pro

                Comment


                • #23
                  Not a bug, just an observation

                  I have HS3 running on a separate box and I am trying to test as much as possible with HS2 still running. That hasn't worked with some plug-ins. I had to disable Z-wave because I was causing conflicts with 2 primary controllers on the same Z-wave network. I believe I may be seeing timing issues with the GC-100.

                  On my weekly generator test, I received notification that the generator was running from both HS2 & HS3, but only from HS2 on the shutdown. IR commands don't always work on both systems when both are operational, but are fine when only one system is running.

                  I was going to tinker with the wait time setting, but don't know enough about the GC and plug-in to know if it would impact performance. This isn't a big issue and I'll continue testing with HS2 shut down.

                  Thanks again for porting this great plug-in.
                  Barry

                  Comment


                  • #24
                    Originally posted by lhfarm View Post
                    I have HS3 running on a separate box and I am trying to test as much as possible with HS2 still running. That hasn't worked with some plug-ins. I had to disable Z-wave because I was causing conflicts with 2 primary controllers on the same Z-wave network. I believe I may be seeing timing issues with the GC-100.

                    On my weekly generator test, I received notification that the generator was running from both HS2 & HS3, but only from HS2 on the shutdown. IR commands don't always work on both systems when both are operational, but are fine when only one system is running.

                    I was going to tinker with the wait time setting, but don't know enough about the GC and plug-in to know if it would impact performance. This isn't a big issue and I'll continue testing with HS2 shut down.

                    Thanks again for porting this great plug-in.
                    Barry
                    If you are trying to use 2 plug-ins with the GC-100, then you'll have issue as that device only allows 1 connection. The plug-ins will fight over the 1 allowed TCP connection.

                    Regards,
                    Ultrajones
                    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                    Comment


                    • #25
                      I just finished UltraGCIR3 HSPI for HomeSeer3. I even completed support for IR pattern matching HomeSeer triggers when used with the GC-IRE connected to a serial port on the GC-100. I am working on the documentation and will post the first release within the week.

                      Regards,
                      Ultrajones
                      Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                      Comment


                      • #26
                        woo hoo !! Thanks !
                        Ubuntu on the Intel NUC ( 8i5BEK ), 32 G, 250G SSD, V4 Pro

                        Comment


                        • #27
                          UltraGCIR3 HSPI is officially released and is available for purchase from the HomeSeer store.

                          Regards,
                          Ultrajones
                          Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                          Comment


                          • #28
                            I get the following error when trying to use the "IR Control" tab and clicking on one of the IR commands.

                            An error occurred in the "sendIrById()" function.
                            The error details are:

                            Number: undefined
                            Description: window.event is undefined
                            Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

                            Comment


                            • #29
                              Originally posted by beerygaz View Post
                              I get the following error when trying to use the "IR Control" tab and clicking on one of the IR commands.

                              An error occurred in the "sendIrById()" function.
                              The error details are:

                              Number: undefined
                              Description: window.event is undefined
                              What is the name and version of the browser that you are using?
                              Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                              Comment


                              • #30
                                I'm using the latest version of Firefox 25.0.1
                                Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

                                Comment

                                Working...
                                X