Announcement

Collapse
No announcement yet.

UltraGCIR3 HSPI - Bug Reports

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    UJ - Firstly any update on the IR Control tab in Firefox?

    Secondly - When I quit HS3 UltraGCIR3 (and UltraNetCam3) crash with a dialog that says "HSPI_UltraGCIR3 has stopped working"
    Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

    Comment


    • #32
      Hello beerygaz. No updates on the IR control tabs yet. I had planned on re-witting the routines using jquery, but have not had time yet.

      I am not sure why the plug-ins are crashing on shutdown. I have never seen this before. When did it start? What version of HS are you using? What operating system are you using?

      Regards,
      Ultrajones
      Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

      Comment


      • #33
        UJ, it started around 3.0.0.42 - but I can't be 100% sure. I'm running 3.0.0.54 now, Windows Server 2008 R2 OS.
        Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

        Comment


        • #34
          Originally posted by Ultrajones View Post
          I am not sure why the plug-ins are crashing on shutdown. I have never seen this before. When did it start? What version of HS are you using? What operating system are you using?

          Regards,
          Ultrajones
          I can report the crash on the shut down of HS3 is happening here too. I only enable the plug-in for short periods of time, then disable it and other plug-ins before handing back control to HS2. When I shutdown HS3, I get the Windows dialog that it has crashed. Running Win7 and on version 0.54.

          I can try enabling, then shutting down to see if the crash happens all the time or just after it has been disabled if that would help.



          Barry
          Edit: OK tried a couple of variations and got the message when the plug-in was enabled and shut HS3 down. However, that only occurred once in three tests. I also got a clean shutdown with the plug-in disabled just now. If you would like for me to try anything, let me know.
          Last edited by lhfarm; December 18th, 2013, 09:46 AM.

          Comment


          • #35
            I am getting frequent occurrences of the following warning in my error log:

            Jan-08 11:39:46 AM Warning In ZipFile, exception opening C:\Program Files\HomeSeer HS3\Data\ultragcir3\ultragcir3.db3 : The process cannot access the file 'C:\Program Files\HomeSeer HS3\Data\ultragcir3\ultragcir3.db3' because it is being used by another process.
            Jan-08 11:32:13 AM Warning In ZipFile, exception opening C:\Program Files\HomeSeer HS3\Data\ultragcir3\ultragcir3.db3 : The process cannot access the file 'C:\Program Files\HomeSeer HS3\Data\ultragcir3\ultragcir3.db3' because it is being used by another process.


            I don't have a recurring event setup for UltraGCIR3. The only rule I have right now is that it triggers the PIP on my TV when the doorbell rings to display our front door camera, and show us a picture of who is standing there. These warnings do not correspond to when the event is triggered.

            Comment


            • #36
              Originally posted by automateme View Post
              I am getting frequent occurrences of the following warning in my error log:

              Jan-08 11:39:46 AM Warning In ZipFile, exception opening C:\Program Files\HomeSeer HS3\Data\ultragcir3\ultragcir3.db3 : The process cannot access the file 'C:\Program Files\HomeSeer HS3\Data\ultragcir3\ultragcir3.db3' because it is being used by another process.
              Jan-08 11:32:13 AM Warning In ZipFile, exception opening C:\Program Files\HomeSeer HS3\Data\ultragcir3\ultragcir3.db3 : The process cannot access the file 'C:\Program Files\HomeSeer HS3\Data\ultragcir3\ultragcir3.db3' because it is being used by another process.


              I don't have a recurring event setup for UltraGCIR3. The only rule I have right now is that it triggers the PIP on my TV when the doorbell rings to display our front door camera, and show us a picture of who is standing there. These warnings do not correspond to when the event is triggered.
              This error isn't something from my plug-in. Do you have some type of backup job running that is trying to access ultragcir3.db3?

              Regards,
              Ultrajones
              Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

              Comment


              • #37
                Originally posted by lhfarm View Post
                I can report the crash on the shut down of HS3 is happening here too. I only enable the plug-in for short periods of time, then disable it and other plug-ins before handing back control to HS2. When I shutdown HS3, I get the Windows dialog that it has crashed. Running Win7 and on version 0.54.

                I can try enabling, then shutting down to see if the crash happens all the time or just after it has been disabled if that would help.



                Barry
                Edit: OK tried a couple of variations and got the message when the plug-in was enabled and shut HS3 down. However, that only occurred once in three tests. I also got a clean shutdown with the plug-in disabled just now. If you would like for me to try anything, let me know.
                This is a confirmed issue on systems running Windows 7. It has something to do with the .Net Framework. It does not happen on Windows 8. I am still looking into it.
                Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                Comment


                • #38
                  Originally posted by Ultrajones View Post
                  This error isn't something from my plug-in. Do you have some type of backup job running that is trying to access ultragcir3.db3?

                  Regards,
                  Ultrajones
                  That was it UltraJones. I am moving over to HS3, and recreating all of my events, so I am doing frequent 'Backup Config' under the Tools/Setup menu. Every time I run that, the warning appears.

                  Comment


                  • #39
                    Last edited by FredrikKan; January 29th, 2014, 11:48 AM. Reason: Update on sw versions

                    Comment


                    • #40
                      Ping

                      "Is there anybody out there...?"

                      Comment


                      • #41
                        this is what I get.. is the port avail > ( 4998) ?
                        what o/s are you running
                        Attached Files
                        Ubuntu on the Intel NUC ( 8i5BEK ), 32 G, 250G SSD, V4 Pro

                        Comment


                        • #42
                          Hello Fredrik. The error is occurring within a section of the code provided by HomeSeer. Are you able to get the sample plug-in installed and working on Microsoft Windows HomeSeer 2011?
                          Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                          Comment


                          • #43
                            Hi UJ!
                            I'm not sure what you mean with sample plugin...? I do have other plugins working (almost) ok. There are quite a lot of small problems/bugs but nothing compared to the startup problem with UltraGCIR3.

                            Windows home Server 2011 is a variant of MS 2008 Server and use the same codebase. I have used it for HS2 for the last 2-3 years with no problems. Before that I used the original Windows Home Server (based on MS 2003 Server).
                            All that is fine and have not been an issue with Homeseer. From what I have read it is supported.

                            I've included the other plugins currently installed in my system.


                            Regards,
                            Fredrik.
                            Attached Files

                            Comment


                            • #44
                              Tried HS3 forum with no success

                              Ultra,
                              according to Rupp you should get in contact with them regarding this problem. I would really lika you to do that!

                              And maybe give me some feedback....

                              Comment


                              • #45
                                I sent Rich a note and asked him to look at the issue you posted at http://board.homeseer.com/showpost.p...5&postcount=39

                                Regards,
                                Ultrajones
                                Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                                Comment

                                Working...
                                X