I have been using the UltraGCIR plug in in Hs2 for awhile with a wifi contact closure device and it is working great today I started to add 2 GC-100-12 units the plug in creates devices for them but I am unable to get commands to send to them. I am using the ilearn software to learn the IR codes with the GC-IRL I am able to communicate with the devices using global caches test software.
I had these sent in and flashed to the latest firmware.

I set the debug log and this is what I am receiving when I try to send an IR command.

1/20/2014 5:58:41 PM UltraGCIR Debug Sending command: 'sendir,4:1,1,38000,1,1,342,169,22,20BB22,62CCBBCCCBBBCCBCBB CBBBCBCCBCCC22,3800' to GC device, attempt # 1
1/20/2014 5:58:41 PM UltraGCIR Debug Waiting for the GC device to respond with '^completeir' for up to 1 seconds...
1/20/2014 5:58:41 PM UltraGCIR Debug Entered ProcessReceived() function with string 'unknowncommand 10', waiting for '^completeir'
1/20/2014 5:58:41 PM UltraGCIR Warning IR command to GC-100-12 [192.168.1.72] returned error: Number of transitions in the IR command is not even (the same number of on and off transitions is required).
1/20/2014 5:58:41 PM UltraGCIR Debug Waited 38 milliseconds for the command response.
1/20/2014 5:58:45 PM UltraGCIR Debug DiscoveryBeacon: Global Cache unit iTachWF2CC [192.168.1.73] is alive.
1/20/2014 5:58:46 PM UltraGCIR Debug Entered GetGCIRData() function.
1/20/2014 5:58:46 PM UltraGCIR Debug Entered GetGCIRDevices() function.
1/20/2014 5:58:47 PM UltraGCIR Debug Watchdog Timer indicates a response from the Global Cache device [192.168.1.72] was received at 1/20/2014 5:58:41 PM.
1/20/2014 5:58:47 PM UltraGCIR Debug Watchdog Timer indicates a response from the Global Cache device [192.168.1.72] was received 6 seconds ago.
1/20/2014 5:58:47 PM UltraGCIR Debug Watchdog Timer thread for the Global Cache device [192.168.1.72] sleeping for 30000.
1/20/2014 5:58:47 PM UltraGCIR Debug Sending command: 'getversion' to GC device, attempt # 1
1/20/2014 5:58:47 PM UltraGCIR Debug Waiting for the GC device to respond with '.+' for up to 1 seconds...
1/20/2014 5:58:47 PM UltraGCIR Debug Entered ProcessReceived() function with string 'version,0,3.2-12', waiting for '.+'
1/20/2014 5:58:47 PM UltraGCIR Debug ProcessReceived() reports: Found '.+' in string 'version,0,3.2-12'
1/20/2014 5:58:47 PM UltraGCIR Debug Waited 23 milliseconds for the command response.
1/20/2014 5:58:48 PM UltraGCIR Debug Sending command: 'sendir,4:1,1,38000,1,1,342,169,22,20BB22,62CCBBCCCBBBCCBCBB CBBBCBCCBCCC22,3800' to GC device, attempt # 1
1/20/2014 5:58:48 PM UltraGCIR Debug Waiting for the GC device to respond with '^completeir' for up to 1 seconds...
1/20/2014 5:58:48 PM UltraGCIR Debug Entered ProcessReceived() function with string 'unknowncommand 10', waiting for '^completeir'
1/20/2014 5:58:48 PM UltraGCIR Warning IR command to GC-100-12 [192.168.1.72] returned error: Number of transitions in the IR command is not even (the same number of on and off transitions is required).
1/20/2014 5:58:48 PM UltraGCIR Debug Waited 90 milliseconds for the command response.

someone please help

Thanks Ken

EDIT: I finally got it working, it didn't like the remote I was trying to learn the codes from, now that I got that figured out all is running great hoping to add a few more in the near future.

Thanks Ultra for the great plug in

Cheers Ken