Announcement

Collapse
No announcement yet.

Cannot control UltraGCIR3 blaster from HSTOUCH client

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot control UltraGCIR3 blaster from HSTOUCH client

    Hi folks,

    I am testing the UltraGCIR3 plugin with the Itach IP2IR device so far with fairly good results, however I am having an issue when using the IR blaster:
    I have saved a few IR codes to channel 1:3 (blaster output) and have setup the blaster to be a couple of feet away from the device I am trying to control.

    The good news is that when I test this setup using the "IR Control" tab in the plugin the device in question responds correctly.
    However when I try to control the very same device with the IR control configured and linked to a HSTouch button, there is no response. I have included screenprints of the setup below.

    Please note that when the same setup is done using 1:1 or 1:2 (non blaster), the IOS client is able to control the IR device.
    Any help would be appreciated.

    Thanks

    mrwassen



    PS: I have tried to restart everything (both plugins as well as the server itself) but this doesnt not help
    Attached Files

  • #2
    I am unable to control anything via the Android HSTouch client using this plugin either. None of the buttons I setup associated with IR commands do anything. However, when using the plugin via the browser through Homeseer, the IR controls function as they should.

    Comment


    • #3
      I have never tried using my plug-in with HSTouch. What options are you selecting to control the device?

      Regards,
      Ultrajones
      Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

      Comment


      • #4
        I am using the same steps to assign a button with the function that MrWassen posted the image of above.

        Action Type: "control Homeseer device"
        Device: GlobalCache IR UltraGCIR3 Plugin iTachIP2IR IR Module 1:1
        Command: Xfinity Channel Up

        I do not see any entries in the log either. I set it to Debug, but nothing appears when I push the assigned button(s) in HSTouch.

        Comment


        • #5
          I am seeing the same thing in HSTouch. The plug-in is working from every other input like the Device Management web page, the UltraGCIR3 HSPI IR Control web page and the HSTouch Device List. I'll have to send an e-mail to Rich and ask what's going on.

          Regards,
          Ultrajones
          Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

          Comment


          • #6
            In the meantime as UltraJones sorts this out you can use events that fire on button press or release. I have 40 or so to drive all my remotes. This one happens to come from a WII remote but the notion works on my HS Touch screens as well.

            Chris
            Attached Files

            Comment


            • #7
              I'm finally getting around to doing my HSTouch screens too...

              And would really appreciate a good method to map UltraGCIR device to an aircon IR blast (simplified: OFF, 18'C, 19'C, 20'C, 21'C, 22'C, 23'C, 24'C).
              HW: HS3 w/ Win8.1 on ASRock C2550d4i. Digi AnywhereUSB, Hubport, Edgeport, UZB, Z-trollers, PLCBUS, SONOS, GC-100, iTach IP2SL, WF2IR, IP2IR, RFXtrx433, Harmony Hubs, Hue, Ademco Vista 128BP, NetAtmo, NetAtmo Welcome

              Google Search for HomeSeer Forum

              Comment


              • #8
                i use hs3 released versions of s/w and plugin and it works for me on on amazon fire and ipad....

                I did have one sequencing issue which is important....if you import ir codes in plugin all the codes get a status value(Status Graphics tab)....then in hstouch xml file that 'value' is used...

                When you re-import the ir codes you may (will) get different values.

                Either use the hstouch designer gui to assign/reassign the code you want or do as I did and edit the xml file
                Last edited by dmurphy; January 28th, 2016, 06:35 PM.

                Comment


                • #9
                  Originally posted by Lee_L View Post
                  I am using the same steps to assign a button with the function that MrWassen posted the image of above.

                  Action Type: "control Homeseer device"
                  Device: GlobalCache IR UltraGCIR3 Plugin iTachIP2IR IR Module 1:1
                  Command: Xfinity Channel Up

                  I do not see any entries in the log either. I set it to Debug, but nothing appears when I push the assigned button(s) in HSTouch.
                  I enabled debug with HSTouch and it appears the command being received is NULL.

                  10:58:44:9177 ~ Client command: (mac-min-dev:mac-mini-dev) NULL

                  Regards,
                  Ultrajones
                  Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                  Comment


                  • #10
                    Ok, it's a tad worse than I described....The status value changes even when you add a new code. Then all/most of the codes get new values and everything in hstouch doesn't work until the correct status value is sent....

                    Comment

                    Working...
                    X