Announcement

Collapse
No announcement yet.

Power and Connection control - Device turns back on

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Power and Connection control - Device turns back on

    Hello,

    if I leave the plugin in the Connect state but turn off the receiver it will turn back on due I assume by some data on the com port which signals the VSX-84TSxi to turn back on.

    It won't turn back on if I disconnect.

    Is there a way not to poll while in the Off but connect state? Or allow the connection to be automated? Or toggle the connection state by the Power control?

    Thanks
    Michael

  • #2
    That should not happen unless something changes the device value of the "Pioneer AVR Power" device. What log entries are written to the HomeSeer log when the receiver turns back on?

    Regards,
    Ultrajones
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

    Comment


    • #3
      Same issue - VSX-92TXH

      The same issue happens on the VSX-92TXH. Most likely due to the response being different then the 2010 commands the plugin uses (my assumption).

      Further, when I toggle the power off to the 92TXH via the plugin, the unit powers back up after a few minutes. The debug is:

      Code:
      5/30/2011 11:43:25 AM 	UltraPioneerAVR Debug 	Command response received by Pioneer AVR.
      5/30/2011 11:43:25 AM 	UltraPioneerAVR Debug 	Entered ProcessReceived() function with a string 'R '
      5/30/2011 11:43:25 AM 	UltraPioneerAVR Debug 	Entered Serial DataReceived() function.
      5/30/2011 11:43:16 AM 	UltraPioneerAVR Debug 	Waited 2656 milliseconds for the command response.
      5/30/2011 11:43:16 AM 	UltraPioneerAVR Debug 	The Pioneer AVR is powered on.
      5/30/2011 11:43:16 AM 	UltraPioneerAVR Debug 	Power=On
      5/30/2011 11:43:16 AM 	UltraPioneerAVR Debug 	The SetIO call was generated locally, no action required.
      5/30/2011 11:43:16 AM 	UltraPioneerAVR Debug 	Entered SetIO() subroutine.
      5/30/2011 11:43:16 AM 	UltraPioneerAVR Debug 	Locally generated SetDeviceValue for %10 to 0, triggers True
      5/30/2011 11:43:16 AM 	UltraPioneerAVR Debug 	Processing response [PWR]
      5/30/2011 11:43:16 AM 	UltraPioneerAVR Debug 	Command PWR response received by Pioneer AVR.
      5/30/2011 11:43:16 AM 	UltraPioneerAVR Debug 	Entered ProcessCommand() subroutine.
      5/30/2011 11:43:16 AM 	UltraPioneerAVR Debug 	Entered ProcessReceived() function with a string 'PWR0 '
      5/30/2011 11:43:16 AM 	UltraPioneerAVR Debug 	Entered Serial DataReceived() function.
      5/30/2011 11:43:14 AM 	UltraPioneerAVR Debug 	Entered ProcessReceived() function with a string 'R '
      5/30/2011 11:43:14 AM 	UltraPioneerAVR Debug 	Entered Serial DataReceived() function.
      5/30/2011 11:43:14 AM 	UltraPioneerAVR Debug 	Entered ProcessReceived() function with a string 'R '
      5/30/2011 11:43:14 AM 	UltraPioneerAVR Debug 	Entered Serial DataReceived() function.
      5/30/2011 11:43:14 AM 	UltraPioneerAVR Debug 	Waiting for the Pioneer AVR to respond with 'PWR' for up to 4 seconds...
      5/30/2011 11:43:14 AM 	UltraPioneerAVR Debug 	Sending ?P to Pioneer AVR serial port.
      5/30/2011 11:43:14 AM 	UltraPioneerAVR Debug 	Entered SendToPAVR() function.
      5/30/2011 11:43:13 AM 	UltraPioneerAVR Debug 	Sending to Pioneer AVR serial port.
      5/30/2011 11:43:13 AM 	UltraPioneerAVR Debug 	Entered SendToPAVR() function.
      5/30/2011 11:43:13 AM 	UltraPioneerAVR Debug 	Sending command: '?P' to Pioneer AVR, attempt # 1
      5/30/2011 11:43:13 AM 	UltraPioneerAVR Debug 	Checking if the Pioneer AVR is powered on...
      5/30/2011 11:43:13 AM 	UltraPioneerAVR Debug 	Watchdog Timer indicates response from Pioneer AVR was received less than 120 seconds ago
      5/30/2011 11:43:03 AM 	UltraPioneerAVR Debug 	Command PF does not produce a result.
      5/30/2011 11:43:03 AM 	UltraPioneerAVR Debug 	Sending PF to Pioneer AVR serial port.
      5/30/2011 11:43:03 AM 	UltraPioneerAVR Debug 	Entered SendToPAVR() function.
      5/30/2011 11:43:03 AM 	UltraPioneerAVR Debug 	Sending command: 'PF' to Pioneer AVR, attempt # 1
      5/30/2011 11:43:03 AM 	UltraPioneerAVR Debug 	Received command PowerOff
      5/30/2011 11:43:03 AM 	UltraPioneerAVR Debug 	Entered SetIO() subroutine.

      Comment


      • #4
        I re-wrote the serial routines. Please download and trying the version I just uploaded to the HomeSeer update. Please provide debug output if it still occurs.

        Regards,
        Ultrajones
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment

        Working...
        X