Announcement

Collapse
No announcement yet.

UltraPioneerAVR HSPI - Support for 22 New 2012 and 2013 Pioneer Receivers

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Originally posted by sparkman View Post
    Hi Randy, I can test it. I've sent you am email as well.

    Cheers
    Al
    Hello Al, let's try this:

    1) Connect you receiver to your local network and ensure its powered off.
    2) Install the UltraPioneerAVR3 plug-in from the HomeSeer updater, then enable it.
    3) From the Receivers tab, confirm the receiver is discovered and the model number is VSX-1124.
    4) Now update the model number from VXS-1124 to VSX-1123, then restart the plug-in.
    5) From the Receivers tab, confirm the receiver model number is still VSX-1123.
    6) Power on the receiver and watch the logs to determine if it detected the powered on stated.
    7) Wait about 1 minute, then visit the AVR Devices web page to determine what was detected.

    At this point, everything under Master Controls, Zone2 Controls, Zone4 Controls, Channel Level, Audio Information, Video Information, Video Function, DSP Function, AMP Function, Tuner Function and Misc Function should have values. If not, try manually putting on a video source and an audio source so those value populate.

    If it appears to be working at this point, then try creating devices and controlling your receiver with the HS devices that gets created. You should also be able to use the remote control and change input, volume etc. and you should see those changes reflected in the HS devices that get created.

    Please report back if that works. If not, we will try plan b.

    Regards,
    Ultrajones
    Last edited by Ultrajones; March 21st, 2015, 10:26 AM.
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

    Comment


    • #62
      Hi Randy,

      All seems to work doing that, except for step 5, the receiver model number stays at VSX-1123.

      I do see some warnings in the log (each repeated 4 times):

      Code:
      Mar-21 8:40:14 AM	 	Warning	No response/improper response from Pioneer AVR device '192.168.1.206:23' to command '?ZEP'. Your Pioneer AVR may not support the feature 'Zone3 Power'.
      Mar-21 8:40:05 AM	 	Warning	No response/improper response from Pioneer AVR device '192.168.1.206:23' to command '?RGB03'. Your Pioneer AVR may not support the feature 'Input Name Information'.
      I'm assuming those are a normal part of the discovery process.

      Thanks
      Al
      HS 3.0.0.532: 1963 Devices 1141 Events
      Z-Wave 3.0.1.261: 122 Nodes on one Z-Net

      Comment


      • #63
        Originally posted by sparkman View Post
        Hi Randy,

        All seems to work doing that, except for step 5, the receiver model number stays at VSX-1123.

        I do see some warnings in the log (each repeated 4 times):

        Code:
        Mar-21 8:40:14 AM	 	Warning	No response/improper response from Pioneer AVR device '192.168.1.206:23' to command '?ZEP'. Your Pioneer AVR may not support the feature 'Zone3 Power'.
        Mar-21 8:40:05 AM	 	Warning	No response/improper response from Pioneer AVR device '192.168.1.206:23' to command '?RGB03'. Your Pioneer AVR may not support the feature 'Input Name Information'.
        I'm assuming those are a normal part of the discovery process.

        Thanks
        Al
        Sorry, item #5 was a typo. I fixed it. Yes, those 2 "No response" warnings are normal for your receiver. You can disable it from the AVR Devices tab so they don't get checked again.

        I'll post an update soon that adds support for the VSX-1124 model so you don't have to manually change the type from VSX-1124 to VSX-1123.

        Regards,
        Ultrajones
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment


        • #64
          Originally posted by Ultrajones View Post
          Sorry, item #5 was a typo. I fixed it. Yes, those 2 "No response" warnings are normal for your receiver. You can disable it from the AVR Devices tab so they don't get checked again.

          I'll post an update soon that adds support for the VSX-1124 model so you don't have to manually change the type from VSX-1124 to VSX-1123.

          Regards,
          Ultrajones
          Thanks Randy!

          Cheers
          Al
          HS 3.0.0.532: 1963 Devices 1141 Events
          Z-Wave 3.0.1.261: 122 Nodes on one Z-Net

          Comment


          • #65
            New receivers announced!
            http://www.soundandvision.com/conten...equipped-av-rs
            _______________________________________________

            HS3 : HSpro (3.0.0.460) on Win2012 (vm on ESXi)
            Plugins: HSTouch, UPBSpud, Kinect, Nest, IFTTT, DirecTV, EasyTrigger, Imperihome, Zwave, RFXcom, UltraMon3, UltraWeatherBug3, UltraGCIR3, UltraLog3, UltraPioneer, PHLocation, Pushover, Pushalot, MCSSPrinklers S, JowiHue
            Jon00 Plugins: Bluetooth Proximity, Performance Monitor, DB Chart, Links

            Comment


            • #66
              Ultrajones,
              My vsx 1121 just turned into a paper weight. So I need to get something pretty soon and am considering the vsx 1124. But I also see the new model coming out which is a vsx 1130. Pricing that I've seen seems pretty close to the same on both models so of course I would rather go with the newer version. Or is that too risky because it might not work with this plugin?
              John

              Comment


              • #67
                VSX-1130-K ?

                Gurus,

                My amp just went belly up and I'm looking for a replacement. I like the VSX-1123-K since it was recommended as a decent amp fully vetted with HS. I ran into the VSX-1130-K which seems similar but has Bluetooth which seems an advantage. Does the VSX-1130-K work with the UltraPioneer plugin? I looked all over and didn't see it listed specifically.


                Thanks in advance,

                Leo

                Comment


                • #68
                  Yes, it should work with the plug-in with a simple work-around (http://board.homeseer.com/showpost.p...7&postcount=61). However, I am updating the plug-in to officially support the 2015 receivers. I'll be posting an update when done.

                  Regards,
                  Ultrajones
                  Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                  Comment


                  • #69
                    Originally posted by Ultrajones View Post
                    Yes, it should work with the plug-in with a simple work-around (http://board.homeseer.com/showpost.p...7&postcount=61). However, I am updating the plug-in to officially support the 2015 receivers. I'll be posting an update when done
                    Just ordered a VSX-1130-k for delivery this week-end. Planning on using the work around. Will that cause any issues when the plug-in formally supports the 2015 models? If so I can wait a bit to bring it into the mix.

                    Chris

                    Comment


                    • #70
                      Originally posted by dcdelong View Post
                      Just ordered a VSX-1130-k for delivery this week-end. Planning on using the work around. Will that cause any issues when the plug-in formally supports the 2015 models? If so I can wait a bit to bring it into the mix.

                      Chris
                      The version I released yesterday adds basic support for the 2014 and 2015 models. I am still going though the documentation to see what other new options I'll be adding to the plug-in.

                      Regards,
                      Ultrajones
                      Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                      Comment


                      • #71

                        Comment


                        • #72
                          http://board.homeseer.com/showpost.p...7&postcount=61. Everything seemed to go well and after installation I have a large list of devices grouped under PAVR1 Master Controls and PAVR1 Channel Level.

                          As recommended I then tried to create events using the listed devices.

                          PROBLEM: The only devices that would respond to the events I created were Power on/off, and Mute.

                          Please advise, is there an additional step I am missing or a configuration change I missed?

                          Thank you

                          Comment


                          • #73
                            Originally posted by morrisdlx View Post
                            Hi, I am in my initial setup of all AV and home automation. I have a Homeseer S6 PRO and a Pioneer VSX-1130K. I have downloaded the UltaPioneerAV3 plugin to test before buying. I followed the recommended install steps listed at http://board.homeseer.com/showpost.p...7&postcount=61. Everything seemed to go well and after installation I have a large list of devices grouped under PAVR1 Master Controls and PAVR1 Channel Level.

                            As recommended I then tried to create events using the listed devices.

                            PROBLEM: The only devices that would respond to the events I created were Power on/off, and Mute.

                            Please advise, is there an additional step I am missing or a configuration change I missed?

                            Thank you
                            Hello, I assume the receiver is turned on when you're trying to control the receiver. Can you tell me if you're able to manually control the receiver using the HomeSeer devices that were created? Is there anything written to the HomeSeer log?

                            Regards,
                            Ultrajones
                            Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                            Comment


                            • #74
                              UltraJones,

                              Sorry the slow response, I have been tied up with getting moved in. To you question, "Hello, I assume the receiver is turned on when you're trying to control the receiver. Can you tell me if you're able to manually control the receiver using the HomeSeer devices that were created? Is there anything written to the HomeSeer log?"

                              PWR and MUTE are working. I tried other devices with manually with no success. I also retried the events, and still can only get PWR and MUTE to work. I have clipped the log entries for your review. Please note, I have an email configuration that I will address.

                              Thank you for any help you can provide.

                              Morrisdlx


                              Dec-09 11:17:44 PM Error Unable to connect to POP server(1) pop3.live.com Error: authentication failed

                              Dec-09 11:16:56 PM HSTouch Server Debug 11:16:56:0150 ~ String change event, value is: 0

                              Dec-09 11:16:56 PM HSTouch Server Debug 11:16:56:0121 ~ String change event for PAVR1_listening-mode to string:AUTO SURROUND Straight Decode

                              Dec-09 11:16:53 PM HSTouch Server Debug 11:16:53:6523 ~ String change event, value is: 0

                              Dec-09 11:16:53 PM HSTouch Server Debug 11:16:53:6503 ~ String change event for PAVR1_listening-mode to string:STEREO

                              Dec-09 11:16:22 PM HSTouch Server Debug 11:16:22:4272 ~ String change event, value is: 0

                              Dec-09 11:16:22 PM HSTouch Server Debug 11:16:22:4247 ~ String change event for PAVR1_listening-mode to string:AUTO SURROUND Straight Decode

                              Dec-09 11:16:02 PM HSTouch Server Debug 11:16:02:3860 ~ String change event, value is: 0

                              Dec-09 11:16:02 PM HSTouch Server Debug 11:16:02:3840 ~ String change event for PAVR1_listening-mode to string:STEREO

                              Dec-09 11:10:50 PM HSTouch Server Debug 11:10:50:0460 ~ String change event, value is: 0

                              Dec-09 11:10:50 PM HSTouch Server Debug 11:10:50:0430 ~ String change event for PAVR1_listening-mode to string:AUTO SURROUND Straight Decode

                              Dec-09 11:10:33 PM HSTouch Server Debug 11:10:33:1470 ~ String change event, value is: 0

                              Dec-09 11:10:33 PM HSTouch Server Debug 11:10:33:1445 ~ String change event for PAVR1_listening-mode to string:STEREO

                              Dec-09 11:07:42 PM Error Unable to connect to POP server(1) pop3.live.com Error: authentication failed

                              Dec-09 11:00:57 PM HSTouch Server Debug 11:00:57:7810 ~ String change event, value is: 0

                              Dec-09 11:00:57 PM HSTouch Server Debug 11:00:57:7785 ~ String change event for PAVR1_listening-mode to string:AUTO SURROUND Straight Decode

                              Dec-09 11:00:29 PM HSTouch Server Debug 11:00:29:3157 ~ String change event, value is: 0

                              Dec-09 11:00:29 PM HSTouch Server Debug 11:00:29:3137 ~ String change event for PAVR1_listening-mode to string:STEREO

                              Dec-09 10:58:16 PM HSTouch Server Debug 10:58:16:6238 ~ String change event, value is: 0

                              Dec-09 10:58:16 PM HSTouch Server Debug 10:58:16:6208 ~ String change event for PAVR1_listening-mode to string:AUTO SURROUND Straight Decode

                              Dec-09 10:57:58 PM HSTouch Server Debug 10:57:58:4876 ~ String change event, value is: 0

                              Dec-09 10:57:58 PM HSTouch Server Debug 10:57:58:4866 ~ String change event for PAVR1_listening-mode to string:STEREO

                              Dec-09 10:57:40 PM Error Unable to connect to POP server(1) pop3.live.com Error: authentication failed

                              Dec-09 10:57:39 PM HSTouch Server Debug 10:57:39:0574 ~ String change event, value is: 0

                              Dec-09 10:57:39 PM HSTouch Server Debug 10:57:39:0544 ~ String change event for PAVR1_listening-mode to string:AUTO SURROUND Straight Decode

                              Dec-09 10:57:10 PM HSTouch Server Debug 10:57:10:3830 ~ String change event, value is: 0

                              Dec-09 10:57:10 PM HSTouch Server Debug 10:57:10:3800 ~ String change event for PAVR1_listening-mode to string:STEREO

                              Dec-09 10:53:21 PM HSTouch Server Debug 10:53:21:9663 ~ Value change ref:69 Address:PAVR1_main-mute NewVal: 1OldVal: 0

                              Dec-09 10:53:18 PM HSTouch Server Debug 10:53:18:5683 ~ Value change ref:69 Address:PAVR1_main-mute NewVal: 0OldVal: 1

                              Dec-09 10:52:13 PM HSTouch Server Debug 10:52:13:0556 ~ String change event, value is: 0

                              Dec-09 10:52:13 PM HSTouch Server Debug 10:52:13:0526 ~ String change event for PAVR1_listening-mode to string:AUTO SURROUND Straight Decode

                              Dec-09 10:52:12 PM HSTouch Server Debug 10:52:12:9698 ~ Value change ref:72 Address:PAVR1_listening-mode-setting NewVal: 5OldVal: 50

                              Dec-09 10:49:28 PM Event Event Trigger "Manage AV Vol-Down"

                              Dec-09 10:49:28 PM Event Event Manage AV Vol-Down triggered by the event page 'Run' button.

                              Dec-09 10:49:27 PM Event Event Trigger "Manage AV Vol-Down"

                              Dec-09 10:49:27 PM Event Event Manage AV Vol-Down triggered by the event page 'Run' button.

                              Dec-09 10:49:24 PM Event Event Trigger "Manage AV Vol-Up"

                              Dec-09 10:49:24 PM Event Event Manage AV Vol-Up triggered by the event page 'Run' button.

                              Dec-09 10:49:22 PM Event Event Trigger "Manage AV Vol-Up"

                              Dec-09 10:49:22 PM Event Event Manage AV Vol-Up triggered by the event page 'Run' button.

                              Comment


                              • #75
                                hello

                                i want use this plugin but it writes me :

                                warning : failed getting interfacestatus from ultrapioneer avr3 - the interface was not found in the list of active interfaces , the list may need to be refreshed.

                                i dont understand why ?

                                i uninstalled the installed but not works

                                Comment

                                Working...
                                X