Announcement

Collapse
No announcement yet.

UltraPioneerAVR HSPI - Support for 22 New 2012 and 2013 Pioneer Receivers

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Thank you Randy.

    Checked the main menu stuff on the Pioneer VSX-44 and adjusted it as you specified above.

    Still seeing plug in disconnects on and off when sending commands. It's not really much of an issue though as basically the AVR device is just turned on and one of two inputs is utilized. IE: I utilize KODI for music collection, streaming services, live TV et al. DTV is DTV. (It's been like that for a few years now).

    @Al; noticed that I cannot set the input to one HDMI and utilize the optical audio at the same time on the Pioneer VSX44. I do not see the option using the remote or on the main OSD receiver menu. Just for this set up will probably go to using a box (found a Mono Price one) that combines digital audio (coaxial or optical) to an HDMI signal.
    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.00
    Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.00

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

    Comment


    • SC-LX801

      Just switched out my receiver to a SC-LX801 and unfortunately I am not able to connect. It is using port 60128 but log is showing no response to any commands. I have tried telnet into this port. And I do get in. But no commands seem to work. No response at port 8102 which is what my old pioneer receiver used. Please help

      I found this list of commands. But I don't know how to test if they work: https://www.snapav.com/wcsstore/Exte...0Protocol.xlsx

      Comment


      • SC-LX801 doesn't work with my plug-in. Pioneer switched to another protocol for their newer receivers after they were purchased by Onkyo.

        Regards,
        Ultrajones
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment


        • Support Pioneer SC-LX90 ?

          Hi

          Will this plugin support my Pioneer SC-LX90, the amp has RS232 and RJ45.

          Br
          Kim

          Comment


          • Originally posted by Kim View Post
            Hi

            Will this plugin support my Pioneer SC-LX90, the amp has RS232 and RJ45.

            Br
            Kim
            I don't think so. I think that one uses the Onkyo API.
            Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

            Comment


            • Do you have any plans on adding this support to the plugin? What do you need to do so?


              Sent from my iPhone using Tapatalk
              _______________________________________________

              HS3 : HSpro (3.0.0.460) on Win2012 (vm on ESXi)
              Plugins: HSTouch, UPBSpud, Kinect, Nest, IFTTT, DirecTV, EasyTrigger, Imperihome, Zwave, RFXcom, UltraMon3, UltraWeatherBug3, UltraGCIR3, UltraLog3, UltraPioneer, PHLocation, Pushover, Pushalot, MCSSPrinklers S, JowiHue
              Jon00 Plugins: Bluetooth Proximity, Performance Monitor, DB Chart, Links

              Comment


              • Originally posted by jlrichar View Post
                Do you have any plans on adding this support to the plugin? What do you need to do so?


                Sent from my iPhone using Tapatalk
                Very unlikely anytime soon. I would need motivation to purchase a new Pioneer Receiver. The 2 I have are working fine.

                Regards,
                Ultrajones
                Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                Comment


                • Good afternoon,

                  I saw a discussion in this thread back from 2013 about the VSX-1023-K and you noted that it was not supported. Just a quick question: is this do to a limitation on the receiver side?

                  Comment


                  • Originally posted by cloomis View Post
                    Good afternoon,

                    I saw a discussion in this thread back from 2013 about the VSX-1023-K and you noted that it was not supported. Just a quick question: is this do to a limitation on the receiver side?
                    Yes, that is correct. It's not officially listed in the RS232 protocol specifications. However, if the iPhone app works with it, then you could simply just update the plug-in to use the same port as the iPhone. If you do this, then you wouldn't be able to use the iPhone app to control your receiver because the VSX-1023-K model only allows 1 connection.

                    Regards,
                    Ultrajones
                    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                    Comment


                    • Trying to Setup a SC-LX701 and same issue as above as expected. Funny thing is on a network scan it actually comes up as an ONKYO device...

                      Will try using the Onkyo Plug in to see if by any chance that works.

                      Comment


                      • So yea...

                        The Onkyo Plugin works SEAMLESSLY with the new Pioneer Units. Just input the IP had to change the volume status graphic to go to 200 and works.

                        Comment


                        • Originally posted by Ultrajones View Post
                          Yes, that is correct. It's not officially listed in the RS232 protocol specifications. However, if the iPhone app works with it, then you could simply just update the plug-in to use the same port as the iPhone. If you do this, then you wouldn't be able to use the iPhone app to control your receiver because the VSX-1023-K model only allows 1 connection.

                          Regards,
                          Ultrajones
                          Thanks for the reply. That is what I suspected. I'll try the workaround you suggested.

                          Cheers!

                          Comment


                          • Hi,

                            Trying this out with Pioneer Elite SC-79. Most functionality seems OK but Tone Control, Treble, Bass, and LEF ATT (sic) only get status updates but cannot send any commands (or can about 1 in 100 times). All other functions (at this point in my testing) can send commands and receive status. Any thoughts?

                            Thanks,

                            Andrew

                            Comment


                            • Originally posted by anevard View Post
                              Hi,

                              Trying this out with Pioneer Elite SC-79. Most functionality seems OK but Tone Control, Treble, Bass, and LEF ATT (sic) only get status updates but cannot send any commands (or can about 1 in 100 times). All other functions (at this point in my testing) can send commands and receive status. Any thoughts?

                              Thanks,

                              Andrew
                              Hello Andrew,

                              The Pioneer receiver ignores tone control changes if the listening mode doesn't allow it. I don't recall which modes also changes.
                              Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                              Comment


                              • I see the compatible list includes the SC-91, but the forum seems to exclude it. Is this model compatible? If not, when might it be? Thanks.

                                Comment

                                Working...
                                X