Announcement

Collapse
No announcement yet.

No response/improper response

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No response/improper response

    Hello,

    I have been using the UltraPioneerAVR plugin with my Pioneer VSX1122 for a year. The last month the receiver reacts very slow to commands from the plugin. Events are not usable anymore, because sometimes there is more then 10 seconds between sending a command and the receiver to react.

    In the log I get messages like:
    8-8-2013 22:39:16 - UltraPioneerAVR Wa - No response/improper response from Pioneer AVR device '192.168.0.7:23' to command '19FN'. Your Pioneer AVR may not support the feature 'Input'.
    8-8-2013 22:38:27 - UltraPioneerAVR Wa - No response/improper response from Pioneer AVR device '192.168.0.7:23' to command '45ZS'. Your Pioneer AVR may not support the feature 'Zone2 Input'.

    8-8-2013 22:37:01 - UltraPioneerAVR Wa - No response/improper response from Pioneer AVR device '192.168.0.7:23' to command '?HO'. Your Pioneer AVR may not support the feature 'HDMI Output Select'.

    These are results of the system state refresh and cause the delays.

    Anyone got an idea on how to solve this?

    Thx.

  • #2
    Yes, the documentation explains how you can disable features that are not supported by your receiver.
    Enable/Disable Pioneer A/V Receiver Feature:
    The UltraPioneerAVR HSPI supports the ability to enable or disable features supported by various Pioneer A/V Receivers. Disabling features not supported by your Pioneer A/V Receiver will greatly reduce the time it takes to refresh the status when your receiver is powered on. You can simply
    unselect the Feature Enabled checkbox so the UltraPioneerAVR receiver no longer attempts to determine the status of a feature not supported by your Pioneer A/V Receiver.

    Please note: Some features may only return a valid response depending on what inputs, outputs and listening modes are selected. Refer to your Pioneer A/V Receiver documenation for a list of supported features.

    From the web page used to create a HomeSeer device, you'll simply unselect the "Feature Enabled" checkbox, then click save. This should cause the plug-in to no longer attempt to get the status of that feature on startup/refresh.

    Let me know if that helps. Complete refresh should take less than 10 seconds or so.

    Regards,
    Ultrajones
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

    Comment


    • #3
      Hello UJ,

      Is disabled all features I'm not using. The refresh now takes less then 10 seconds.
      Strange thing is that some of the invalid responses involve features I am using.

      Anyway, everything seems to be working fine now. Thanks a lot!

      Comment

      Working...
      X