Announcement

Collapse
No announcement yet.

Isuses with Pioneer Receivers and the Amazon Echo

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Isuses with Pioneer Receivers and the Amazon Echo

    I own the Pioneer VSX-1123-K and a VSX-1121-K Receivers. I have them connected to one network switch and they are all on the subnet 192.168.2.0/24. I have had this setup for several years and it has been very stable. However, I recently purchased and installed several Amazon Echo devices (sold by Amazon) and started experiencing issues with all my Pioneer receivers. In particular, I started to notice Apple Airplay cuts out about every 20-30 minutes. I also noticed HomeSeer was being disconnected by the Pioneer receivers when I lost Airplay connectivity.

    In a nutshell, the Ethernet interfaces on all of my Pioneer Receivers are resetting (at exactly the same time) as a result of a UPnP/SSDP packet being sent by the Amazon Echo. I can duplicate the issue 100% of the time by simply asking my Amazon Echo to “discover devices”. This results in a UPnP/SSDP packet to be broadcast on my local LAN (it’s part of the UPnP/SSDP protocol). Unfortunately, the UPnP/SSDP packet sent by the Amazon Echo causes the Pioneer Receiver Ethernet Interface to reset. I was able to prove this by purchasing a switch that sends an SNMP trap whenever a switch port changes state. Packet captures also shows the Pioneer Receiver resets the Ethernet interface because the first packet sent after it comes back online is a DHCPDISCOVER. I tried setting a static IP, but that didn’t help (cause the Pioneer Receiver is resetting the Ethernet Interface which causes all connected devices to disconnect). I was also able to prove this by capturing packets to see the Pioneer Receiver is sending a TCP RST packet to any connected TCP client (e.g. my home automation system) prior to the Interface resetting.

    If you are also experiencing this issue, please contact Pioneer support.

    Possible work-around:
    • Purchase a network switch that can block UDP traffic by source IP (e.g. Netgear GS108T currently $72 at Amazon).
    • Connect your Pioneer Receivers to the new switch and connect the new switch to your existing network via port 1.
    • Assign a static IP address to each Amazon Echo using DHCP.
    • Add an IP Extended Rule to block all UDP traffic from the IP address you assigned to your Amazon Echo and assign that rule to port 1.


    Regards,
    Ultrajones
    Attached Files
    Last edited by Ultrajones; August 1st, 2015, 08:41 AM.
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

  • #2
    Thanks for the investigation! I don't use Airplay with my Pioneer receive too often, however the past couple of uses I couldn't understand why my receiver was disconnecting, alas I now have an Echo. Great, something else to work on.

    Thanks Ultrajones!
    Mike

    Comment


    • #3
      Having the same issues with my 4 receivers since adding the Echo, having to unplug all receivers and repower is not fun. I put zwave plugs on each for now so resets are easy enough until a fix surfaces.

      John

      Comment


      • #4
        Thanks Ultra - knowing the cause is more than half the battle.

        Question - is it JUST when the Echo discovers devices? Does that mean that if I do not tell it to discover devices I do not have to worry about it?

        I have a ton of Z-Wave modules, so I am thinking of trying John's solution and have it kill the power to the receiver if the plug-in reports it disconnected for a period of time.
        Regards,

        Rick Tinker (a.k.a. "Tink")

        Comment


        • #5
          Originally posted by Rick Tinker View Post
          Thanks Ultra - knowing the cause is more than half the battle.

          Question - is it JUST when the Echo discovers devices? Does that mean that if I do not tell it to discover devices I do not have to worry about it?

          I have a ton of Z-Wave modules, so I am thinking of trying John's solution and have it kill the power to the receiver if the plug-in reports it disconnected for a period of time.
          Hello Rick,

          The Amazon Echo appears to occasionally send the sequence of packets that kills the Pioneer Ethernet interface at least once every 20-30 minutes. The only solution I am aware of is to isolate the Amazon Echo devices from the network the Pioneer receivers are connected to.

          I tried really hard to contact Pioneer to let them know what I found, but they never responded to the many e-mails I sent to them.

          Regards,
          Ultrajones
          Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

          Comment


          • #6
            Hey Ultrajones,

            I am a customer of your excellent UltraPioneer plugin and suffering the same problems you have referred to!

            I bought a GS108T and inserted it between my 2 pioneer receivers...but something I'm doing is just plain wrong as I still get gazillions of:

            Code:
            Family AVR Master UltraPioneerAVR3 Plugin SC-1223 Connection changed from 1 to 0 (PAVR2_Connection)Name: SC-1223 Connection
            followed by loads of errors like this:

            Code:
            No response/improper response from Pioneer AVR device '192.168.1.138:23' to command '?P'. Your Pioneer AVR may not support the feature 'Power'.
            In my case, I have so many Alexa's that I would rather block by destination (I only have two receivers) than by source.

            So I set up an extended ACL for each receiver that says:
            Action: Deny,
            Match Every: False,
            Protocol Type: UDP,
            Src IP: 192.168.1.1, Src IP MAsk: 0.0.0.255,
            Dest IP: 192.168.1.127 Dest IP Mask: 0.0.0.0

            With a Permit/True at the end.
            I've bound the rules to all ports and it shows up in the Binding Table - but to no avail.

            Any ideas? (By the way, I don't need any DLNA access to my receivers...the only control I need is your port:23 stuff).

            Thanks.

            Comment


            • #7
              Originally posted by skavan View Post
              Hey Ultrajones,

              I am a customer of your excellent UltraPioneer plugin and suffering the same problems you have referred to!

              I bought a GS108T and inserted it between my 2 pioneer receivers...but something I'm doing is just plain wrong as I still get gazillions of:

              Code:
              Family AVR Master UltraPioneerAVR3 Plugin SC-1223 Connection changed from 1 to 0 (PAVR2_Connection)Name: SC-1223 Connection
              followed by loads of errors like this:

              Code:
              No response/improper response from Pioneer AVR device '192.168.1.138:23' to command '?P'. Your Pioneer AVR may not support the feature 'Power'.
              In my case, I have so many Alexa's that I would rather block by destination (I only have two receivers) than by source.

              So I set up an extended ACL for each receiver that says:
              Action: Deny,
              Match Every: False,
              Protocol Type: UDP,
              Src IP: 192.168.1.1, Src IP MAsk: 0.0.0.255,
              Dest IP: 192.168.1.127 Dest IP Mask: 0.0.0.0

              With a Permit/True at the end.
              I've bound the rules to all ports and it shows up in the Binding Table - but to no avail.

              Any ideas? (By the way, I don't need any DLNA access to my receivers...the only control I need is your port:23 stuff).

              Thanks.
              Hello skavan,

              Can you check out the screenshot to see if rule 6 looks like the one you added? I think you may need to change the source from 192.168.1.1 to 192.168.1.0. I have not yet tested rule 6, but I assume the source mask 0.0.0.255 is appropriate.

              Regards,
              Ultrajones
              Attached Files
              Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

              Comment


              • #8
                Yep - I match. Doesn't seem to work though.
                I've even tried leaving the source fields blank (i.e. everything) - doesn't work either. Scratching my head.

                Also - another quirk...
                When I try your way -- filtering each specific alexa -- it works...but only if I bind the rule to the incoming port, rather then the port the receiver is connected to. This seems illogical to me. Perhaps I'm misunderstanding quite how the ACL stuff works.

                Comment


                • #9
                  Thank you all for both discovering this and solving it! About six months ago my pioneer sc-71 stopped responding to any network commands, and only worked again after unplugging and plugging it back in. Randomly I was looking through devices that were having connectivity issues and noticed the date of the last time the pioneer responded. Then several minutes later, on an unrelated search, I saw the date I purchased my first echo while browsing amazon. *click* Go to google, find this thread, giant sigh of relief. I bought the netgear, and now after some tweaking I have my pioneer control back. (Plus some other nifty network filters). I found the same thing of needing to bind to the incoming traffic port. In my case I also had an access point on the same switch that was being connected to by one of the echos so I had to assign the rules to multiple ports.

                  I wish pioneer would address some of these, but at least it is possible to work around! Thanks!

                  Comment


                  • #10
                    Although I don't use Amazon Echos. I have a Pioneer VSX-2020 (With UltraPioneerAVR 3 plugin) set with a static IP address. And quite a few Netgear switches.
                    Now I can't say that feel your pain or neither can I recreate the Echo problem. All that I can suggest is update switch firmware and always restart the switch after any configurations in the switch! I say this from experience that I once even tried to replace network cards after updating software for cards on the server The switch knocks them off line until it's restarted! This here unrelated but may also help: https://www.flashrouters.com/blog/20...up-vlan-ddwrt/



                    Eman.
                    The Closer.

                    Comment


                    • #11
                      I am setting up a deny rule on a Dlink DIR 880l. What UDP port is this pioneer killing packet broadcast on by the Alexa device? SSDP 1900?

                      Glad I found this thread as since setting up the Echo the Pioneer receiver SC-1223 keeps having this problem described. Just gotta figure out how to setup a rule in my router.
                      Last edited by srodgers; January 3rd, 2017, 11:05 PM.

                      Comment


                      • #12
                        Yamaha RX-V675

                        Hi everyone. I have a Yamaha RX-V675 and have been having problems with my Amazon Echo for over a year now. I tried isolating the Echo on a guest LAN, but it had issues while playing music. My receiver would completely lose connectivity after a few minutes of being on the network. Very frustrating!!

                        I captured traffic via wireshark and found the same problem reported by Ultrajones: SSDP broadcasts from the Echo appeared to be causing network problems on my receiver.

                        Since I am running DD-WRT on my router, I was in the process of nailing down the syntax to block port 1900 on the receiver when I noticed that I hadn't installed the latest firmware (7/2016) update available for my Yamaha. After installing it, It's been up and running for several days now with no issues.

                        I just wanted to let everyone know that this isn't a problem exclusive to the Pioneers. Perhaps these receivers run a common kernel that's susceptible to SSDP broadcast problems?

                        I hope this is resolved for my receiver and wish you all resolution soon too. If it continues, I will renew my iptables approach.

                        Comment


                        • #13
                          Problem solved with a simple fix. Just created a separate guest SSID WiFi with no access to lan just internet. Alexa is on this network and works great now and cant kill my receiver.


                          Sent from my iPhone using Tapatalk

                          Comment


                          • #14
                            Originally posted by srodgers View Post
                            Problem solved with a simple fix. Just created a separate guest SSID WiFi with no access to lan just internet. Alexa is on this network and works great now and cant kill my receiver.


                            Sent from my iPhone using Tapatalk
                            But can you still use the Echo to control devices on your local network?
                            Regards,

                            Rick Tinker (a.k.a. "Tink")

                            Comment


                            • #15
                              I have not had much time to bother trying to address this the right way, but what I did which I thought would work was to use the plug-in's connection status. When it said it was disconnected, I would kill the power to the receiver with a module, turn it back on after a few seconds, then force the plug-in to re-connect. Unfortunately, while this worked before, the current version of the plug-in does not have it working. It never re-connects on command. Even if I use the Pioneer app on my phone and that can re-connect, the plug-in cannot. If, on the other hand, I completely turn off/disable the plug-in and then restart it, then it connects just fine. So something about the re-connect is not working right.
                              Regards,

                              Rick Tinker (a.k.a. "Tink")

                              Comment

                              Working...
                              X