Announcement

Collapse
No announcement yet.

Error on Network Interruption

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error on Network Interruption

    Hi Randy,

    The UltraPioneer plugin is working great for me overall. I have one request though. When I have a network interruption, the following errors are shown in the log:

    Feb-01 5:01:39 PM 1 Error System.IO.IOException: Unable to write data to the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host at System.Net.Sockets.Socket.Send(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags) at System.Net.Sockets.NetworkStream.Write(Byte[] buffer, Int32 offset, Int32 size) --- End of inner exception stack trace --- at System.Net.Sockets.NetworkStream.Write(Byte[] buffer, Int32 offset, Int32 size) at HSPI_ULTRAPIONEERAVR3.PioneerAVR.SendMessageToEthernet(Strin g Message)
    Feb-01 5:01:38 PM 1 Error System.IO.IOException


    Could this be changed to a Warning with maybe a shorter message? I think the UltraGCIR plugin has similar messages when it looses its connection to my GC devices, so if that could be changed as well, that would be great.

    Thanks
    Al
    HS 3.0.0.523: 1984 Devices 1111 Events
    Z-Wave 3.0.1.256: 114 Nodes on one Z-Net

  • #2
    Hi Randy,

    Have you had a chance to consider this?

    Thanks
    Al
    HS 3.0.0.523: 1984 Devices 1111 Events
    Z-Wave 3.0.1.256: 114 Nodes on one Z-Net

    Comment


    • #3
      Yes, that's been on my todo list for a while. I need to catch the System.IO.IOException exception and write a friendly "Unable to Connect" message. However, I still feel it should be an error instead of a warning.

      Regards,
      Ultrajones
      Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

      Comment


      • #4
        I have updated the UltraPioneerAVR3 plug-in to write a friendly error. In this case, the new error will be: Attempted to write to a closed Ethernet stream in SendMessageToEthernet()

        I'll post it in a few minutes.

        Regards,
        Ultrajones
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment


        • #5
          Originally posted by sparkman View Post
          Hi Randy,

          Have you had a chance to consider this?

          Thanks
          Al
          Hi Al, I reviewed the code for UltraGCIR3 HSPI and I am unable to locate where that verbose error is being written. Can you provide a sample please?

          Regards,
          Ultrajones
          Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

          Comment


          • #6
            Originally posted by Ultrajones View Post
            I have updated the UltraPioneerAVR3 plug-in to write a friendly error. In this case, the new error will be: Attempted to write to a closed Ethernet stream in SendMessageToEthernet()

            I'll post it in a few minutes.

            Regards,
            Ultrajones
            Great, thanks Randy!

            Originally posted by Ultrajones View Post
            Hi Al, I reviewed the code for UltraGCIR3 HSPI and I am unable to locate where that verbose error is being written. Can you provide a sample please?

            Regards,
            Ultrajones
            Will try to replicate it and post it when I do.

            Thanks
            Al
            HS 3.0.0.523: 1984 Devices 1111 Events
            Z-Wave 3.0.1.256: 114 Nodes on one Z-Net

            Comment


            • #7
              Hi Randy,

              Here's the one from UltraGCIR. It's quite a bit shorter already, so not as bad

              Feb-06 7:18:04 AM Error Ethernet connection could not be made to 192.168.1.xx:4998 - A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.168.1.xx:4998

              Thanks
              Al
              HS 3.0.0.523: 1984 Devices 1111 Events
              Z-Wave 3.0.1.256: 114 Nodes on one Z-Net

              Comment

              Working...
              X