Announcement

Collapse
No announcement yet.

What Does This Error Mean?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • What Does This Error Mean?

    I'm trying out the Blue Iris plugin and have set up a motion event to test with but instead of firing it throws an error to the Homeseer log. I assume I have misconfigured something but could use a hint as to what this error means so I can figure out what to fix.
    Attached Files

  • #2
    If it helps, this is the string I have configured in "Request from a web service" under the alerts section in the camera configuration in Blue Iris:

    192.168.0.10/JSON?request=pluginfunction&function=Alert&plugin=Blue-Iris&P1=&CAM&P2=&TYPE

    What am I missing?

    Comment


    • #3
      I would check to make sure your plugin is up to date (check the beta section) and the blue iris server has all it's patches. It looks like you are receiving an alert from the blue iris server properly. how do you have your event configured? can you post a snap shot of the event? In the setup of the event there are zones you can configure. they have to match with the zones configured from the BI server.

      Comment


      • #4
        I don't see anything in Blue Iris that corresponds to the zones in the plugin so I checked them all:
        Attached Files

        Comment


        • #5
          Here is the motion config screen in Blue Iris. Where are the zones mentioned?
          Attached Files

          Comment


          • #6
            Originally posted by upstatemike View Post
            Here is the motion config screen in Blue Iris. Where are the zones mentioned?

            under the use mask and hot spot

            Comment


            • #7
              I don't see zones but I can define a hotspot and then make that selection in the event. Still doesn't work.
              Attached Files

              Comment


              • #8
                I looked on mine....if you mask it out, it ignores that spot. it should be all green by using the hotspot. then if you go to the alerts tab you will see the motion zones a-h.

                you should also have a check mark in the post to web address or mqtt server. what version of blue iris are you running? mine is 4.7.5.3 x64

                Comment


                • #9
                  Blue Iris is 3.62.04

                  When I click on Hotspot and draw the rectangle it still paints it red

                  I still don't see what you are referring to on the Alerts Tab
                  Attached Files

                  Comment


                  • #10
                    The Zones refer to the different definable motion zones in BI. This way you can trigger an event on motion in just one specific zone.

                    For your initial error, are you sure you have the URL correct in the "Post to a web address or MQTT server" action on the Alerts tab?
                    Attached Files
                    Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

                    Comment


                    • #11
                      Originally posted by beerygaz View Post
                      The Zones refer to the different definable motion zones in BI. This way you can trigger an event on motion in just one specific zone.

                      For your initial error, are you sure you have the URL correct in the "Post to a web address or MQTT server" action on the Alerts tab?
                      Not sure if the URL is correct or not... I have it set to this:

                      192.168.0.10/JSON?request=pluginfunction&function=Alert&plugin=Blue-Iris&P1=&CAM&P2=&TYPE

                      Does that look right?

                      I also do not have any option to edit motion zones in my version of Blue Iris. If I open the edit screen for "Use mask and hot spot" I only have the option to "edit motion mask".

                      Comment


                      • #12
                        The URL is correct. But I strongly suggest you update your BI to the latest version for compatibility, functionality and security reasons.


                        Sent from my iPhone using Tapatalk
                        Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

                        Comment


                        • #13
                          Originally posted by beerygaz View Post
                          The URL is correct. But I strongly suggest you update your BI to the latest version for compatibility, functionality and security reasons.


                          Sent from my iPhone using Tapatalk
                          OK but not right now. The cost to go from BI 3 to 4 is high enough for me to look at some other priorities ahead of this. I'll try the plugin again down the road after I get around to updating BI.

                          Thanks for the help and thanks to wadesready as well.

                          Comment

                          Unconfigured PHP Module

                          Collapse

                          Working...
                          X