Announcement

Collapse
No announcement yet.

Motion alerts stopped processing.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Motion alerts stopped processing.

    Also noticed these error messages in the log. I did just add some new cameras.

    And, I enable and disable cameras - could this be the Parameter count mismatch? I would prefer to hide/Unhide.

    Motion alerts are not firing in HS3.

    ----------------- Logging started on 2019-01-05 00:21:03.5695 ------------------
    2019-01-05 00:21:03.4985|INFO|HSPI_BI.web_config.postBackProc |Enabling logging to file: C:\Program Files (x86)\HomeSeer HS3\Logs\HSPI_BI.log
    2019-01-05 00:21:07.4066|ERROR|HSPI_BI.HSPI.PluginFunction |Error in PluginProc:Parameter count mismatch.
    System.Reflection.TargetParameterCountException: Parameter count mismatch.
    at System.Reflection.RuntimeMethodInfo.InvokeArgumentsCheck(Obj ect obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    at HSPI_BI.HSPI.PluginFunction(String proc, Object[] parms)
    2019-01-05 00:21:07.4066|ERROR|HSPI_BI.HSPI.PluginFunction |Procedure called: Alert
    2019-01-05 00:21:07.6166|INFO|HSPI_BI.plugin.CheckConfig |Connected to Blue Iris server Home as Homeseer - polling every 30 seconds
    2019-01-05 00:21:42.3373|INFO|HSPI_BI.BlueIris.MyLogin |Successfully logged in to BlueIris server: Home (ver 4.8.4.6) as Homeseer.
    ----------------- Logging finished on 2019-01-05 00:22:05.6718 -----------------




    Click image for larger version  Name:	24619409-3DF6-4367-9285-C8DB7266953D.png Views:	1 Size:	207.6 KB ID:	1272177
    Michael

    HS3 Pro 3.0.0.470 | 849 devices | 349 events | OpenSprinkler | BLShutdown | EasyTrigger | NetCAM | Harmony Hub | Sonos | SDJ-Health | BLUPS | PHLocation | BLBackup | BLLock | Z-Wave 3.0.1.243 | weatherXML | Pushover 3P | Blue-Iris | AirPlaySpeak

  • #2
    I thought it might be short cam names as this seems to be a possible problem with BI when you substitute a new camera with the same name as the old camera. I changed the short names...

    But, no. Frustrating!
    Michael

    HS3 Pro 3.0.0.470 | 849 devices | 349 events | OpenSprinkler | BLShutdown | EasyTrigger | NetCAM | Harmony Hub | Sonos | SDJ-Health | BLUPS | PHLocation | BLBackup | BLLock | Z-Wave 3.0.1.243 | weatherXML | Pushover 3P | Blue-Iris | AirPlaySpeak

    Comment


    • #3
      I also see in the log that the BI PI is nearly constantly logging into BI.

      I sure hope the PI author weighs in soon.

      Click image for larger version

Name:	C651024A-EE25-40B7-B991-55A3217886AF.png
Views:	29
Size:	311.6 KB
ID:	1273722
      Michael

      HS3 Pro 3.0.0.470 | 849 devices | 349 events | OpenSprinkler | BLShutdown | EasyTrigger | NetCAM | Harmony Hub | Sonos | SDJ-Health | BLUPS | PHLocation | BLBackup | BLLock | Z-Wave 3.0.1.243 | weatherXML | Pushover 3P | Blue-Iris | AirPlaySpeak

      Comment


      • #4
        Michael, you posted the OP on the 6th, it's now the 8th - a bit early for the "I sure hope the PI author weighs in soon." comment?

        The error you posted looks like a badly configure web request in the BI alert section. Please can you post the full web request URLs for your cameras (feel free to obfuscate any sensitive data such as IP and credentials)

        As for the "constantly logging in" - this is expected behaviour.
        1. The API token to communicate with BI expires after a period of time and needs to be renewed
        2. The Plugin is set to poll BI to update status information in order to keep the plugin devices current and reflecting the status of your BI cameras & server
        2.1 You can reduce the polling interval in the PI config (per the help file)
        2.2 You could set the log level to only show Warnings and above to reduce this noise in your log (see the help file)
        Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

        Comment


        • #5
          Gavin,

          Thanks for the response. I posted in another thread on the 3rd and PM’d you on the 4th. I started this thread figuring it was lost in the depth of the “Error in Log” thread.

          Here is the URL - they are all the same.

          192.168.0.2/JSON?request=pluginfunction&function=Alert&plugin=Blue-Iris&P=&CAM&P2=&TYPE

          I now see that &P= should be &P1=. For some reason, perhaps because I only had 1 camera triggering alerts, it worked with the incorrect URL. Over the holidays I added a bunch of cameras and configured alert triggers for many of them.

          Michael
          Michael

          HS3 Pro 3.0.0.470 | 849 devices | 349 events | OpenSprinkler | BLShutdown | EasyTrigger | NetCAM | Harmony Hub | Sonos | SDJ-Health | BLUPS | PHLocation | BLBackup | BLLock | Z-Wave 3.0.1.243 | weatherXML | Pushover 3P | Blue-Iris | AirPlaySpeak

          Comment


          • #6
            That would break it. Also make sure there are no spaces or other special characters in your camera short names that might break the url (ampersand, question mark, space, slash, etc)


            Sent from my iPhone using Tapatalk
            Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

            Comment


            • #7
              Originally posted by beerygaz View Post
              That would break it. Also make sure there are no spaces or other special characters in your camera short names that might break the url (ampersand, question mark, space, slash, etc)


              Sent from my iPhone using Tapatalk
              Thanks.

              Michael

              HS3 Pro 3.0.0.470 | 849 devices | 349 events | OpenSprinkler | BLShutdown | EasyTrigger | NetCAM | Harmony Hub | Sonos | SDJ-Health | BLUPS | PHLocation | BLBackup | BLLock | Z-Wave 3.0.1.243 | weatherXML | Pushover 3P | Blue-Iris | AirPlaySpeak

              Comment

              Working...
              X