Announcement

Collapse
No announcement yet.

PluginProc:Exception has been thrown by the target of an invocation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PluginProc:Exception has been thrown by the target of an invocation

    Motion alerts back to BlueIRis seem to be failing?

    Getting this in the log.
    Jun-06 12:12:40 PM Blue-Iris Error Parameter: MOTION
    Jun-06 12:12:40 PM Blue-Iris Error Parameter: Frontdoor
    Jun-06 12:12:40 PM Blue-Iris Error Procedure called: Reset
    Jun-06 12:12:40 PM Blue-Iris Error Error in PluginProc:Exception has been thrown by the target of an invocation.

    Upgraded to BI5 if I run TEST it works but if I put MOTION it fails every time Any help with this would be fantastic

  • #2
    I'm using the following which has been working and just stopped.

    10.1.30.7/JSON?request=pluginfunction&function=Alert&plugin=Blue-Iris&P1=&CAM&P2=&TYPE

    If I do TEST it does work but if I put MOTION or &TYPE is throws the error.

    Comment


    • #3
      Little more information.
      2019-06-06 17:32:51.9307|DEBUG|HSPI_BI.plugin.Alert |Alert TRIGGER from BI received: MOTION on Frontdoor
      2019-06-06 17:32:51.9407|ERROR|HSPI_BI.HSPI.PluginFunction |Error in PluginProc:Exception has been thrown by the target of an invocation.
      System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.IndexOutOfRangeException: Index was outside the bounds of the array.
      at HSPI_BI.plugin.GetMotionZones(String trigger)
      at HSPI_BI.plugin.Alert(String camera, String type, String action)
      at HSPI_BI.HSPI.Alert(String camera, String type)
      --- End of inner exception stack trace ---
      at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
      at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Obj ect obj, Object[] parameters, Object[] arguments)
      at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
      at HSPI_BI.HSPI.PluginFunction(String proc, Object[] parms)
      2019-06-06 17:32:51.9407|ERROR|HSPI_BI.HSPI.PluginFunction |Procedure called: Alert
      2019-06-06 17:32:51.9627|ERROR|HSPI_BI.HSPI.PluginFunction |Parameter: Frontdoor
      2019-06-06 17:32:51.9737|ERROR|HSPI_BI.HSPI.PluginFunction |Parameter: MOTION
      ----------------- Logging finished on 2019-06-06 17:33:10.0779 -----------------

      Comment


      • #4
        I shutdown BI5 and went back to 4 and it works just a FYI. Anyone have Alerts working with BI5?

        Comment


        • #5
          I'm having almost the same problem. Motion won't trigger a HS event in BI5, but no errors in the HS log. Ken at BI support has been trying to help, but no resolution yet. Switched back to BI4 for now.

          Comment


          • #6
            This seems to be a regression in the BI API - then multi-zone motion was introduced all of the MOTION notifications contained a letter (e.g. MOTION_A, MOTION_B, etc.) It appears that motion is now only sending the "MOTION" command and dropping the letter suffix.

            I will implement a fix as soon as I can. In the meantime, a short-term workaround may be to add a second motion zone of just a tiny area of the image and test to see if perhaps that makes BI add the letter suffix,
            Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

            Comment


            • #7
              I'm actually using Zone B for my MOTION event so there is a secondary motion zone in BI. I reverted back to BI4 and its working fine.

              Comment


              • #8
                OK, this then suggests BI is not sending the zone in the alert any more and have reverted back to just "MOTION" instead of "MOTION_<zone>" - I'll mail Ken and see.
                Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

                Comment


                • #9
                  any update on this?
                  Regards Bart
                  ------------------------------------------
                  Win7 64Bit on Intel NUCI7 with SSD
                  HSPRO 3.
                  Devices; 1370 Events; 691

                  Jon00 Scripts, JowHue, HSTouch, Plugwise, Z-wave, Ultranetatmo, Ultracam, PHlocation, BLUSBUIRT, MeiHarmony, Buienradar, MEiUnifi Pushover 3P, Random, Nest HSPhone and Blueiris

                  Visonic Powermax Alarm System (HS3) Interface: http://www.domoticaforum.eu/viewtopic.php?f=68&t=11129

                  Comment


                  • #10
                    I got a reply from Ken yesterday and he said he looked at it and its passing the zone on the end. He had me send over my config file and he was going to look at it.

                    Comment


                    • #11
                      Earlier in the day motion trigger worked just fine. With no changes to HS3, this afternoon am getting the error described above.
                      Michael

                      HS3 Pro 3.0.0.470 | 849 devices | 349 events | OpenSprinkler | BLShutdown | EasyTrigger | NetCAM | Harmony Hub | Sonos | SDJ-Health | BLUPS | PHLocation | BLBackup | BLLock | Z-Wave 3.0.1.243 | weatherXML | Pushover 3P | Blue-Iris | AirPlaySpeak

                      Comment


                      • #12
                        So I tried the latest update with no change. I used Wireshark to verify its not sending the Zone info and have sent that to Ken. He's going out of town but will look into it further over the weekend.

                        Comment


                        • #13
                          beerygaz It looks like BI5 has been fixed but the BI plugin for Homeseer is still failing cause of the string maybe?

                          Comment


                          • #14
                            Seems Ken fixed the Alerts but on the Reset it only sends MOTION as &TYPE which causes and exception.

                            Comment


                            • #15
                              Just updated to BlueIris V5 and am experiencing the same, my problem was compounded due to changing all of my devices to a different subnet (updated to Unifi equipment) and my Alerts was pointing to the previous subnet, after resolving that problem it worked but I'm now getting the aforementioned BI error... Troy you made mention that Ken fixed the problem within Blue Iris app in which version? I'm assuming that we are waiting for Barry to update BI plugin before were whole again? Mike
                              Jul-05 3:20:35 PM Blue-Iris Error Parameter: MOTION
                              Jul-05 3:20:35 PM Blue-Iris Error Parameter: Cam1
                              Jul-05 3:20:35 PM Blue-Iris Error Procedure called: Reset
                              Jul-05 3:20:35 PM Blue-Iris Error Error in PluginProc:Exception has been thrown by the target of an invocation.
                              Jul-05 3:20:26 PM Blue-Iris Successfully logged in to BlueIris server: LMBFarms (ver 5.0.0.57) as admin.
                              Computer: CUK Intel NUC7i7BNH
                              Op System: Windows 10 Pro - Work Station
                              HS Version: HS3 Pro Edition 3.0.0.435

                              Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                              Comment

                              Working...
                              X