Announcement

Collapse
No announcement yet.

Is the Motion error going to get fixed for BI5?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Is the Motion error going to get fixed for BI5?

    As others, I've been dealing with this error for quite some time now. I've tried everything suggested to no avail.


    Click image for larger version

Name:	2019-10-22_18-02-03.png
Views:	474
Size:	55.0 KB
ID:	1334821
    RJ_Make On YouTube

    #2
    It doesn't seem like a lot of development has been going on with this plugin as of late. It's just an observation and I'd love to be mistaken.

    It's frustrating to have this particular functionality broken, it's caused some grief and the wife-acceptance-factor has been affected negatively. This is something that would be great to have fixed soon, especially with HS4 on the horizon.

    Comment


      #3
      Hey there... not to usurp a PI author's ability to sell their plugin, but if you need a workaround, this can be done reliably without the PI. I current use motion detection in blue iris to change a virtual motion detector I created in HS3. From there you can fire whatever event you want.

      In blue iris, in the camera properties/alert tab, configure a new "on alert' action... then "configure a web request"

      This is the command for the web request to change your VD motion detector to 'motion'

      <HS3 IPort>/JSON?request=controldevicebylabel&ref=<VDmotionDetector Reference ID>&label=Motion

      When motion is detected, it fires an event. At the end of the event I have it set the VD motion detector back to 'no motion'.... and set to not rerun for 5 minutes).

      Hope that helps. let me know if you have any questions.

      Comment


        #4
        Originally posted by Tomgru View Post
        Hey there... not to usurp a PI author's ability to sell their plugin, but if you need a workaround, this can be done reliably without the PI. I current use motion detection in blue iris to change a virtual motion detector I created in HS3. From there you can fire whatever event you want.

        In blue iris, in the camera properties/alert tab, configure a new "on alert' action... then "configure a web request"

        This is the command for the web request to change your VD motion detector to 'motion'

        <HS3 IPort>/JSON?request=controldevicebylabel&ref=<VDmotionDetector Reference ID>&label=Motion

        When motion is detected, it fires an event. At the end of the event I have it set the VD motion detector back to 'no motion'.... and set to not rerun for 5 minutes).

        Hope that helps. let me know if you have any questions.
        Can I please get the details of your Virtual Device as far as creating it and the settings you used. I'm a sales guy, not a programmer so my skills are a tad limited. I have created virtual devices and they work great, I'm just missing some details on how to set this one up to receive the Motion Label from BI.

        Thanks!

        Comment


          #5
          ha... i'm same. took some trial and error to get this right. Screen shots below should help! Assume you have triggers figured out in BI (as I found that software a bit tricky at times!. On my Front Door camera, right click , select camera settings, then alerts tab. from that screen, select On alert button at bottom in the Action Pane, and hit the "+" to add an action.

          This is what mine looks like. (per the JSON request in my earlier post):

          Click image for larger version

Name:	Annotation 2019-11-10 103552.jpg
Views:	380
Size:	95.5 KB
ID:	1339055
          in Homeseer (I have both HS3 and BI on the same server, so IP is the same, FYI)...My Front Door Motion Sensor VD looks like this. The reference number on the advanced tab (468 in my case) is what is used in the BI action you created above.

          Click image for larger version

Name:	Annotation 2019-11-10 103916.jpg
Views:	343
Size:	82.8 KB
ID:	1339056
          Then I created an event that runs if motion is detected. this kicks of a separate event to change my tablets to the camera view of the front door, then it resets the motion VD back to NO MOTION (key).

          Click image for larger version

Name:	Annotation 2019-11-10 104248.jpg
Views:	340
Size:	133.1 KB
ID:	1339057
          Here is the action camera event. NOTE: I have this setup so it cannot re-run for 5 minutes, so people hanging out at the front door doesn't keep tripping the event. Notice in prior event I have "run only if other event conditions are TRUE" to ensure this works. After 1:30 min, the tablets are set back to the home page.

          Click image for larger version

Name:	Annotation 2019-11-10 104448.jpg
Views:	343
Size:	156.3 KB
ID:	1339058






          Comment


            #6
            Tomgru

            thank you much. I had a bracket in the json that wasn’t needed (around the device I’d)

            once again. Thanks!!

            Comment


              #7
              You bet!!!

              Comment


                #8
                Anyone else having issues with the BlueIris Alerts firing? I have a couple of camera's configured to send motion alerts to my MQTT server. If I manually trigger motion the MQTT message is sent. If the Camera triggers based on actual motion the MQTT message is not sent.

                Any ideas why this would be happening

                Comment


                  #9
                  Originally posted by jim@beersman.com View Post
                  Anyone else having issues with the BlueIris Alerts firing? I have a couple of camera's configured to send motion alerts to my MQTT server. If I manually trigger motion the MQTT message is sent. If the Camera triggers based on actual motion the MQTT message is not sent.

                  Any ideas why this would be happening
                  are you sure the camera Is triggering motion? I found that getting the motion settings right are tricky and BI, even more so with the newest version.

                  Comment


                    #10
                    Originally posted by Tomgru View Post

                    are you sure the camera Is triggering motion? I found that getting the motion settings right are tricky and BI, even more so with the newest version.
                    Yes, it's recording the alert

                    Comment


                      #11
                      Originally posted by jim@beersman.com View Post

                      Yes, it's recording the alert
                      Just so I understand... you know the alert is occurring because the camera is recording when motion triggers it? Just a shot, but do you have 'minimum time between alerts" checked and if so, how much time?

                      the other thing could be the profile. I have alerts set to trigger on certain profiles only, and often don't realize that BI has changed the profile.

                      Comment


                        #12
                        Originally posted by Tomgru View Post

                        Just so I understand... you know the alert is occurring because the camera is recording when motion triggers it? Just a shot, but do you have 'minimum time between alerts" checked and if so, how much time?

                        the other thing could be the profile. I have alerts set to trigger on certain profiles only, and often don't realize that BI has changed the profile.
                        I do have minimum time between alerts checked and it's set to 10 seconds.

                        As for profiles all cameras run under Profile 1.

                        Also have the red outline on the camera image so I'm very sure it's firing.

                        Comment


                          #13
                          you've probably done this, but maybe ask over at the ipcamtalk forum.. they are pretty helpful.

                          Comment


                            #14
                            I use a Z-Wave transmitter on my mailbox to trigger an event in HS3 which sets a Blue Iris profile. The BI profile records video and takes 3 snaps from 2 cameras. BI sends me 1 snapshot for review very reliably. If cameras are set sensitive enough to record motion you would get way to many false alerts. I record 100's of motion events a day, I don't want a bunch of message alerts. I use Z-wave motion detectors and switches to trigger reliable alerts.

                            Comment


                              #15
                              Just installed the Blue Iris plug in, created an event, when motion is detected, turn on living room light. Motion is being detected in BI, the video is being recorded as a triggered motion event. I'm running BI 5. Maybe this isn't working correctly in BI5?

                              Comment

                              Working...
                              X