Announcement

Collapse
No announcement yet.

Is the Motion error going to get fixed for BI5?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by jacobegan View Post
    Just installed the Blue Iris plug in, created an event, when motion is detected, turn on living room light. Motion is being detected in BI, the video is being recorded as a triggered motion event. I'm running BI 5. Maybe this isn't working correctly in BI5?
    That's is correct, the PI does not correctly "parse" BI5 motion triggers. I've been using MQTT
    RJ_Make On YouTube

    Comment


      #17
      Got it, thank you!

      Comment


        #18
        Originally posted by Tomgru View Post
        Hey there... not to usurp a PI author's ability to sell their plugin, but if you need a workaround, this can be done reliably without the PI. I current use motion detection in blue iris to change a virtual motion detector I created in HS3. From there you can fire whatever event you want.

        In blue iris, in the camera properties/alert tab, configure a new "on alert' action... then "configure a web request"

        This is the command for the web request to change your VD motion detector to 'motion'

        <HS3 IPort>/JSON?request=controldevicebylabel&ref=<VDmotionDetector Reference ID>&label=Motion

        When motion is detected, it fires an event. At the end of the event I have it set the VD motion detector back to 'no motion'.... and set to not rerun for 5 minutes).

        Hope that helps. let me know if you have any questions.
        Thank you for this! Simple solution that works without delay.

        Comment


          #19
          Originally posted by jacobegan View Post

          Thank you for this! Simple solution that works without delay.
          You are welcome!!!

          Comment


            #20
            Tomgru thanks for the workaround. I just setup my first HS camera and it's been a learning experience. Your "VD" sure simplifies things.

            Comment


              #21
              Originally posted by Tomgru View Post
              ha... i'm same. took some trial and error to get this right. Screen shots below should help! Assume you have triggers figured out in BI (as I found that software a bit tricky at times!. On my Front Door camera, right click , select camera settings, then alerts tab. from that screen, select On alert button at bottom in the Action Pane, and hit the "+" to add an action.

              This is what mine looks like. (per the JSON request in my earlier post):

              Click image for larger version

Name:	Annotation 2019-11-10 103552.jpg
Views:	572
Size:	95.5 KB
ID:	1339055
              in Homeseer (I have both HS3 and BI on the same server, so IP is the same, FYI)...My Front Door Motion Sensor VD looks like this. The reference number on the advanced tab (468 in my case) is what is used in the BI action you created above.

              Click image for larger version

Name:	Annotation 2019-11-10 103916.jpg
Views:	530
Size:	82.8 KB
ID:	1339056
              Then I created an event that runs if motion is detected. this kicks of a separate event to change my tablets to the camera view of the front door, then it resets the motion VD back to NO MOTION (key).

              Click image for larger version

Name:	Annotation 2019-11-10 104248.jpg
Views:	527
Size:	133.1 KB
ID:	1339057
              Here is the action camera event. NOTE: I have this setup so it cannot re-run for 5 minutes, so people hanging out at the front door doesn't keep tripping the event. Notice in prior event I have "run only if other event conditions are TRUE" to ensure this works. After 1:30 min, the tablets are set back to the home page.

              Click image for larger version

Name:	Annotation 2019-11-10 104448.jpg
Views:	530
Size:	156.3 KB
ID:	1339058





              Just found this post and wanted to thank you. This worked perfectly and solved the non-functional BI PI issue.

              Comment

              Working...
              X