Announcement

Collapse
No announcement yet.

Can't get stream

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't get stream

    Hi Spud,

    I just downloaded this plug-in, and I have not been able to connect to any cams.

    I have 2 Wanscam and 2 ONVIF (USB cam connected to a QNAP NAS.

    I have tried every possible URL, from LAN IP to WAN IP with port forward to the cams, with username and password, with &fmt=.jpg.

    I am lost...

    I guess trying to troubleshoot one of the wanscam would be the easiest.
    I enable the plug in... all seem good, status says OK
    Then add the network stream URL, obviously replacing the relevant info with actual values below, I have tried using:
    http://[username]:[password]@[LANIP]:[port]/videostream.cgi (doesn't work on browser either)
    http://[LANIP]:[port]/videostream.cgi?user=[username]&pwd=[password] this does work on browser)
    http://[WANIP]:[port]/videostream.cgi?user=[username]&pwd=[password] this does work on browser locally and remotely)

    I also tried adding &fmt=.jpg and ticking snapshot, and both above still work on browser.

    No matter what I do, I get the following error in HS3 log:

    FaceRecognition WARNING Recognition is not running, cannot stop it
    FaceRecognition ERROR System.NullReferenceException: Unable to create capture from http://[IP]:[port]/videostream.cgi?user=[username]&pwd=[password]&fmt=.jpg at Emgu.CV.Capture..ctor(String fileName) at HSPI_FaceRecognition.FaceRecognitionApp.StartCapture()

    I have also tried to set the log to debug... can't see anymore info... I tried to start and stop the FaceRecognition device manually, doesn't do anything.


    I am running out of ideas here...

    Thank you,

  • #2
    have you tried to use the snapshot mode?
    I saw that some wanscam cameras have a snapshot url: http://[LANIP]:[port]/snapshot.cgi?user=[username]&pwd=[password]

    do you know what format is the video stream? mjpeg, mpeg, ....

    if you can't figure it out, can you email me the wan url that works in a browser so that I can have a look myself?

    Comment


    • #3
      Hi Spud,

      Thanks I did try, it works on browser, but not in homeseer:

      May-27 3:51:37 PM FaceRecognition ERROR System.NullReferenceException: Unable to create capture from http://[IP]:[PORT]/snapshot.cgi?user=[USER]&pwd=[PASSWORD} at Emgu.CV.Capture..ctor(String fileName) at HSPI_FaceRecognition.FaceRecognitionApp.StartCapture()


      May-27 3:51:36 PM FaceRecognition WARNING Recognition is not running, cannot stop it

      will PM you the URL cheers,

      Comment


      • #4
        please install version 3.0.1.0 available in the updater.

        with this version both snapshot and stream url worked:

        http://[IP]:[PORT]/snapshot.cgi?user=[USER]&pwd=[PASSWORD]
        http://[IP]:[port]/videostream.cgi?user=[username]&pwd=[password]

        Comment


        • #5
          woohoo, you are a legend... Still struggling with one more URL that I can't find for an ONVIF H.264 on my qnap NAS but all other cams are now working, even the other ONVIF MPEG on the NAS.

          Will be doing some testing now...

          Comment


          • #6
            Hi mate, thanks again for your help but I am not having much luck so far. The plugin rarely picks up any faces, I guess my cams may not be good enough, or maybe the lighting.

            My trial has now expired, any chance to get an extension so I can do some more testing as at this stage, it was not successful.

            Thanks,
            Seb.

            Comment


            • #7
              I don't have any control over licensing, but you can ask HST for a new trial license, it shouldn't be a problem.

              For the plugin to pick up a face, its size must be at least 100x100 pixels, so make sure that an adequate resolution is chosen in your camera settings, and in the config page.

              Comment

              Working...
              X