Announcement

Collapse
No announcement yet.

How to get a snapshot from a Y-cam cube HD1080 camera

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to get a snapshot from a Y-cam cube HD1080 camera

    Hi,

    I try to add a Y-cam cube HD1080 camera to my system.
    When accessing the snapshot - url directly in my browser I get the snapshot instantly shown.
    But, when having the url added in the NetCam config, it just does not grab a picture? So what's wrong here or Am I missing some part?

    This is the url I added in the NetCam config (user and pwd are hidden)

    Code:
    http://192.168.0.11:80/snapshot.jpg?user=name&pwd=********** 
     and for a second camera
    http://192.168.0.12:83/snapshot.jpg?user=name&pwd=**********
    Any advice on this? Thanks.

  • #2
    Any ideas on this? Would be nice if I get this working.

    Thanks W.

    Comment


    • #3
      I have not utilized Netcam in a very long time. (Homeseer 2 early days).

      Try the same without the username and password.

      Have a look here:

      Y-Cam Black and HD Bullet

      Try this:

      hxxp://admin:admin@192.168.0.11/snapshot.jpg?user=admin&pwd=admin&strm=0

      or

      hxxp://admin:admin@192.168.0.11/snapshot.jpg

      Note that just about every new camera has multiple streams (from HD to SD resolutions).

      Here utilize both typically SD for a multiple camera view and HD for a single camera view in Zoneminder.
      The higher the pixel resolution the larger the JPG will be.

      Black and white or grey pictures at night utilize less than a color picture in daylight.
      Last edited by Pete; August 26th, 2017, 05:57 PM.
      - Pete

      Auto mator
      Homeseer 3 Pro - 3.0.0.500 (Linux) - Ubuntu 18.04 64 bit Intel CPU - Mono 5.18
      Homeseer Zee2 (Lite) - 3.0.0.531 (Linux) - ARMBian Ubuntu 18.04 64 bit Arm CPU - Mono 5.20

      X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

      Comment


      • #4
        Thanks for your advise on this. I still can not get a snapshot taken by Netcam.
        The problem is, if I have an Url like yours or any other format. The "Camera page" is opened and a login-screen is popping up! Only after providing a user and password in that inlog-screen the snapshot is taken. So apparently when executing through Netcam the "inlog-screen" is also opened (virtual) and is not filled and nothing will be executed?
        So how to pass through the "virtual" inlog-screen than?

        See image in next post:

        Comment


        • #5

          Comment


          • #6
            Any thoughts on this? Still can not get it to work with these cams! Thanks.

            Comment


            • #7
              Here continue to utilize Zoneminder for my CCTV.

              Googled

              Zoneminder Y-Cam and see this:

              Zoneminder Y-Cam

              Just a guess here ...using info...

              Code:
              Remote Protocol: HTTP
              Remote Method: Simple
              Remote Host Name: user:pass@ip_of_camera
              Remote Host Port: 80
              Remote Host path: /stream.jpg
              Target Colorspace: 24 bit colour
              Capture Width: 640 (1280 for 720p Bullet)
              Capture Height: 480 (720 for 720p Bullet)
              so it would be something like:

              Code:
              hxxp://user:pass@ip_of_camera/stream.jpg
              for a snap shot?

              You can check on the size of the image using Firefox and right clicking on properties of image.


              NOTE: this is different from what I found above and posted in #3 above (I do not have one of these cameras)

              hxxp://admin:admin@192.168.0.11/snapshot.jpg

              It appears to be stream.jpg versus snapshot.jpg.



              Keep trying using a browser link to the JPG. Once you have the browser link working then Netcam should not be an issue.

              PM if you want me to test this from across the big pond.

              1 - create a test username / password on your camera
              2 - open up port 80 to your camera with your firewall.
              3 - give me your internet IP address

              and will test over here near Chicago.
              Last edited by Pete; December 31st, 2017, 03:36 PM.
              - Pete

              Auto mator
              Homeseer 3 Pro - 3.0.0.500 (Linux) - Ubuntu 18.04 64 bit Intel CPU - Mono 5.18
              Homeseer Zee2 (Lite) - 3.0.0.531 (Linux) - ARMBian Ubuntu 18.04 64 bit Arm CPU - Mono 5.20

              X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

              Comment


              • #8
                Great this seems to work for me Thanks a lot!

                admin:admin_passwd@192.168.0.11/snapshot.jpg


                Comment

                Working...
                X