Announcement

Collapse
No announcement yet.

Need serious help with Foscam FI9821

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Rupp
    replied
    Originally posted by cpd5899 View Post
    Rupp,

    Do you need to put the port in the address as well? I still can't seem to get an image in the image element. If I type directly into IE or Chrome I see a snap shot. I tried Blue Iris as well and can't seem to get that image to work either...
    Yes the port is required if it's set to anything other than 80. HSTouch wasn't working the last time I tried it with this URL so I would recommend putting in a Bugzilla ticket on this issue.

    Leave a comment:


  • cpd5899
    replied
    Originally posted by Rupp View Post
    I have this camera and to capture a snap shot in a browser you can use.

    _ipAddress/cgi-bin/CGIProxy.fcgi?cmd=snapPicture&usr=xxx&pwd=xxx

    So the URL should look something like this:
    http://192.168.1.105/cgi-bin/CGIProx...dmin&pwd=admin
    Rupp,

    Do you need to put the port in the address as well? I still can't seem to get an image in the image element. If I type directly into IE or Chrome I see a snap shot. I tried Blue Iris as well and can't seem to get that image to work either...

    Leave a comment:


  • Rupp
    replied
    I have this camera and to capture a snap shot in a browser you can use.

    _ipAddress/cgi-bin/CGIProxy.fcgi?cmd=snapPicture&usr=xxx&pwd=xxx

    So the URL should look something like this:
    http://192.168.1.105/cgi-bin/CGIProx...dmin&pwd=admin

    Leave a comment:


  • RJS
    replied
    Originally posted by cpd5899 View Post
    Tomorrow I'll post screen shots... I believe the login page is different... And if it's the first time logging in, it asks for you to download the plugin.

    I installed blue Iris and now, gonna have to figure out how to get that to work.... Ugh
    You might want to change the name of your thread to include "Foscam FI9821" so people browsing the forum and use that cam might find you more easily.

    Leave a comment:


  • cpd5899
    replied
    Originally posted by RJS View Post
    Hmmm then the 9821 is different from the 8910 and 8918 which are the two models I have. The out of the box procedure for those 2 models are:
    - Install IP Camera (or download or the newest version)
    - Attach a network cable to the camera
    - Run IP Camera
    - When the camera appears in the listing, change the ip address, port & cam name.
    - After it reboots, close IP Camera
    - Use IE and log into the camera using that IP:Port
    - Under Device Management, configure the cam as necessary

    If the 9821 has other software, maybe another Homeseer user who uses the 9821 can chime in and clear this up.

    - Robert
    Tomorrow I'll post screen shots... I believe the login page is different... And if it's the first time logging in, it asks for you to download the plugin.

    I installed blue Iris and now, gonna have to figure out how to get that to work.... Ugh

    Leave a comment:


  • RJS
    replied
    Originally posted by cpd5899 View Post
    Robert,

    I uninstalled the program. I THINK the problem is, when first trying to access the camera via Web browser, you have to install their plugin or else you can't view the live feed. I can only imagine that with that plugin and homeseer there is a disconnect... I've tried EVERYTHING. I'm going to attempt the Blue Iris plugin and see if I can get it to work that way... I just have no clue what else to do :'(
    Hmmm then the 9821 is different from the 8910 and 8918 which are the two models I have. The out of the box procedure for those 2 models are:
    - Install IP Camera (or download or the newest version)
    - Attach a network cable to the camera
    - Run IP Camera
    - When the camera appears in the listing, change the ip address, port & cam name.
    - After it reboots, close IP Camera
    - Use IE and log into the camera using that IP:Port
    - Under Device Management, configure the cam as necessary

    If the 9821 has other software, maybe another Homeseer user who uses the 9821 can chime in and clear this up.

    - Robert

    Leave a comment:


  • cpd5899
    replied
    Originally posted by cpd5899 View Post
    It's whatever came in the box. When I get home I'll have to check. It definitely did more then just assign an IP.
    Robert,

    I uninstalled the program. I THINK the problem is, when first trying to access the camera via Web browser, you have to install their plugin or else you can't view the live feed. I can only imagine that with that plugin and homeseer there is a disconnect... I've tried EVERYTHING. I'm going to attempt the Blue Iris plugin and see if I can get it to work that way... I just have no clue what else to do :'(

    Leave a comment:


  • cpd5899
    replied
    Originally posted by RJS View Post
    What Foscam program do you use to view the camera's video? The only program of theirs that I have used is called IPCamera but it's just for setting the ip address and port. (Make sure you don't use a common port like 80 or 8088. Assign a not commonly use port.) They have always use a web browser for viewing and configuring.
    It wouldn't hurt to forward the port in your router. You'll also need a web address to access it when you are away from home. You can do this at No-Ip for free but every 30 days you have to go back in and refresh something to keep your account active. You get 3 ip addresses for free. Since I have a bunch of cameras, I use their paid version.
    https://www.no-ip.com

    Here's a good video that I used for my initial setup:
    https://www.youtube.com/watch?v=iHTxuYa3Kzo

    Also, I confirmed that when using IE, just enter the ip address & port, not the username and password, like this:
    http://ipadressort
    If you can't get it to work on IE, don't bother with HST yet. There is something wrong with your setup. Let me know how it goes.

    -Robert
    It's whatever came in the box. When I get home I'll have to check. It definitely did more then just assign an IP.

    Leave a comment:


  • RJS
    replied
    Originally posted by cpd5899 View Post
    still not working... do I need port forwarding? as of right now I am just trying to use in my house but I would eventually like to view the cameras remotely.

    I just dont understand. I am able to view via the Foscam program. HST Server reads it and the password is stored. I attempted to use a default program containing the camera screen and that as well won't read the camera.
    What Foscam program do you use to view the camera's video? The only program of theirs that I have used is called IPCamera but it's just for setting the ip address and port. (Make sure you don't use a common port like 80 or 8088. Assign a not commonly use port.) They have always use a web browser for viewing and configuring.
    It wouldn't hurt to forward the port in your router. You'll also need a web address to access it when you are away from home. You can do this at No-Ip for free but every 30 days you have to go back in and refresh something to keep your account active. You get 3 ip addresses for free. Since I have a bunch of cameras, I use their paid version.
    https://www.no-ip.com

    Here's a good video that I used for my initial setup:
    https://www.youtube.com/watch?v=iHTxuYa3Kzo

    Also, I confirmed that when using IE, just enter the ip address & port, not the username and password, like this:
    http://ipadressort
    If you can't get it to work on IE, don't bother with HST yet. There is something wrong with your setup. Let me know how it goes.

    -Robert

    Leave a comment:


  • cpd5899
    replied
    Originally posted by RJS View Post
    Are you trying to view the video on the same network as your cam? Otherwise you'll have to setup port forwarding on your router for that ip/port.

    There is an alternative format that some people have had success with:
    http://cam-ip:cam-port/user=yourusername&;pwd=yourpassword?snapshot.cgi
    Try that.
    Also, in IE using that command line may not work. It should work in HST. When I view my foscams in IE I enter just the ip & port.
    still not working... do I need port forwarding? as of right now I am just trying to use in my house but I would eventually like to view the cameras remotely.

    I just dont understand. I am able to view via the Foscam program. HST Server reads it and the password is stored. I attempted to use a default program containing the camera screen and that as well won't read the camera.

    Leave a comment:


  • RJS
    replied
    Originally posted by cpd5899 View Post
    I did that and still NOTHING :-( I tried to type in straight into IE and it says page not found... Is there a step I missed when setting everything up? I thought it was supposed to be a few simple steps with HS3
    Are you trying to view the video on the same network as your cam? Otherwise you'll have to setup port forwarding on your router for that ip/port.

    There is an alternative format that some people have had success with:
    http://cam-ip:cam-port/user=yourusername&;pwd=yourpassword?snapshot.cgi
    Try that.
    Also, in IE using that command line may not work. It should work in HST. When I view my foscams in IE I enter just the ip & port.

    Leave a comment:


  • cpd5899
    replied
    Originally posted by RJS View Post
    To view Foscam cams in HSTouch the format is generally the same for all their cams.
    1. Add an Image Element to your page.
    2. Add a button and define it to change the URL of the Image Element in this format:
    http://cam-ip:cam-port/snapshot.cgi?user=yourusername&;pwd=yourpassword
    3. On your 'go home' button that you add to take you back to the home screen, add a line to change the url of the image element but leave the url box empty so it removes the cam video and doesn't slow down your interface.


    - Robert
    I did that and still NOTHING :-( I tried to type in straight into IE and it says page not found... Is there a step I missed when setting everything up? I thought it was supposed to be a few simple steps with HS3

    Leave a comment:


  • RJS
    replied
    Originally posted by cpd5899 View Post
    I just purchased a foscam Fi9821W. I used their program and am able to view and control the camera via typing in the url directly to IE. I can seem to get into to work in HS or HST. the IP comes up in the HST config I inputted the user name and password.

    Can someone please dummy it down for me and tell me how the hell to make this work??????????
    To view Foscam cams in HSTouch the format is generally the same for all their cams.
    1. Add an Image Element to your page.
    2. Add a button and define it to change the URL of the Image Element in this format:
    http://cam-ip:cam-port/snapshot.cgi?user=yourusername&;pwd=yourpassword
    3. On your 'go home' button that you add to take you back to the home screen, add a line to change the url of the image element but leave the url box empty so it removes the cam video and doesn't slow down your interface.


    - Robert

    Leave a comment:


  • cpd5899
    started a topic Need serious help with Foscam FI9821

    Need serious help with Foscam FI9821

    I just purchased a foscam Fi9821W. I used their program and am able to view and control the camera via typing in the url directly to IE. I can seem to get into to work in HS or HST. the IP comes up in the HST config I inputted the user name and password.

    Can someone please dummy it down for me and tell me how the hell to make this work??????????
Working...
X