Announcement

Collapse
No announcement yet.

Foscam Alarm doesn't trigger

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Foscam Alarm doesn't trigger

    Hi,
    I have enabled this plugin and followed the documentation as best I understand. I have two camera types, both Foscam FI8919W and FI8905W. I can get them to send email from the alarm inbuilt in the camera so I know they are sensing movement. However, I cannot seem to get the camera's to trigger in a HS event, other than using external X10 motion sensors (which I would rather not use). I have done the:
    http://{camera IP address}:{port}/set_alarm.cgi?http=1&http_url=http://{IP Address of
    HomeSeer}/hspi_ultranetcam/hspi_ultranetcam.aspx?trigger=alarm&user=admin&pwd=password and also enabled using:

    http://{camera IP address}:{port}/set_alarm.cgi?http=1&user=admin&pwd=password

    Both returned an "ok."

    I am getting "snapshots" if I run the event manually, so I think the actual event "action" is OK and I am using the "Ultra Netcam Alarm Trigger" with the correct camera selected.

    Plugin is the latest version. Any ideas as to what I am doing wrong?

    cheers
    Andrew




  • #2
    Oh, I should also add, I have NOT configured any "Controls" as I am assuming (maybe wrongly) that this is for actions on the camera for Pan/Tilt etc from HS events which I am not worrying about.

    cheers
    Andrew

    Comment


    • #3
      Originally posted by 9v1tt View Post
      Oh, I should also add, I have NOT configured any "Controls" as I am assuming (maybe wrongly) that this is for actions on the camera for Pan/Tilt etc from HS events which I am not worrying about.

      cheers
      Andrew
      Hello Andrew. The Controls allow you to easily set the values needed to enable Foscam Triggers. To confirm everything is setup properly, please go to the following URL:

      Code:
      http://xx.xx.xx.xx:pppp/get_params.cgi
      Where xx.xx.xx.xx is the IP address of your NetCam and pppp is the port number.

      Once authenticated, look for the following variables:

      Code:
      var alarm_motion_armed=1; # 1 = enabled, 0 = disabled
      var alarm_http=1;  # 1 = enabled, 0 = disabled
      var alarm_http_url='http://xxx.xxx.xxx.xxx/hspi_ultranetcam/hspi_ultranetcam.aspx?trigger=alarm';
      Where xx.xx.xx.xx is the IP address of your HomeSeer system.

      For UltraNetCam3 (HS3 version), the http_url should be:

      Code:
      alarm_http_url='http://xxx.xxx.xxx.xxx/hspi_ultranetcam3/hspi_ultranetcam3.aspx?trigger=alarm';
      Where xx.xx.xx.xx is the IP address of your HomeSeer system.

      Regards,
      Ultrajones
      Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

      Comment

      Working...
      X