Announcement

Collapse
No announcement yet.

axis M1031W

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • axis M1031W

    Well I give up. I am trying to trigger an event off the motion detector in the axis M1031W camera. The motion detector is working locally at the camera but not through ulternetcam. I have tested this on both the HS2 and HS3 version to no avail. I can trigger the snapshot from within HS (although I only get one picture). Since it is both plugins the trouble is between the camera and the plugin. Anyone using a axis camera that might give me a hand?

  • #2
    UltraNetCam3 Triggers currently only work with Foscam Cameras. However, I can certainly add support for others if I am provided the HTTP GET the camera runs when motion is detected. Can you provide this information?

    Regards,
    Ultrajones
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

    Comment


    • #3
      axis M1031W

      Well axis is setup to detect a trigger (events). Motion Detection, PIR Sensor and a couple of others. Then you setup a event server to handle the action. It will send an email, ftp trigger, http trigger, tcp trigger . I will enclose some screenshots. What I was trying to do was use your url http://192.168.1.10:86/hspi_ultranet...?trigger=alarm and placing it in the event server. Didn't work. If you notice on the event server after populating the url you can use the test button and test it. Does this help any?


      Gene
      Attached Files

      Comment


      • #4
        After confirming you have your camera defined (including the IP address) in UltraNetCam3 > UltraNetCam3 > Devices, enabled debug within UltraNetCam3 HSPI, then click the test button on your camera. It should log the following if it is sending the HTTP request:

        Alarm motion trigger received from 192.168.1.10!

        Can you report back after trying this?

        Regards,
        Ultrajones
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment


        • #5
          I have log level set to debug. I have not been able to get any log messages at all from ultranetcam3.

          Comment


          • #6
            Spelling Error

            Found this error.
            Attached Files

            Comment


            • #7
              I just posted UltraNetCam3 HSPI that fixes that typo and adds a debug statement if the trigger is received by any device. Please install it, enable debug within UltraNetCam3 and enable Developer Mode by selecting the checkbox under Plug-ins > Manage.

              Once you start the plug-in, a console window will appear allowing you to see the debug output in real-time.

              This is what you should see on the console once you enable the plug-in:

              Code:
              UltraNetCam3 HSPI starting...
              Connecting to HomeSeer server at 127.0.0.1, attempt 1...
              Connection to HomeSeer at 127.0.0.1, attempt 1 succeeded.
              Entered InitIO() function.
              Entered Version() function.
              UltraNetCam3 version 3.0.5069.22813 initializing...
              Entered InitializeMainDatabase() function.
              Entered OpenDBConn() function.
              Running SQLite database vacuum.
              Database initialization complete.
              Entered GetSetting() function.
              Section: Settings, Key: Version, Value: 3.0.5069.22813
              Entered Version() function.
              Table tblNetCamDevices exists.
              Table tblNetCamTypes exists.
              Table tblNetCamEvents exists.
              Table tblNetCamControls exists.
              The NetCam discovery connection routine has started ...
              ProcessCommandQueue Thread Started
              Adding NetCam Object with Id NetCam001
              Updating existing HomeSeer Family Room device.
              ProcessCommandQueue Thread Started
              Adding NetCam Object with Id NetCam002
              Updating existing HomeSeer Basement device.
              ProcessCommandQueue Thread Started
              Adding NetCam Object with Id NetCam003
              Updating existing HomeSeer Den device.
              ProcessCommandQueue Thread Started
              Adding NetCam Object with Id NetCam004
              Updating existing HomeSeer Garage device.
              ProcessCommandQueue Thread Started
              Adding NetCam Object with Id NetCam005
              Updating existing HomeSeer Raspberry PI device.
              SnapshotFileMaintenance Thread Started
              The SnapshotFileMaintenance routine has started ...
              Entered Version() function.
              UltraNetCam3 version 3.0.5069.22813 initialization complete.
              Entered PurgeFTPArchives() subroutine.
              Entered GetSetting() function.
              Section: FTPArchive, Key: ArchiveEnabled, Value: 0
              Alarm motion trigger received from 192.168.2.36!
              Regards,
              Ultrajones
              Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

              Comment


              • #8
                OK I finally got the correct version loaded. You know that you have to manually download a new version? Other plugins will let you know one is available and allow you to "X" it to load. Attached ScreenShot looks like it is sending what is needed. It still will not do an auto snapshot. In the log you will see that it did a snapshot, but that was manually generated by me.
                Attached Files

                Comment


                • #9
                  What Program?

                  What program do you use to produce the "Code" example of your previous post?


                  Gene

                  Comment


                  • #10
                    Your network camera at IP 192.168.1.22 never sent an HTTP request to your HomeSeer system. Do you know if your camera sends an HTTP GET or a POST?

                    Regards,
                    Ultrajones
                    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                    Comment


                    • #11
                      I think I have two troubles. I have an event setup to snapshot. If I trigger it manually. I get images from the camera. first trouble, if I just connect to URL: 'http://192.168.1.10:86/hspi_ultranetcam3/hspi_ultranetcam3.aspx?trigger=alarm' I get the 'alarm motion trigger received from 192.168.1.10!' at the console, but this does not trigger the event to capture images. Second trouble if I manually trigger the event from the camera which is setup with the same URL as above I don't get the alarm motion trigger.

                      How does your plugin hand the motion alarm? The event server has the capability for a URL and a message. I know what HTTP get and post are suppose to do but I am not sure how to use them in my arrangement.


                      Gene

                      Comment


                      • #12
                        For the first issue, you'll never get the event to trigger unless you have a camera defined at 192.168.1.10. There is code to ignore requests from cameras that are not configured within the plug-in.

                        For the second issue, the trigger from your camera isn't reaching the HomeSeer system. Lets do this:

                        1) Create a file in your HomeSeer html directory called test2.aspx.
                        2) Put the following content into that file:
                        PHP Code:
                        <%@ Page Language="VB" %>
                        <
                        script runat="server">

                            
                        ' Insert page code here
                            '
                          
                        Dim hs As Scheduler.hsapplication
                          Dim plugin 
                        As HomeSeerAPI.PluginAccess
                            
                          Sub Page_Load
                        (Sender As ObjectAs EventArgs)
                            
                        ' for use with the HS web server
                            hs = Context.Items("Content")

                            Dim strGetTrigger As String = Request.QueryString("trigger") & ""
                            If strGetTrigger.ToLower = "alarm" Then
                              Dim strRemoteIP As String = Request.UserHostAddress
                              Label1.Text = String.Format("GET trigger received from {0}", strRemoteIP)
                              hs.WriteLog("Debug", Label1.Text)
                            End If
                            
                            Dim strPostTrigger As String = Request.Form("trigger") & ""
                            If strPostTrigger.ToLower = "alarm" Then
                              Dim strRemoteIP As String = Request.UserHostAddress
                              Label2.Text = String.Format("POST trigger received from {0}", strRemoteIP)
                              hs.WriteLog("Debug", Label2.Text)
                            End If
                                
                          End Sub
                          
                          Private Function GetHeadContent() As String
                            Try
                              Return hs.GetPageHeader("", "Test Page", "", "", False, False, True, False, False)
                            Catch ex As Exception
                            End Try
                            Return ""
                          End Function
                                
                          Private Function GetBodyContent() As String
                            Try
                              Return hs.GetPageHeader("", "Test Page", "", "", False, True, False, True, False)
                            Catch ex As Exception
                            End Try
                            Return ""
                          End Function
                            
                        </script>
                        <html>
                        <head runat="server">
                        <%response.write(GetHeadContent())%>
                        </head>
                        <body>
                        <% response.write(GetBodyContent()) %>

                            <form runat="server">
                              <p>
                                  <asp:Label id="Label1" runat="server">No GET trigger detected.</asp:Label>
                              </p>
                              <p>
                                  <asp:Label id="Label2" runat="server">No POST trigger detected.</asp:Label>
                              </p>
                              <p>
                            </form>

                        </body>
                        </html> 
                        3) Visit http://192.168.1.10:86/test2.aspx?trigger=alarm from any browser to confirm it works.
                        4) Configure your camera to send the trigger to http://192.168.1.10:86/test2.aspx?trigger=alarm
                        5) Check your HomeSeer log for an entry that looks like:
                        Nov-18 8:20:22 PM Debug GET trigger received from 192.168.x.xx

                        Regards,
                        Ultrajones
                        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                        Comment


                        • #13
                          Thanks for Your Help!

                          Ultra: Thanks for your help. I have a Geovision Camera system with about 20 cameras. It is setup to record all cameras including this litter box cam. I loaded the plugin to use the trigger mechanic's as an alert to dog activity around the litter box (know what I mean). The axis camera has everything needed to trigger off Motion or PIR. All I really needed was some way to send a trigger to HomeSeer. I setup the axis to send a http notification (connect to a .asp file). The .asp file only has one line "hs.TriggerEvent("Netcam Litterbox")". This event will trigger whatever alert I need. It will also trigger your plugin to produce snapshots. I probably should be using .aspx instead but since this is only one line it seems quick enough.

                          Thanks again for your help and Plugins

                          Gene

                          By the way the test2 program produced the screen shot. I could not get it to send the trigger (http notification) and work. The axis live view allows the setting of a manual trigger. The manual trigger produced the screen shot, not the auto. I could not make the auto trigger work.
                          Attached Files
                          Last edited by rhodesep; November 20th, 2013, 09:42 AM.

                          Comment

                          Working...
                          X