Announcement

Collapse
No announcement yet.

Camera Name as a variable

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Camera Name as a variable

    Hi Ultra,

    I am trying to use UltraNetcam with Blueiris. With BI the urls to the snapshots and PTZ controls must contain the shortname of the camera. Is there a way to have that variable added in the plugin?

    For example with Foscam device type you add the $user and $pass : /cgi-bin/CGIProxy.fcgi?cmd=snapPicture2&usr=$user&pwd=$pass

    For my BlueIris device type I would need the following : /image/$camname
    and have it use the NetCAM name of the device as $camname

    Mathieu

    #2
    Yes, this is possible. Give me a day or two to post the update.
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

    Comment


      #3
      Nice to hear this.

      I guess it could also be a separate variable than the NetCAM name if needed since people may like to use a different name for the HS Device than the short camera name from BlueIris.

      Comment


        #4
        I added the replacement variable for $camname in the HS3 version (I assume you were talking about the HS3 version).

        So, you would use the URL
        /image/$camname

        The Network Camera Name is URL encoded, so please be aware that you may have trouble if the name contains a space (or other non-ASCII characters).

        Please let me know if this work and provide an example usage so I can update the User's Guide.

        Regards,
        ultrajones
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment


          #5
          I applied the update and the new variable does work.

          However, I looks like I can't have more than one camera with the same IP. I can set my first camera with the IP to my BI server and login/password but when I try to add a second camera with the same IP but different name the entry does not get added.

          Mathieu

          Comment


            #6
            I'll have to update the database to allow that. May take a day or two ...
            Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

            Comment


              #7
              Originally posted by mathd View Post
              I applied the update and the new variable does work.

              However, I looks like I can't have more than one camera with the same IP. I can set my first camera with the IP to my BI server and login/password but when I try to add a second camera with the same IP but different name the entry does not get added.

              Mathieu
              Sorry for the delay. I released UltraNetCam3 HSPI version 3.0.5265.25815 that modifies the database unique restriction for NetCam Devices. It now allows entries with the same IP and port, but the camera name must be unique. Before installing the plug-in, you'll need to shutdown HomeSeer, then rename the database (\HomeSeer HS3\Data\ultranetcam3\ultranetcam3.db3) so the new database gets installed. You'll also need to modify any existing UltraNetCam3 events so they use the correct camera.

              Regards,
              Ultrajones
              Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

              Comment

              Working...
              X