Just restarted my server and updated everything.

In the HS3 Sighthound Plugin, there's a choice for verions 2.X or 3.X. My sighthound software is running version 5.1.7.

Any support for newer Sighthound Version?

Charlie.