Announcement

Collapse
No announcement yet.

set_Device_Type_String

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    set_Device_Type_String

    What happened to set_Device_Type_String()?
    I suspect it's replaced with UpdatePropertyByRef(ref, EProperty.DeviceType, TypeInfo)?

    On the device Settings page there's "Device Type String" which does show the value set in HS3 plugin, but I don't see how I can set it in HS4 plugin?

    Click image for larger version

Name:	Screenshot 2020-11-20 205348.jpg
Views:	79
Size:	50.3 KB
ID:	1434929

    #2
    Take a look at https://docs.homeseer.com/pages/view...pageId=7443561

    Comment


      #3
      Originally posted by Michael McSharry View Post
      As I said, it's talking about TypeInfo, but I can't see there anything related to HS3 get_Device_Type_String

      Comment


        #4
        I created an internal function to replace the HS3 function with the data stored in the PED. If the UI was needed to be visible to the user then it was created on a Feature Page. I also used the SubTypeDescription in other cases rather than the PED.

        Comment


          #5
          Originally posted by Michael McSharry View Post
          I created an internal function to replace the HS3 function with the data stored in the PED. If the UI was needed to be visible to the user then it was created on a Feature Page. I also used the SubTypeDescription in other cases rather than the PED.
          I'm trying to find out where "Device Type String" (see the screenshot) is set in HS4.
          I do set SubTypeDescription - but where is it displayed? I can't see. spud?

          Comment


            #6
            The property allowing you to assign the Device Type String is supposed to be Devices.Identification.TypeInfo.Summary.
            Unfortunately there is a bug in HS Core (HS-1078) which results in the Device Type String to be always blank for HS4 devices even if you set the Summary property. This bug has been fixed and the fix will be included in the next release

            https://github.com/HomeSeer/Plugin-SDK/issues/119

            Comment


              #7
              Crap, I spent hours trying... Thanks for the response spud.
              May be also some reply to https://forums.homeseer.com/forum/de...ing-jui-pages?

              Comment

              Working...
              X