Announcement

Collapse
No announcement yet.

How to manually install an hs4 plugin into hs4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How to manually install an hs4 plugin into hs4

    dropping the hspi_xxxx.exe into the hs4 root folder doesn't seem to work

    i dont have my beta in the updater so it must be installed manually

    how can i get someone else to install a plugin manually
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    #2
    You need to package your plugin to the zip with the instal file as per https://docs.homeseer.com/display/HSPI/Plugin+Packaging
    Then build a updater_override.json file as per https://docs.homeseer.com/display/HS...g+Installation
    Then you can are the updater_override.json and zip and people can add this to there root folder and it will show and instal for the updater.

    Greig.
    Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
    X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
    Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
    Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
    Scripts =
    Various

    Comment


      #3
      Originally posted by mnsandler View Post
      dropping the hspi_xxxx.exe into the hs4 root folder doesn't seem to work
      What issue do you have Mark? That's how I develop, never seen an issue and sometime still send a test build here or there if someone has a though to figure out issue. I send them the .exe and tell them to drop it in the homeseer directory.

      Comment


        #4
        when i just drop the plugin exe into the root, hs4 doesn't pick it up when it starts up. fine. I'll go through the updater_override.json process

        i created the json file, when i click plugin/manage/Add i get my listing, but then the installer can't find my zip file (which i also put in the hs root folder)
        Mark

        HS3 Pro 3.0.0.534
        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

        Comment


          #5
          Are you also installing the .exe.config?

          https://docs.homeseer.com/display/HS...app.configfile
          Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
          X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
          Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
          Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
          Scripts =
          Various

          Comment


            #6
            I have my updater_override.json and HSPI_Insteon_4.0.0.5.zip in the hs root with the following content

            Code:
            {
            "Version":"4.0.0.0",
            "Packages":[
            {
            "ProductID":"348",
            "PackageName":"Insteon",
            "EXEFile":"HSPI_Insteon.exe",
            "ID":"Insteon",
            "Version":"4.0.0.5",
            "UC":63,
            "ZipFile":"HSPI_Insteon_4.0.0.5.zip",
            "Author":"Mark Sandler",
            "Price":"TBD",
            "IconFile":"",
            "StoreURL":"",
            "ReleaseNotesURL":"http://plugins.homeseer.com/releasenotes?productid=348",
            "Featured":"False",
            "ShortDescription":"This plugin supports Insteon",
            "SupportURL":"",
            "HelpFileURL":null,
            "Tags":[
            ]
            }
            ]
            }
            i'm getting the following error when i click Install on the first popup

            Click image for larger version

Name:	Installer error.PNG
Views:	58
Size:	11.2 KB
ID:	1502692

            I have tried different zip files names but still not joy so I dont think the installer is unzipping and installing anything according to the install.txt file which is in the .zip file
            Mark

            HS3 Pro 3.0.0.534
            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

            Comment


              #7
              Did you try replacing the dots with underscores in the zip file names as I don't think that is a supported character?
              Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
              X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
              Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
              Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
              Scripts =
              Various

              Comment


                #8
                Originally posted by enigmatheatre View Post
                Did you try replacing the dots with underscores in the zip file names as I don't think that is a supported character?
                I did try replacing dots with underscores (even tried dashes), also tried removing the version number all together, and I changed the filename in the json file accordindly each time...no joy

                Mark

                HS3 Pro 3.0.0.534
                Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                Comment


                  #9
                  any chance the error i'm seeing is bogus, and its a permission error when hs tries to copy my zip somewhere else?

                  i'm running hs42.5 on win10 and i have to give admin permission every time i manually copy a file into the hs4 root
                  Mark

                  HS3 Pro 3.0.0.534
                  Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                  Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                  Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                  Comment


                    #10
                    Mark,

                    I sent you a PM.

                    Greig.
                    Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
                    X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
                    Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
                    Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
                    Scripts =
                    Various

                    Comment


                      #11
                      substituting a URL in the ZipFile location got the plugin installed

                      but hs still wont load it even after a reboot. it just doesn't see the hspi_.exe file in the root folder (which was my original problem)
                      Mark

                      HS3 Pro 3.0.0.534
                      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                      Comment


                        #12
                        Your previous (HS3) version of the PI was for pay, correct? Does your HS4 version use the same pluginID?
                        Reason I ask, i ran into something, what I think is not correct, in that, when you report back your accesslevel, even if you report if to be free, if the PI is in the store for pay, it won't start. Seem to recall I had to first uninstall whatever I had downloaded from the updater to get it going.
                        Is this a linux install or Windows. The .exe has to correct privilages?

                        Comment


                          #13
                          i figured out the issue,. my exe.config wasn't correct. i needed to add the following to my previous paths

                          <probing privatePath="bin;bin/homeseer;
                          thanks all for the help
                          Mark

                          HS3 Pro 3.0.0.534
                          Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                          Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                          Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                          Comment

                          Working...
                          X