Announcement

Collapse
No announcement yet.

HS4 Alpha Plugin Development Release

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    How long does it take to get the trial license? It is 3 hours now since I requested it, but still no answer?

    Wim
    -- Wim

    Plugins: JowiHue, RFXCOM, Sonos4, Jon00's Perfmon and Network monitor, EasyTrigger, Pushover 3P, rnbWeather, BLBackup, AK SmartDevice, Pushover, PHLocation, Zwave, GCalseer, SDJ-Health, Device History, BLGData

    1210 devices/features ---- 392 events ----- 40 scripts

    Comment


      #17
      For me it was instantly. Have you checked your spam folder?
      stefxx

      Comment


        #18
        Yes, first thing I looked at. Maybe it is only done during US daytime? Don't know for sure.
        -- Wim

        Plugins: JowiHue, RFXCOM, Sonos4, Jon00's Perfmon and Network monitor, EasyTrigger, Pushover 3P, rnbWeather, BLBackup, AK SmartDevice, Pushover, PHLocation, Zwave, GCalseer, SDJ-Health, Device History, BLGData

        1210 devices/features ---- 392 events ----- 40 scripts

        Comment


          #19
          Mine was instantly .... maybe try again? I did need to go through the whole, add to cart -> pay business even though it was free

          Comment


            #20
            Originally posted by w.vuyk View Post
            Yes, first thing I looked at. Maybe it is only done during US daytime? Don't know for sure.
            Wim - Licenses are issues very quickly. I would STRONGLY recommend that you use your Gmail account for any HomeSeer interactions. Your .nl email service is obviously blocking emails from our message board and from the registration server. This has been an ongoing issue (as you know) and there is literally no way for us to fix this on our end.
            Learn About HomeSeer

            Comment


              #21
              Mark,

              Last time we mailed about this issue I tried to explain to you that my ISP (largest of Holland) has gone though several tests to find if they are blocking anything. Since you changed this board and changed plugin publishing and mailing system I am not getting mail from forum and subsrcibers list. My ISP has gone through several tests with me, including changing my mail address to normal for the forum and forcing mails to me. They have checke their log and there was no blocking fo mails coming from the forum. There was just nothing delivering to their servers
              In that same mail I asked if you could contact your ISP for the forum and subscribers list. As my ISP explained that the provider should check their bounce/non delivery list after sending to the subscribers list and/or forum mail for non deliveries. They can do that quickly by searching on mail address. I don't think you tried?

              On de shop, I am using a different mail adress w dot vuyk at chello dot nl - and I use this adress for shopping at homeseer for 15 years by now. All licenses are registerd on this account. My last plugin I bought on this account was bought a year ago. And I got the order info in my mailbox, like expected.
              But now you are telling me that this account is now also faulty?

              I would change this account, but I cannot change the mail account in the shop, or I cannot find how to do that. I do not want two accounts, as this would split the license administration as well. If I check my account online, the order is unfullfilled, does this mean the mail has not been send maybe?

              Wim Click image for larger version  Name:	2019-09-07 21_37_58-Account – HomeSeer.png Views:	0 Size:	26.7 KB ID:	1324943
              -- Wim

              Plugins: JowiHue, RFXCOM, Sonos4, Jon00's Perfmon and Network monitor, EasyTrigger, Pushover 3P, rnbWeather, BLBackup, AK SmartDevice, Pushover, PHLocation, Zwave, GCalseer, SDJ-Health, Device History, BLGData

              1210 devices/features ---- 392 events ----- 40 scripts

              Comment


                #22
                1/ I seem to have at least 2 issues during init:

                a/ the call to hs.getipaddress seems to fail with error: error = Object reference not set to an instance of an object. Service Version: NO_VERSION

                b/ When I enable the speaker_proxy by calling callback.RegisterProxySpeakPlug(sIFACE_NAME, MainInstance) I get this error: error = Unable to cast object of type 'Scheduler.PluginHolder' to type 'HomeSeerAPI.IAllRemoteAPI'. Service Version: NO_VERSION

                2/ Should we start raising bug reports? If so how?

                3/ I took a quick look at the new sample VB code, is singleexeMultipleInstance type of PI still supported, if so how?

                4/ I apologize if already asked and answered somewhere, apart from the GUI changes, which real new features are targeted if any? The description above is very vague, I'm trying to decide whether it is worth to rewrite my PIs to make use of new features but with the info I've read so far, I don't really see any benefit ... yet. Anyone care to weigh in? For Media PIs, being able to navigate through media content was always high on our list but we never got to something rock solid, are the new GUI featutes providing an extended object listbox type of capability?

                Thanks,

                Dirk

                Comment


                  #23
                  Originally posted by alexbk66 View Post
                  I don't understand how to get to my device config?

                  In HS3 I click on device name and then go to the config page (this includes child devices as well):





                  Click image for larger version Name:	ConfigDevice.PNG Views:	0 Size:	285.7 KB ID:	1325049


                  In HS4 the devices are not clickable?
                  @JLDubz?

                  Comment


                    #24
                    Some more suggestions for you.

                    Please give the plugins a proper subfolder instead of placing them in the root of the homeseer installation. As it is now, if we wanted to dockerize/containerize the homeseer app we cannot map the plugins outside the container so we must map the entire homeseer installation for persistent storage. I would love to see anything that needs to be persistent able to have it's own location.

                    Comment


                      #25
                      Originally posted by dcorsus View Post
                      Should we start raising bug reports? If so how?
                      +1 Jira?
                      I suspect unfortunately we'll have lots of issues, if we keep reporting them all here - they will just be buried in this forum. We need proper ticket system.

                      Comment


                        #26
                        jqDropList doesn't seem to work in trigger UI. In HS3 I have a list of calendars to select, but in HS4 it doesn't show:
                        Click image for larger version  Name:	CalendarOld.PNG Views:	0 Size:	22.6 KB ID:	1325080 Click image for larger version  Name:	CalendarNew.PNG Views:	0 Size:	46.8 KB ID:	1325081

                        HTML for the droplist:
                        Code:
                        <!-- jqDropList selectedcalendarid_2_G0_T0_ID598385-->
                        <script>
                        $(function() {
                         $('#selectedcalendarid_2_G0_T0_ID598385').change( function() {
                          var value = $(this).val();
                          value = encodeURIComponent(value);
                          var theID;
                           var theform =$('#'+$(this)[0].form.id);
                           var theData = theform.serialize()+'&id='+'selectedcalendarid_2_G0_T0_ID598385';
                        commonAjaxPost(theData,'events');
                         });
                        });
                        </script>
                        <select  id='selectedcalendarid_2_G0_T0_ID598385'  name='selectedcalendarid_2_G0_T0'  class='.jqDropList'  style='width: 150px;'>
                        <option selected='selected' value=''>Select Calendar</option><option  value='gulnara.artemenko@gmail.com'>gulnara.artemenko</option><option  value='jgcuopiksi78f231qq5t23b2pg@group.calendar.google.com'>Homeseer</option><option  value='alexbk66@gmail.com'>Primary</option><option  value='addressbook#contacts@group.v.calendar.google.com'>Contacts</option><option  value='en.australian#holiday@group.v.calendar.google.com'>Holidays in Australia</option></select>

                        Comment


                          #27
                          And why attached images in this forum now show only as thumbnails?

                          Comment


                            #28
                            I find it hard to test my plugins. Basic functionality of most of them seem to work ok, but to use all the functionality I have to revert back to the old devicelist (http://<ip>/deviceutility). Maybe I don't understand the new interface, or more likely, it isn't anywhere near completion. I realize this is Alpha software, and I don't dislike the new interface, but it isn't really useful either at it's current state. I don't know if using the old HS3 interface is the best way to test the plugins. Please give some more guidance and/or explanation.

                            Thanks!
                            stefxx

                            Comment


                              #29
                              Hello,

                              I did not notice any issue when running my Jeedom plugin with to current state of HS4. I mean I did not get any error in the log during "normal" use of the plugin. However, since the UI is obviously still at a very preliminary stage, I cannot confirm it is 100% compatible with HS4.

                              Here are some of the UI issues I noticed :
                              • Devices values/status are not displayed in the device 'list' view.
                              • Devices values/status are not displayed for some devices in the "tile view" : a device that represent a switch with 2 controls ON/OFF show the switch value (but not the string), but a device expected to show temperature or humidity does not display any value/string. I don't know if it is linked to the fact that they do not have controls, or if it is because they have decimal values in European format (decimal separator is , instead of .)
                              • When values are displmayed for devices, they do not update automatically, it is necessary to clic the refresh button of the browser to have the latest value displayed)
                              • Hudge regression on the "device info screen" (Device settings)
                                • No room code anymore ?
                                • Advance tad is missing
                                • Specific tab created by the plugin are not shown
                              • Not possible to bind the server to a specific IP address
                              • Some page do not load when server port is changed to someting else than 80
                              • The web server is showing a strange IP address on the browser : 10.8.1.46 when running on a PC with IP address 192.168.0.100
                              • I finally succeed to re-compile the sample plugin with VS2019 but when running the plugin from there, it appear in the "plugin" menu, but if I select "manage", it does not show in the plugin list (with HS3 it was displayed as "remote" and it was possible to disconnect it).
                              That's it for my preliminary feedback on HS4. I hope it helps.

                              Comment


                                #30
                                Click on the name of the device on the devices page, it is a link that brings you to the device config. You will not see hs3 device config info there at this time, just the hs4 formatted page, if you create one.

                                The biggest reason to convert your plugins to HS4 is the new bootstrap based UI where your plugin will display properly on mobile devices. While we are trying to display the old hs3 content where possible (like for triggers/actions), there may be some real issues getting that working with every older UI element. Right now we are not displaying the H3 tab in the device properties.

                                HS4 will be evolving as we go forward so I strongly suggest you update your plugins as the user experience will be poor if you only offer an HS3 version.

                                Note that we dropped support for multi instance plugins as this was just a shortcut for developers. We suggest you just add support for multiple interfaces in your plugin.We can offer ideas if you like.

                                We will get the SDK docs posted shortly.

                                The HS4 UI is still being worked on so we understand that some features are missing or not wokring. There should be enough there to develop a plugin. New builds will be posted as functionality is added/fixed.

                                Originally posted by alexbk66 View Post
                                website | buy now | support | youtube

                                Comment

                                Working...
                                X