Announcement

Collapse
No announcement yet.

Error in log when changing devices view and CPU raising to 100%

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Error in log when changing devices view and CPU raising to 100%

    If I change the device view to list view the log is flooded with errors:

    Code:
    18-9-2019 11:43:15 Error In SettingManager getVar setting var false: var not found
    18-9-2019 11:43:15 Error In SettingManager getVar setting var false: var not found
    18-9-2019 11:43:15 Error In SettingManager getVar setting var false: var not found
    18-9-2019 11:43:15 Error In SettingManager getVar setting var false: var not found
    18-9-2019 11:43:15 Error In SettingManager getVar setting var false: var not found
    18-9-2019 11:43:15 Error In SettingManager getVar setting var false: var not found
    18-9-2019 11:43:15 Error In SettingManager getVar setting var false: var not found
    18-9-2019 11:43:15 Error In SettingManager getVar setting var false: var not found
    18-9-2019 11:43:15 Error In SettingManager getVar setting var false: var not found
    <SNIP>
    Then if I return to tile view, another error is thrown in the log (only once)

    Code:
    18-9-2019 11:43:31
    Error
    In SettingManager setVar setting var gDeviceViewList: De objectverwijzing is niet op een exemplaar van een object ingesteld.
    After that the CPU rises to 100% (shared browser and HS4) for some time. It will go back after a while to normal.

    Wim

    Edit: this is with v4.0.0.18
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    #2
    *bump*

    This still continues in .22

    Adding extra info I added at the github site, where I was requested to report this issue on the forum - which I aready did....

    When I open the logscreen and enable autoupdate the CPU will gradually raise to 100% (shared between browser process and HS4)
    Switching over to device will drop the usage again.
    Also, is it possible to enable autupdate by default? Users checking the log file will mostly want to see progress in the log and expect the log to automatically proceed if new lines are added.
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment

    Working...
    X