Announcement

Collapse
No announcement yet.

Viable .net version

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Viable .net version

    Any thoughts on what .net version people should use for new hs3 plugins? I was thinking 4.6.2 just to be sure, but has anyone started requiring 4.7?

    I guess hs itself use 4.6.x?

    #2
    This is a good question as consistency is a good thing. Anyone wanna chime in here. Rich?
    HomeSeer 2, HomeSeer 3, Allonis myServer, Amazon Alexa Dots, ELK M1G, ISY 994i, HomeKit, BlueIris, and 6 "4k" Cameras using NVR, and integration between all of these systems. Home Automation since 1980.

    Comment


      #3
      I've been using 4.6.1 (I believe). it's either that or 4.6.2. I have not moved up to 4.7 on any of my plugins yet.
      MeiAutomtion Home

      Comment


        #4
        4.5 is the highest version I have used. Updates are too frequent to expect a standard to be followed.

        Comment


          #5
          IMHO New plugins should use the versions that HS is shipping unless there is a feature that is absolutely needed.

          Comment


            #6
            Yeah, but if we can use .NET Standard 2.0, it will be easier to write cross-platform plugins.

            Comment


              #7
              4.7.2 works, by the way. Haven't tried .NET Standard 2.0... yet.

              Comment

              Working...
              X