Announcement

Collapse
No announcement yet.

Is there any interest in a plugin for Bond Ceiling Fan controller if I write one?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #91
    Originally posted by rprade View Post
    I was running v1.x.x, it updated to v2.10.8
    Yeah, the firmware should be > 2.0. And that's Beta too.

    Originally posted by rprade View Post
    I can turn the fan on or off, but cannot control the speed. I can turn the light in or off, but all three controls (Toggle, On, Off) all toggle the light state. I cannot control the dim level of the lights.
    As I explained before - only the controls without arguments work for now. Because I can't know all possible actions for all possible devices.

    I'm waiting for reply from Bond developer if there's an API function for getting info about number and type of arguments.
    Also I'm waiting for reply about getting the device state info - for displaying in HS.

    If both above not possible - another option is to make action arguments and device state info configurable. But would be great to avoid this.

    When HST create subforum for my plugin I will start collecting feedback about not working actions from users.

    Comment


      #92
      Originally posted by rprade View Post
      I can turn the fan on or off, but cannot control the speed. I can turn the light in or off, but all three controls (Toggle, On, Off) all toggle the light state. I cannot control the dim level of the lights.
      Just received reply from Bond. Will implement actions with arguments tomorrow (it's 2:42 am in AU )

      I guess it's gonna be quite a change - because to specify the action arguments each action must become a separate HS device... Unless I can make the arguments values hard-codded (configurable) - i.e. for "IncreaseSpeed" make a configurable argument, say 10%.

      Thoughts?

      Comment


        #93
        I'm not sure. The app offers 3 speeds for these fans as they are 3-speed fans. Reverse is offered for all three but only the bedroom fan supports it. It would be great if we could select a speed (low, med, high), but since the control is universal to a lot of different fans, this may not be possible. Two of my fans are Hunter branded and one is Hampton Bay. The Hampton Bay is the one with reverse.

        I would say, go with your best instincts, based on what the API offers. This may take some tries to flesh out what works best over the broad variety of fans that might be controlled.
        Randy Prade
        Aurora, CO
        Prades.net

        PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

        Comment


          #94
          Originally posted by rprade View Post
          I would say, go with your best instincts, based on what the API offers. This may take some tries to flesh out what works best over the broad variety of fans that might be controlled.
          The API is actually very powerful and a lot of stuff can be done - even creating new buttons, commands, anything.

          [EDIT] - deleting buttons is also possible.

          May be to give me an idea please post the APP screenshots so I know what you are talking about.

          Comment


            #95
            And I would appreciate detailed feedback on each button - i.e. if it (a) works, (b) needs arguments, (c) is not needed at all

            Comment


              #96
              One of my fans has six speeds and another has an upper and lower light. Not sure if this screenshot will be helpful?




              Sent from my iPhone using Tapatalk
              Attached Files
              HS3 3.0.0.548 &HSTouch Designer 3.0.71 with 996 Devices, 547 Events
              Plugin's:
              BLBackup, BLOccupied, BLShutdown, EasyTrigger, Ecobee, Nest, AK Bond
              EnvisaLink DSC, PHLocation, Pushover, SONOS, Blue Iris, UltraRachio3,
              weatherXML, Jon00 Alexa Helper, Network Monitor, MyQ, Z-Wave 3.0.1.252

              Comment


                #97
                Originally posted by The Profit View Post
                One of my fans has six speeds and another has an upper and lower light. Not sure if this screenshot will be helpful?
                Thank you, one picture is always better than you know...

                I was hoping that the API returns same list of buttons you have in the app. But it's not the case?

                Is your app setup different for each fan?

                Can you please explain in more details what you want to be changed? I.e.

                * Are you happy with the buttons setup in the app, or you would prefer something changed (in the app)
                * Which buttons do work in HS?
                * Which buttons (in HS) you don't want at all?
                * Which buttons (in HS) need to change and how? I.e. split SetSpeed button in 6 separate buttons? Or you would prefer a slider (0-100%)?

                Too many questions, sorry. But I want to get it right.

                Comment


                  #98
                  Another question: what do you guys prefer -

                  (1) Create only one HS device for each fan with lots of buttons - as it's done currently, i.e. for fan with 6 speeds have 6 btns (Speed1, Speed2, etc)?
                  This way it's not possible to display the current state of each feature (current fan speed, current light brightness) - because the HS device has only one status.

                  Or

                  (2) For each fan create HS root device and create children devices for each feature, i.e. separate device for Fan Speed with a slider 0 to 6?
                  This way I can display the current state for each feature, i.e. current fan speed in HS device status. But the status is uncertain anyway - that's only what the Bond app thinks, not real fan status.

                  Comment


                    #99
                    I do not have any material that would work with bond...but i think the second option is the way to go .


                    Comment


                      Originally posted by MattL0 View Post
                      I do not have any material that would work with bond...but i think the second option is the way to go .
                      I use Bond Bridge to learn commands from all my RF433 transmitters, i.e. Gate and Garage openers. For that I create (in Bond app) devices of type MS (Motorized Shades).

                      Comment


                        Originally posted by alexbk66 View Post
                        Another question: what do you guys prefer -

                        (1) Create only one HS device for each fan with lots of buttons - as it's done currently, i.e. for fan with 6 speeds have 6 btns (Speed1, Speed2, etc)?
                        This way it's not possible to display the current state of each feature (current fan speed, current light brightness) - because the HS device has only one status.

                        Or

                        (2) For each fan create HS root device and create children devices for each feature, i.e. separate device for Fan Speed with a slider 0 to 6?
                        This way I can display the current state for each feature, i.e. current fan speed in HS device status. But the status is uncertain anyway - that's only what the Bond app thinks, not real fan status.
                        #2 for sure. Not having the current status make it impossible to check the status of the devices. I don't see any event triggers for the PI, so you'll need to provide a device status instead.

                        Comment


                          Originally posted by vasrc View Post

                          #2 for sure. Not having the current status make it impossible to check the status of the devices. I don't see any event triggers for the PI, so you'll need to provide a device status instead.
                          Ok. I guess so. Just only issue is - the status is basically a copy of the Bond app, not the physical device. But better than nothing.

                          Comment


                            Originally posted by alexbk66 View Post

                            It means that the discovery (mDNS/Zeroconf) doesn't work.
                            Anything in the logs?
                            Are you on Linux or Windows?
                            You should be able to add the Bridge manually in Config page - Using the "+" button, then entering the Bridge ID and IP. But I didn't test it yet.
                            OK- running windows 10. How do I check that mDNS works mate? I think thats my issue

                            Comment


                              Originally posted by Timmy_G View Post

                              OK- running windows 10. How do I check that mDNS works mate? I think thats my issue
                              [EDIT] What's your Bridge Firmware version?

                              Can you try ServiceBrowser from here (download is at the bottom)

                              Click image for larger version  Name:	2020-01-23 (1).png Views:	0 Size:	27.4 KB ID:	1355867

                              Comment


                                Using the + button didnt work for me. Does issue with mDNS possibly relate to the plugin not creating a root devive upon install of the plugin (as per post #71)

                                Comment

                                Working...
                                X