Announcement

Collapse
No announcement yet.

Velleman K8055 Plugin V1.0.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    multiple velleman k8055-cards

    Hello guy's,

    First of all excusen my english, i'm new with homeseer and i'm orientating which components i need for my situation.

    Some people sugests mee the velleman K8055, but the number of i/o's are not enough. On the velleman website i've read i can connect a maximum of 4 boards to my computer, but does the plugin supports 4 boards?

    Jaco

    Comment


      Hi Jaco

      I am affraid that the 4 board version of the plugin was never released. It was developed, but had issues over switching between boards so was put on hold.

      If you need multiple outputs, check out the maxibee - Jon00 has code for that - and I can confirm it works great. The maxibee range includes a 64 port output module for not much money.

      David
      ---------------------------------------------------http://weather.penicuik.org

      Comment


        DigiBee has boards that have a maximum of 16 inputs or 64 outputs, they can be controlled with the software that is shipped with the boards.

        If you need more you have to use the BeeHive software that can be downloaded from their website. This advanced software will support 4 boards if I am not mistaking.

        I have read through the documenation and to my opinion there is one setback. The boards do not have an unique identifier and have to be identified upon connection. So if you unplug the board en connect it again, you could have some fun...

        I personally have a DigiBee+ and developed my own HS plugin. The manuals are good and even for a VB-noob it is possible to write an interface within a couple of days.

        Please notice: the DigiBee board are not isolated or able to drive high current outputs. You will have to connect them to a relay board such as the Velleman relay board and a optocoupler interface.

        Comment


          setting K8055 digital output with script

          Hi everybody,
          I'm trying to set the digital outputs of my 8055 board using script.
          Should I use the hs.setdevicestatus or hs.setdevicevalue function ?
          what is the parameter value to set or reset one output ?
          A one line example would help me !
          Thank you very much for your support

          Comment


            Analogue Outputs

            Hi there, thank you to Malarcy for all of his hard work he did getting the K8055 to work. This may just be the drive i need to go out and but the Homeseer software (well get some of the other automation bits).

            I have a chance to try out the software and quite like it but can someone give me step my step on how to use the analogue outputs. when i right click i cant see any settings or place to put a script i can ony see this in events

            Any help appreciated

            Edd

            Comment


              Source code available?

              Originally posted by Malarcy View Post
              Gotta reckon it was poor coding on my behalf - I kinda stopped with the plugin when the vellemen dll had problems with switching between multiple boards - if I can find the source code I'll post it - if anyone want's to pick it up.

              I'll look this weekend - it;s in the archive somewhere.

              Malarcy
              Malarcy, did you post the sourcecode somewhere?

              I'm currently experience the same issue as Tonlof:

              Originally posted by tonlof View Post
              The max countervalue for 8055 is 65535 but the plugin stop after 32767.

              Any Idea?

              /Tony
              Also there is no option to do somehow a reset of the countervalue which I really need in my setup.

              Instead of start writing a new plugin from scratch I would like to start with the sourcecode you've written already. Of course only if you're happy to share it ...
              Last edited by BreFra; August 8, 2009, 06:44 AM. Reason: typo...

              Comment


                In the HomeSeer log I see a strange message.

                14-5-2010 22:52:23 - hspi_malk8055 - initialised
                14-5-2010 22:52:23 - Warning - GetDevice is not reliable for device enumeration. Please use the new GetDeviceEnumerator method.
                14-5-2010 22:52:23 - Warning - 'status' property on device malk8055 K8055-0-DI1 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:23 - Warning - 'status' property on device malk8055 K8055-0-DI2 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:23 - Warning - 'status' property on device malk8055 K8055-0-DI3 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:23 - Warning - 'status' property on device malk8055 K8055-0-DI4 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:23 - Warning - 'status' property on device malk8055 K8055-0-DI5 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:23 - Warning - 'status' property on device malk8055 K8055-0-DO1 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:23 - Warning - 'status' property on device malk8055 K8055-0-DO2 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:23 - Warning - 'status' property on device malk8055 K8055-0-DO3 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:23 - Warning - 'status' property on device malk8055 K8055-0-DO4 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:23 - Warning - 'status' property on device malk8055 K8055-0-DO5 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:23 - Warning - 'status' property on device malk8055 K8055-0-DO6 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:23 - Warning - 'status' property on device malk8055 K8055-0-DO7 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:23 - Warning - 'status' property on device malk8055 K8055-0-DO8 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:23 - Warning - 'status' property on device malk8055 K8055-0-AI1 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:23 - Warning - 'status' property on device malk8055 K8055-0-AI2 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:23 - Warning - 'status' property on device malk8055 K8055-0-AO1 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:23 - Warning - 'status' property on device malk8055 K8055-0-AO2 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:24 - Warning - 'status' property on device malk8055 K8055-0-DC1 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:24 - Warning - 'status' property on device malk8055 K8055-0-DC2 was accessed - this property has been deprecated and should not be used.
                14-5-2010 22:52:24 - Plug-In - Finished initializing plug-in malk8055


                I have deleted the devices in the homeseer.mdb database. And started homeseer again. But I see the same message in the logging.

                WIN7 Homeseer Pro and hspi_malk8055.ocx version 1.1.0.1

                Can anyone tell me what to do?

                Thanks Wiel
                Last edited by Wiel; May 14, 2010, 04:48 PM. Reason: config added

                Comment


                  There isn't anything you can do, other than ignore the warnings. The plugin was written for an earlier version of HomeSeer and some of the calls/functions it uses are going away. At some point, the plugin will stop working at all when the HS crew remove support for those deprecated calls.

                  Comment


                    I believe they are only warning messages and can be disregarded,

                    Go into the setup page in HomeSeer itself, find the setting "Disable obsolete API procedure warning messages:" and set it to Yes and save it.

                    I think that will work anyway.

                    Comment


                      Solved

                      Brain, mrHappy, thanks for the quick response. Appreciated!

                      After starting up HomeSeer-Pro for several times I do not see the message again. Strange but it is true.
                      Perhaps deleting the devices from the Velleman-plugin K8055-0-* helped.

                      For sure I disabled the obsolete API procedure warning messages.

                      Velleman plugin is working fine with Windows 7, HomeSeer-Pro (both on SSD-drive).

                      Thank for help.

                      Best regards, Wiel (The Netherlands)

                      Comment


                        Setting the option to not print the warnings is probably what got rid of them.

                        At some point though, the HomeSeer crew will actually delete the calls/properties that the warnings are about, and old plugins will start throwing fatal errors or just stop working. There won't be any way around that other than updating the plugin, stop using it, or not upgrade the version of HomeSeer you're using.

                        Comment


                          celebrate !

                          Thanks Brian,
                          Today I am happy the Velleman-plugin works ;-)
                          Thanks, Wiel

                          Comment


                            Hello tout le monde !
                            I have the same probleme as Wiel ( the digital inputs don't work in homeseer).
                            Where can i find the version hspi_malk8055.ocx version 1.1.0.1 of the plugin ?
                            I downloaded and installed the plugin (first page) and homeseer say that the version is 0.0.0.1
                            Thx
                            Jul

                            Comment


                              masterjul
                              Try clicking them all off in the status screen for the digital inputs, they should then respond to inputs, you just need to set them to off first.

                              Comment


                                Thx for your answer Mrhappy.
                                I try it but it doesn't work.
                                I tested the card with K8055_demo program in the CD and it works fine (Input and output devices).
                                But in homeseer there are only the output devices working.
                                The problem is maybe with the plugin version ?
                                Is a newer version than 0.0.0.1 existing ?
                                Thx
                                Jul

                                Comment

                                Working...
                                X