No announcement yet.

Velleman K8055 Plugin V1.0.0

  • Filter
  • Time
  • Show
Clear All
new posts

    OK - VPN back to home was up - and I have cut a recompiled version on the OCX - I am thinking that there is some mix up between older versions and newer versions and I really don't know what is breaking but....

    Try this (backup 1st just in case)

    Unregister the existing hspi_malk8055.ocx file, then rename it to something else - like "notworkingmalk8055.ocxnot"

    Unregister the mcsxap ocx
    Re-register the mcsxap ocx (assuming mcsxap is an ocx)

    Try HS - does mcsxap work/start OK?
    Shutdown homeseer

    Unzip the attached ocx into the homeseer directory - register it

    Try HS again

    NOTE: No functionality changes in this version, just a recompile with the compatability stuff turned off to make it create a new guid.

    Let me know....

    Attached Files


      Hi Malarcy..

      Thanks for the advice... gave it a go... and got this....

      5/7/2006 9:14:33 PM ~!~Info~!~Initializing Plug-in: malk8055
      5/7/2006 9:14:33 PM ~!~COM Plugin~!~Calling InitIO
      5/7/2006 9:14:33 PM ~!~COM Plugin Info~!~malk8055 initialising...
      5/7/2006 9:16:44 PM ~!~Error~!~Initializing interface: malk8055->The remote procedure call failed.
      5/7/2006 9:16:44 PM ~!~Info~!~Done initializing plug-in malk8055
      5/7/2006 9:16:44 PM ~!~Info~!~Initializing Plug-in: mcsXap
      5/7/2006 9:16:44 PM ~!~Error~!~Initializing interface: mcsXap->The RPC server is unavailable.
      5/7/2006 9:16:44 PM ~!~Info~!~Done initializing plug-in mcsXap

      Going to restore from backup and try again... just to be sure...

      Will keep going.... gotta get this working.....



        What if you remove my plugin altogether - does mcsxap work then?



          Hi there...

          Removed your plugin and mcs is working fine.. how strange...

          I did post a question re debugging and was told that if the house code was duplicate a plug in may fail...

          What and how do house codes get allocated? Could this be it?



            Hi Malarcy

            Well... I have now spent about 30hours on this and am at a loss!

            To summarise... and sorry for the long post...

            Pre-Prod server(!)
            OS Windows Server 2003 SP1
            Symantec Antivirus
            MS Windows defender antispyware
            8055 board works great in Velleman diags/demo
            Plugin works on "spare" test Homeseer 2041 installation
            One funny with it - D1 appears as house code A1 while all others are [x

            Production server
            HS 2041
            Windows Server 2003 SP1
            Symantec Antivirus
            MS Windows defender antispyware
            8055 works fine in velleman diags/demo

            5/14/2006 3:10:07 PM - COM Plugin Info - malk8055 initialising...
            5/14/2006 3:10:07 PM - COM Plugin - Calling InitIO
            5/14/2006 3:10:07 PM - Info - Initializing Plug-in: malk8055

            At HS start, HS server "hangs" waiting for malk8055

            If I terminate hs_compatibility.exe then HS starts as expected, minus 8055 obviously.

            Tried all three versions of the plugin, including unregistering the ocx each time.

            Tried disabling all other plugins in setup/interfaces

            Tried unregistering other plugins and deleting the ocx/dll from the HS directory.

            AGH.... no hair left.....


            made a copy of the HS directory tree..

            Went into add/remove and uninstalled HS2


            Ran a registry cleaner... deleted everything i could find re HS... inc all the OCX and DLLs that were registed and no longer around...


            Installed 2041 from original download & rebooted.

            Started HS and runs as expected.

            Stopped HS, installed the 8055 plugin, and registered it.

            Restarted HS....

            Hangs at the same point as above... kill hs_compatibility and HS initialised as normal... but no 8055 before.

            So... questions... and not in order....

            8055 Plugin

            The config never opens a window when clicked - only records an event in log... checked that no windows were behind others.

            Logging... when a button is pressed on the digital input, nothing gets logged in the log. If i refresh the status screen... the update time is updated correctly. How can I get every event in the log?

            Where does the plugin store its configuration? I want to have a look why it gets input 1 wrong on the server that works....

            Given that de-installing HS leaves bits lying around... inc the registration details... where does HS store all its bits!?!?

            You mentione din an earlier post that you have a debug version - would that log more so we could see why its failing to init?

            I really dont want to toast this server to get this working.... there is so much stuff on it - doing a reconfig fom the ground up is unthinkable!

            My plan B is to go back to running HS in a windows XP VM... at least the host OS is preserved!!

            Last edited by Bestgear; May 14, 2006, 10:55 AM.


              Been out of town for a few days - so give me some time to digest - to answer the 1st one HS provides a function to get the next available housecode, so if something is using "[" you get something else - that said - I have tested that bit of code on my systems and that seems to work.

              If mcsxap is working, delete all the velleman related devices, then run up my plugin again, see if it grabs a new code I can imagine that there could be some interesting results if 2 plugins are trying to fiddle with the same devices.

              I have added some debug around the initio call - message boxes should popup - tell me what you see - there may be 4 or 5

              myplugin uses the savesetting function so it's got it's values under

              HKEY_CURRENT_USER\Software\VB and VBA Program Settings\

              It's very wierd if the one of the devices pops up under an A housecode - so deleting the devices and starting again with the velleman setup may be the way forward

              Attached Files


                Hi Malarcy

                Any progress on the 4 adres version ?

                Lookingfwd to be "updated" hihihi


                  Progressing but slowly - working on it but I have also just rebuily my entire home setup - running all my world on a dual core machine with vmare - 6 virtuals including homeseer, regarded adsl - getting around 6meg downloads now and a new router..... so been busy with my setup.

                  Will keep you posted




                    Glad you have joined the VMware world... I assume you are using VM server?

                    I have managed the migration and deployment fo some 80hosts and 1400 virtual machines at work... using ESX of course...

                    Wish we had this stuff years ago!

                    My home VM hosts are great, just with I could get Geovision in a VM too... but cannot obviously due to the hardware dependancy.

                    I have a ripe subnet at home and Vm lets me have everything i want in my DMZ... and cust down the noise/heat/power of all these damn PCs that we all have running 24/7!! I have two hosts permanently running... one DMZ and one inside.



                      Yup - vmware server is a real winner, we have about 800 hosts running virtual at work, with another 2000 moving onto esx this year.

                      I have gone down to 1 machine from the 4 I had running 24/7 + a media center in the study.

                      Only bottle neck has been disk - but another spindle in the box should solve that.



                        Hi Malarcy...sorry its been a while...

                        RIGHT... bit the bullet and reinstalled 2k3 std edtn,.... did a fresh install...

                        Apart from the usual windows update stuff, I have symantecs AV plus windows defender...oh, and VNC.

                        8055 works great (both of them!) using the velleman demo and the rev 2 dll....

                        Now, with only plain old 2041 Hs, plus your debug plugin running.... at HS startup I get....

                        In INITIO - Starting
                        In INITIO - about to call InitHW with port=1

                        After that, hs_compatibility goes to 98% cpu and sits there... killing it obviously lets HS continue to startup...

                        The HS log sits with...

                        COM plugin info malk8055 initialising...

                        So... no xap.. and Im back to the dark ages and no HS until I can get this sorted and walk myself forwards again piece by piece.

                        I just cannot understand it.... I have seen it work once on another server...

                        Brought up a plain old XP vm (last tests were physical) with avg and windows VNC and same again - same hang point as the physical 2k3 box.




                          Just don't get it - I'll dig in the code and see where it goes next - been working on the multiboard version this week - but need to get this sorted - will try and get some time on it this week



                            Actually - just re-read - has your new setup got mcs in it?



                              Hi Malarcy

                              Like you say, I just dont get it!!!

                              I have just finished rebuilding the box again...physical....

                              It has... 2k3 server from a newly downloded ISO from microsoft...

                              no drivers added other than what windows found on the distribution cd at install time.

                              The motherboard has now been changed too... from a PCchips M810 to a M848 which I know to be great motherboards (for the money) and reliable - my geovision runs ona M848 for the last 2 years with zero hangs/reboots)

                              I have changed the ram too... although I knew it would makr no difference!

                              So, after a rebuild... copies the files from the velleman cd to system32. Ran the demo and checked the boards works fine - all ok. I use dthe mk2 dll as I have done before...could this be the problem? I had used the original mk1 dll ages ago... and it still did not work... The hspi compatibility goes to 99% and game over....

                              I have not just built the server back up again with Av/drivers/vnc/etc... and its still broken...agh!! Should I load the motherboard usb drivers? all usb devices I have work ok with windoes defaults... printer, hd etc... (did remove them all when testing the k8055)

                              I really am at my wits end..... next plug is buy you beer for a .net version...

                              My last hope is the velleman dll... I am assuming that it all lives in system32 - and does not need any registering... although when I did try once, it did not work... said no entry point from memory...

                              Anyway - how is the multi board version doing? I bought another board (sucker!) and built it, ready and waiting....

                              Being 2k3, I had to install IIS to get the framework... then stopped/disabled the service from starting - HS web interface starts and runs ok....

                              I really appreciate your help... it must be something very stupid I am doing now... especially when the VM of Xp did not cut it....



                                ..meant to add...

                                The HS install was a std 2041 install from a single exe... no plug or addins...

                                Also, there is no xap hub or gubbins....