Announcement

Collapse
No announcement yet.

Library 'Scheduler.dll' could not be found when running any scripts

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Library 'Scheduler.dll' could not be found when running any scripts

    So i have Linux HS3 installed on a pi3, I have started with some basic scripts to start learning but every time i get an error.

    I have tried with the most basic immediate script command i can think of (&hs.WriteLog "Test", "Hello World!") but no luck.



    Anyone know whats happening or not happening here.

    Regards Chris

  • #2
    The correct script format would be:

    &hs.writelog("Test","Hello World")
    Jon

    Comment


    • #3
      Thanks jon00. Good spot, however, with the now correct script i still get the same error.

      Click image for larger version

Name:	UntitledA.png
Views:	1
Size:	18.8 KB
ID:	1237166

      Comment


      • #4
        Try:

        &nhs.writelog("Test","Hello World")
        Jon

        Comment


        • #5
          Thanks but no luck still

          Comment


          • #6
            How are you starting the HS3 application? It should be started from the installation root directory, which is where the Scheduler.dll file is located.

            Comment


            • #7
              Originally posted by zwolfpack View Post
              How are you starting the HS3 application? It should be started from the installation root directory, which is where the Scheduler.dll file is located.
              Thanks xwolf, you might be on the right track. Although i may have to do a crash course in Linux first as its a bit beyond me at this stage. I was just excited I initially got it working in the first place, mainly through trial and error. Cant even remember how i got it to start automatically.

              Thanks everyone for your help

              Chris

              Comment


              • #8
                When i open the application via SSH using 'cd HomeSeer' then 'sudo ./go' everything works and scripts run fine. But this requires the SSH console screen to be open all the time.

                When i open via SSH using 'sudo mono /home/pi/HomeSeer/HSConsole.exe &' everything works except for scripts and i get the same error again.

                The 'Scheduler.dll' is located in the /home/pi/HomeSeer/ directory.

                --------------------
                I just tried 'sudo mono /home/pi/HomeSeer/HSConsole.exe' (without the ampersand) and it is now working as it should.
                Does the ampersand Matter?
                Last edited by Pricey1985; July 31st, 2018, 01:10 AM.

                Comment


                • #9
                  Do you have it starting automatically now? There are several ways that can be done, so if you've got something semi-operational, lets figure out that out and try to fix it.

                  It's usually done either from /etc/rc.local (older method), or through a startup script in either /lib/systemd/system/ or /etc/init.d/. Does this ring any bells?

                  Comment


                  • #10
                    When i manually start it with 'sudo mono /home/pi/HomeSeer/HSConsole.exe' everything works fine, including scripts.

                    I added 'sudo mono /home/pi/HomeSeer/HSConsole.exe' to '/etc/rc.local' before the 'exit 0' line, It now starts automatically but im back to it not running scripts again and gives the error above, but all other functions work.

                    I just went to remove that line i added in rc.local but now its saying " '/etc/rc.local' : file does not contain a valid CIL image"

                    Its truly testing my patience.

                    Comment


                    • #11
                      Change /etc/rc.local to resemble this
                      Code:
                      #!/bin/sh -e
                      #
                      # rc.local
                      #
                      # This script is executed at the end of each multiuser runlevel.
                      # Make sure that the script will "exit 0" on success or any other
                      # value on error.
                      #
                      # In order to enable or disable this script just change the execution
                      # bits.
                      #
                      # By default this script does nothing.
                      
                      # Print the IP address
                      _IP=$(hostname -I) || true
                      if [ "$_IP" ]; then
                        printf "My IP address is %s\n" "$_IP"
                      fi
                      
                      export LANG=en_US.UTF-8
                      cd /home/pi/HomeSeer
                      mono HSConsole.exe
                      exit 0
                      Note only change from distribution is addition of the 3 lines before 'exit 0'.

                      Comment


                      • #12
                        That worked a treat. Starts automatically and I can run scripts without getting an error.

                        Thanks so much for your patience, we have a good community on here.

                        Comment

                        Working...
                        X