Announcement

Collapse
No announcement yet.

HomeSeer HSM200 Z-Wave Multi-Sensor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HomeSeer HSM200 Z-Wave Multi-Sensor

    How do I control the color of the HomeSeer HSM200 Z-Wave Multi-Sensor light though scripting using .vb?
    Kirk

    http://cleverhouseautomation.ca
    http://southcoastwebsitedesign.ca

    #2
    Originally posted by ldragon99 View Post
    How do I control the color of the HomeSeer HSM200 Z-Wave Multi-Sensor light though scripting using .vb?
    You would use CAPI to send a command to it:

    Code:
    hs.CAPIControlHandler(hs.CAPIGetSingleControl(targetDev, true, "Green", false, false))
    Cheers
    Al

    PS Replace targetDev with the reference ID of the color child device
    HS 3.0.0.548: 1990 Devices 1172 Events
    Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

    Comment


      #3
      Hate to hijack a thread, but since the original question has been answered... How do you find the reliability of the HSM200? I purchased one a couple of months ago and it does not seem very stable. It switches from reporting lumens to percentage of light (huh?) and has stopped reporting any status several times, requiring it to be unplugged and plugged back in. Since this is in a second house that's not normally occupied it's frustrating to say the least.
      HS Pro 3.0 | Linux Ubuntu 16.04 x64 virtualized under Proxmox (KVM)
      Hardware: Z-NET - W800 Serial - Digi PortServer TS/8 and TS/16 serial to Ethernet - Insteon PLM - RFXCOM - X10 Wireless
      Plugins: HSTouch iOS and Android, RFXCOM, BlueIris, BLLock, BLDSC, BLRF, Insteon PLM (MNSandler), Device History, Ecobee, BLRing, Kodi, UltraWeatherWU3
      Second home: Zee S2 with Z-Wave, CT101 Z-Wave Thermostat, Aeotec Z-Wave microswitches, HSM200 occupancy sensor, Ecolink Z-Wave door sensors, STI Driveway Monitor interfaced to Zee S2 GPIO pins.

      Comment


        #4
        Perfect. That has got it.
        Kirk

        http://cleverhouseautomation.ca
        http://southcoastwebsitedesign.ca

        Comment


          #5
          I have not had any issues with it Reidfo. I have only had it a week or so though and just started playing with it.

          I will reply back if I do find that any of that starts happening
          Kirk

          http://cleverhouseautomation.ca
          http://southcoastwebsitedesign.ca

          Comment


            #6
            Originally posted by reidfo View Post
            Hate to hijack a thread, but since the original question has been answered... How do you find the reliability of the HSM200? I purchased one a couple of months ago and it does not seem very stable. It switches from reporting lumens to percentage of light (huh?) and has stopped reporting any status several times, requiring it to be unplugged and plugged back in. Since this is in a second house that's not normally occupied it's frustrating to say the least.
            Have you updated the firmware? I've had one for quite a while now and everything works well for me except the luminosity which stopped working for me after the firmware upgrade. Since I really was only using the motion sensor and the light as a status indicator, I haven't done much troubleshooting for that.

            Cheers
            Al
            HS 3.0.0.548: 1990 Devices 1172 Events
            Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

            Comment

            Working...
            X