Announcement

Collapse
No announcement yet.

Updated Mono to 6.8.0.105 now scripts don't compile

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Updated Mono to 6.8.0.105 now scripts don't compile

    I updated mono from 4.2.1 to 6.8.0.105 so that the device pages in HS4 would display properly. Now my scripts no longer compile even in HS3. I get the following compile error when executing an event that has a script:
    Compiling script /usr/local/HomeSeer/scripts/somfy.vb: Visual Basic.Net Compiler version 0.0.0.5943 (Mono 4.0.1 - tarball) Copyright (C) 2004-2010 Rolf Bjarne Kvinge. All rights reserved. /tmp/6iudzro4.0.vb (2,16) : warning VBNC40056: Namespace or type specified in the Imports 'System.Core' doesn't contain any public member or cannot be found. Make sure the namespace or the type is defined and contains at least one public member. Make sure the imported element name doesn't use any aliases. /tmp/6iudzro4.0.vb (87,77) : error VBNC99999: Internal compiler error close to this location vbnc : Command line : error VBNC99999: Unexpected error: The method or operation is not implemented. at vbnc.CecilHelper.InflateType (Mono.Cecil.TypeReference original, Mono.Collections.Generic.Collection`1[T] parameters, Mono.Collections.Generic.Collection`1[T] arguments
    I get the same errors in both HS3 & HS4.
    I don't know how to proceed from here.

  • #2
    Never Mind. There was a problem with the Linux release update when I went from 16.04 to 18.04. Once I straightened that out, mono worked fine.

    Comment

    Working...
    X