Announcement

Collapse
No announcement yet.

The Include Files

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    The Include Files

    Discussion, problems, etc. for the new include files.

    Jeff Farmer

    --
    Jeff Farmer
    HS 3, HSPhone
    My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
    Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

    Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

    #2
    Jeff et al.

    Thanks for the work on the Include Files. I downloaded them last night and all of my scripts and pages seem to be working fine.

    I see that lots of work went into them.

    I like the extra features like the time in the tips window.

    Comment


      #3
      for those of us wondering what they are talking about, look here
      [img]/infopop/emoticons/icon_cool.gif[/img]

      Thanks for the people contributing to this library of handy functions.
      They DO set a new standard in spartan documentation ;-) though.

      ----------------------------
      Robert's Audrey pages
      http://www.canoma.com/audrey
      http://www.canoma.com/audrey/controlpanels

      Comment


        #4
        CFGuy,

        I'm not sure my includes.ini is up to date. I see some requests that don't seem to be in mine, and I dont think my setup page is right.
        Is there a chance that includes.txt is available in "generic" form?

        -System Spec------
        ASUS A7V333ARU VIA KT333 MOTHERBOARD; AMD ATHLON XP PROCESSOR 2200+ (1800MHz); 1024MB DDR 333MHz DDRAM; ATI RAGE 128 CHIPSET 32MB W/ TV OUT VGA CARD; AHANIX PLATINUM XP SILVER/BLACK COLOR 9 DRIVE BAYS SPI 300W POWER SUPPLY TOOL-LESS PANELS ATX MID TOWER CASE; Win2K SP2 5Serial 1Parallel, Hawking Modem, Broadband >Mediacomm, Phillips Audio, ATT Voices, PhoneSwitch, 10/100 Ethernet, Ocelot for IR and Bobcats, CM11A for X10
        -------------
        GenevaDude

        Comment


          #5
          Opps, forgot to post to the docs.

          http://www.c-website.com/securelinks5.htm

          GenevaDude
          If you have an includes.ini then you have the most current. The ini is new with this release of the includes. The idea was to allow you to set the defaults rather than me making that decision and hard coding them in.
          The ini file is in the Homeseer config directory.

          Jeff Farmer

          --
          Jeff Farmer
          HS 3, HSPhone
          My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
          Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

          Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

          Comment


            #6
            Setup_Includes.asp seems to have a problem with the first radio-button. Selecting Use Security: Yes leaves No on as well. Saving and reloading - it goes back to No.

            --Bill

            Comment


              #7
              I see what is causing it. I'll fix this tonight and post it.

              Jeff Farmer

              --
              Jeff Farmer
              HS 3, HSPhone
              My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
              Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

              Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

              Comment


                #8
                I'm getting this error when loading the setup_includes.asp file:

                Script error: [Microsoft][ODBC Microsoft Access Driver] Undefined function 'GetDate' in expression.

                I checked (& double checked) the ODBC setup and it seems to be okay.

                Replaced the customhs2k.mdb with a freshly downloaded one.

                Thanks

                Comment


                  #9
                  Looks like you have SQL server set somewhere. Check in the ini file - websettings.ini and look for this line.
                  dbtype=

                  Make sure it has the value of Access
                  dbtype=Access

                  Jeff Farmer

                  --
                  Jeff Farmer
                  HS 3, HSPhone
                  My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                  Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                  Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                  Comment


                    #10
                    I am in the process of installing the new includes. I changed the menu edit to the new one and it just spills the page at Script error: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified.
                    I have tried to set web_settings.ini to no avail.
                    here are the lines.....

                    [Settings]
                    dbpath=c:\homeseer
                    dbname=HomeSeer_2000.mdb
                    dbusername=
                    dbpassword=
                    dbserverip=http://moo:8383
                    rowstyle=Link
                    usesecurity=True
                    linkfileext=htm
                    dbtype=access
                    hsip=
                    exthsip=v1
                    footerlinkrule=Same
                    useslideinmenu=No
                    audreyrowstyle=Image
                    fpoptimeout=20
                    fpopport=110
                    touchscreenips=
                    usesound=True
                    showhsversion=No
                    showhssystime=No
                    logpagehits=1
                    [Device Admin]
                    Device_Hide=1
                    col_Status=1
                    col_Status_Level=10
                    col_Code=1
                    col_Code_Level=10
                    col_Locations=0
                    col_Locations_Level=10
                    col_Dev_Type=0
                    col_Dev_Type_Level=10
                    col_Last_Change=1
                    col_Last_Change_Level=10
                    col_Edit=1
                    col_Edit_Level=10
                    col_Control=1
                    col_Control_Level=10
                    col_Events=0
                    col_Events_Level=10
                    col_String=0
                    col_String_Level=10
                    Device_Hide_Level=10

                    I'm sure my formatting or syntax is wrong..
                    All other older include pages still work with the settings tha are in maininclude.asp and DSNString.vbs


                    ...............JG
                    HS2PRO - Ocelot, SecuIR, Secu16, Attendence Management Alarm Interface, X-10, LCD Studio VFD Display, 3 Apexis IP Cams, Custom Software Interfaces, GMQ Geiger Graphing
                    HS3PRO - Testing

                    Comment


                      #11
                      Bill,
                      Here is the fix for the Security setting.

                      Jeff Farmer

                      Attached Files
                      --
                      Jeff Farmer
                      HS 3, HSPhone
                      My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                      Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                      Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                      Comment


                        #12
                        Jebus, change dbtype=access to dbtype=Access

                        Jeff Farmer

                        --
                        Jeff Farmer
                        HS 3, HSPhone
                        My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                        Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                        Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                        Comment


                          #13
                          Jeff, that fixed it. I think I figured out how it happened. . Using a 'wheel' mouse; I was on the setup page the other day and selected that field and I must have jogged my wheel at some point and didn't notice.

                          Could you help with this error?

                          Script error: Type mismatch: 'GetDBValues'

                          I get this anytime I select any of the 'Device' links . . .

                          Also, something that is driving me crazy: Any link that I select from the "Homeseer Links" want to go to either /hs/pagename.asp or /control/pagename.asp. . . of course the pages aren't in the html/hs or html/control directories, so the links are broken. Would you point me in the right place to fix this?

                          Thank you -

                          Comment


                            #14
                            To the the new includes to work for everyone, I moved some functions around.
                            Download http://www.c-website.com/securelinks.zip and replace any of the files that you get errors on.
                            Make sure you have put all of the new includes into the includes directory. Expecially db_functions.asp.

                            Jeff Farmer

                            --
                            Jeff Farmer
                            HS 3, HSPhone
                            My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                            Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                            Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                            Comment


                              #15
                              For everyone reading this thread the links that cxl99 is refering to is part of Secure Links not the includes.

                              cxl99, there is an edit page for the links.
                              menu_editor.asp
                              You can either delete the links that you aren't using or you can edit them to be pointing to the correct directory for where those files are.

                              Jeff Farmer

                              --
                              Jeff Farmer
                              HS 3, HSPhone
                              My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                              Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                              Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                              Comment

                              Working...
                              X